Newly installed applications are not showing in "Installed"

Bug #1742997 reported by AsciiWolf on 2018-01-12
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GNOME Software
Expired
Medium
gnome-software (Ubuntu)
Low
Unassigned
Bionic
Low
Robert Ancell
packagekit (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Impact]
Removing and installing an app stops it showing in the installed apps page.

[Test Case]
1. Open GNOME Software
2. Go to installed tab
3. Click on an installed app
4. Remove this app
5. Install this app
6. Click back button to return to installation page.

Expected result:
App shows on page.

Observed result:
App does not show on page.

[Regression Potential]
Change is small, and just fixes and ordering issue. Unlikely to trigger other major issues.

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in gnome-software (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

what Ubuntu serie and gnome-software version are you using?

AsciiWolf (asciiwolf) wrote :

I am using Ubuntu 18.04 with gnome-software-3.26.3-2ubuntu1. I am not sure if this is an upstream issue, it does not happen on any of my Fedora machines.

Changed in gnome-software (Ubuntu):
status: Incomplete → New
Sebastien Bacher (seb128) wrote :

Could be an issue in the aptd plugin or the aptcc packagekit backend...

Changed in gnome-software:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in gnome-software:
status: Confirmed → Expired
Changed in gnome-software (Ubuntu):
status: New → Triaged
AsciiWolf (asciiwolf) wrote :

Can someone test if this still an issue?

Olivier Tilloy (osomon) wrote :

I can reliably observe the issue on bionic. Not on cosmic.

Changed in gnome-software (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-software (Ubuntu Bionic):
status: New → Confirmed
Changed in gnome-software (Ubuntu Bionic):
importance: Undecided → Low
assignee: nobody → Olivier Tilloy (osomon)
Changed in packagekit (Ubuntu):
status: New → Invalid
Changed in packagekit (Ubuntu Bionic):
status: New → Invalid
Olivier Tilloy (osomon) wrote :

Can still reproduce on bionic, not on cosmic. Killing gnome-software and running it again is enough to "fix" the issue (because the list of installed applications is being refreshed at startup).

Changed in gnome-software (Ubuntu Bionic):
assignee: Olivier Tilloy (osomon) → Robert Ancell (robert-ancell)
Robert Ancell (robert-ancell) wrote :

I was reproducing this, but when I added instrumentation it started working. It does reproduce in a VM, so will keep investigating. The code that adds the installed apps to the installation page seems fairly robust, so not sure what might be breaking it.

On a fresh installed Ubuntu 19.10 Eoan with Gnome software 3.30.6-2ubuntu3
I installed: synaptic, gparted, Gnome-tweaks, stellarium, GIMP
then I Switch to the "Installed" tab and:
ONLY Gnome-tweaks and stellarium are visible as installed
also closing and restarting Gnome software does not change the situation
killing gnome software and restarting solves the problem

Changed in gnome-software (Ubuntu Bionic):
status: Confirmed → Triaged
status: Triaged → Confirmed
Robert Ancell (robert-ancell) wrote :

I've managed to find a bug that stops apps appearing in the installed list when they are *reinstalled*.

To reproduce:
1. Open GNOME Software
2. Go to installed tab
3. Click on an installed app
4. Remove this app
5. Install this app
6. Click back button to return to installation page.

The app won't show in the installation page, this is because the app row was animated to collapse, but not removed. When the app is installed again G-S thinks the row is already there and it doesn't show it.

If you've had G-S open for a long time then you might be installing an app you had previously installed at launch time or after.

Can anyone reproduce this issue with an app that was *not* previously installed?

Robert Ancell (robert-ancell) wrote :

Note that this bug occurs on all versions of GNOME Software.

Changed in gnome-software (Ubuntu Bionic):
status: Confirmed → Triaged
description: updated
Changed in gnome-software (Ubuntu Bionic):
status: Triaged → Fix Committed

Hello AsciiWolf, or anyone else affected,

Accepted gnome-software into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.28.1-0ubuntu4.18.04.12 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-bionic
Robert Ancell (robert-ancell) wrote :

Confirmed in bionic that gnome-software 3.28.1-0ubuntu4.18.04.12 after removing and re-installing moon-buggy it shows in the installed page.

tags: added: verification-done-bionic
removed: verification-needed verification-needed-bionic

The verification of the Stable Release Update for gnome-software has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.28.1-0ubuntu4.18.04.12

---------------
gnome-software (3.28.1-0ubuntu4.18.04.12) bionic; urgency=medium

  * debian/patches/0001-Fix-apps-that-were-previously-uninstalled-from-not-s.patch:
    - Fix apps that are reinstalled from disappearing from installed page
      (LP: #1742997)

gnome-software (3.28.1-0ubuntu4.18.04.11) bionic; urgency=medium

  * debian/patches/0031-shell-Don-t-progate-CTRL-F-key-pressed-event.patch:
    - Fix Ctrl-F not opening search bar (LP: #1735071)
  * debian/patches/0014-Add-a-basic-permissions-system.patch:
    - Fix interface connections not showing correct state (LP: #1806697)
  * debian/patches/0017-snap-Use-default-icon-if-none-provided.patch:
    - Update default snap icon (LP: #1818920)
  * debian/patches/0032-snap-Update-Snap-store-category-mapping.patch:
    - Update snap store categories (LP: #1836826)

 -- Robert Ancell <email address hidden> Tue, 17 Sep 2019 09:49:03 +0200

Changed in gnome-software (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.