GNOME Software app not shown as "Ubuntu Software" in Unity 17.10

Bug #1731296 reported by Jeremy Bicha
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
Confirmed
Low
Unassigned

Bug Description

Test Case
=========
Install Ubuntu 17.10.
sudo apt install unity
Restart your computer.
On the login screen, click your name then click the gear button and select Unity. Log in.
In the Launcher on the left side of the screen, GNOME Software is shown but not Ubuntu Software

Background Info
===============
There is an interesting per-desktop override feature. The primary .desktop is installed as /usr/share/applications/org.gnome.Software.desktop . That .desktop file can be overriden for the ubuntu desktop by shipping /usr/share/applications/Ubuntu/org.gnome.Software.desktop or for the gnome desktop by shipping /usr/share/applications/gnome/org.gnome.Software.desktop.

Until now, this override was only done for the Ubuntu session (which in 17.10 is no longer Unity).

Proposal #1
===========
Have the ubuntu-software packaging install the override .desktop to /usr/share/unity/applications/ too.

Proposal #2
===========
Have the ubuntu-software packaging install the override .desktop to /usr/share/FOO/applications/ where FOO is every desktop session in Ubuntu. Then it's up to users and flavors whether they want the Ubuntu or GNOME branding based on whether they install the ubuntu-software package.

Proposal #3
===========
Rework the packaging to install the Ubuntu Software .desktop to /usr/share/applications/
Install the GNOME Software .desktop to /usr/share/gnome/applications/ so that GNOME (as in the vanilla GNOME session) alone gets the GNOME branding.

In this case, the ubuntu-software package is not needed any more (after a transitional period for upgrades).

The question is whether there is any reason why someone not using vanilla GNOME would want the GNOME branding instead of the Ubuntu branding.

Tags: bionic artful
Jeremy Bicha (jbicha)
description: updated
Changed in gnome-software (Ubuntu):
importance: Undecided → Low
Revision history for this message
Khurshid Alam (khurshid-alam) wrote :

I like proposal #1. Ubuntu-software is not unity specific but rather Ubuntu specific. Other desktop-shell may want to use that Ubuntu branding. If they want that they only need to provide a override in /usr/share/<other-session>/applications/ & install ubuntu-software. But only if they want. So we can dismiss #2 as it would be over-patching things.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu):
status: New → Confirmed
Revision history for this message
Sebastien Bacher (seb128) wrote :

That got fixed before 17.10 iirc

Changed in gnome-software (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Jeremy Bicha (jbicha) wrote :

Seb, I'm reopening this bug since it is still not fixed. It is not a problem for the default Ubuntu session but for every other desktop session such as Unity. I haven't fixed it yet because there are several ways to fix it and I wasn't sure which option we want.

tags: added: artful bionic
Changed in gnome-software (Ubuntu):
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers