GNOME Shell Extensions subcategory is empty in GNOME Software

Bug #1722809 reported by AsciiWolf on 2017-10-11
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
GNOME Software
Fix Released
Medium
gnome-software (Ubuntu)
Low
Unassigned
Artful
Low
Unassigned

Bug Description

Impact
======
In the Ubuntu/GNOME Software app, the Addons > Shell Extensions category is empty. This makes it really difficult to browse for GNOME Shell extensions.

Test Case
=========
Install the update.
Run Ubuntu/GNOME Software
It should prompt your to reload the Software app itself since it has been updated. (Or log out and log back in.)
On the home screen, click Addons. Click Shell Extensions.
It should show a list of available extensions after a few moments.

Regression Potential
====================
This minimal patch was cherry-picked from the gnome-3-26 stable branch. Fedora 27 applies the patch.

Other Info
==========
The issue is that GNOME Software limited results to 500 but there are more than 800 Shell Extensions now. Maybe in the future, there should be some pagination or organization instead of a massive alphabetical list of extensions.

Workaround
==========
You can still look up and install a special GNOME Shell extension if you search for it.

Original Bug Report
===================
The Shell Extensions subcategory in GNOME Software is empty. I am using the latest (3.26.1-0ubuntu1) GNOME Software package.

Sebastien Bacher (seb128) wrote :

Where do you see that subcategory? Searching for extensions returns results here

Jeremy Bicha (jbicha) wrote :

On the homepage, click Add-ons, then click Shell Extensions.

Changed in gnome-software (Ubuntu):
status: New → Confirmed
summary: - GNOME Shell Extensions cannot be installed using GNOME Software
+ GNOME Shell Extensions subcategory is empty in GNOME Software
tags: added: rls-aa-incoming
Jean-Baptiste Lallement (jibel) wrote :

From the journal:

gnome-software[15929]: failed to get apps for category apps: too many results returned

Sebastien Bacher (seb128) wrote :

oh ok, you have a small arrow to display more categories, that's not obvious ... bug confirmed indeed

Iain Lane (laney) on 2017-10-12
tags: added: rls-aa-notfixing
removed: rls-aa-incoming
Iain Lane (laney) wrote :

Valid bug, but I don't think we'll commit to fixing for the release.

I forwarded it upstream.

As it happens, I've been looking at this a bit already, hopefully should be fixed in a future 3.26 release. :D

Changed in gnome-software (Ubuntu):
importance: Undecided → Medium
Changed in gnome-software:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in gnome-software (Ubuntu):
status: Confirmed → Triaged
importance: Medium → Low
AsciiWolf (asciiwolf) wrote :

I think this bug should not be classified as low importance bug, because it prevents users from installing GNOME Shell extensions.

Jeremy Bicha (jbicha) wrote :

The workaround is to just search for the extension you want instead of browsing all ~800 in a giant list.

Jeremy Bicha (jbicha) on 2017-10-28
Changed in gnome-software (Ubuntu Artful):
importance: Undecided → Low
status: New → Triaged
Changed in gnome-software (Ubuntu):
status: Triaged → Fix Committed
Jeremy Bicha (jbicha) on 2017-10-28
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.26.1-0ubuntu5

---------------
gnome-software (3.26.1-0ubuntu5) bionic; urgency=medium

  [ Jeremy Bicha ]
  * Cherry-pick 0001-Don-t-error-out-for-over-500-results.patch:
    - Fix empty Addons > Shell Extensions category (LP: #1722809)

  [ Michael Biebl ]
  * Cherry-pick upstream fixes to make gnome-software build against fwupd 1.0.
    (Closes: #879006)

 -- Jeremy Bicha <email address hidden> Sat, 28 Oct 2017 09:47:27 -0400

Changed in gnome-software (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-software:
status: Confirmed → Fix Released
Iain Lane (laney) wrote :

Thanks for uploading, but it'd have been good if you'd asked me beforehand (since I mentioned in team meetings I was working on related fixes) - I've got other improvements to Shell Extensions in Software pending. (I think this could have waited for the regular point release?)

Jeremy Bicha (jbicha) wrote :

Iain, I had to do an upload to 'bionic' anyway to finish the fwupd transition.

I didn't do an SRU for artful but forwarded this to Robert who was working on an SRU with some snap fixes. If we don't want to encourage users needing to install chrome-gnome-shell (and a Firefox addon), then I think this fix is important.

Hello AsciiWolf, or anyone else affected,

Accepted gnome-software into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.26.1-0ubuntu2.17.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-software (Ubuntu Artful):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-artful

SRU verification for Artful:
I have reproduced the problem with gnome-software 3.26.1-0ubuntu2 in artful and have verified that the version of gnome-software 3.26.1-0ubuntu2.17.10.1 in -proposed fixes the issue.

Marking as verification-done

tags: added: verification-done verification-done-artful
removed: verification-needed verification-needed-artful
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.26.1-0ubuntu2.17.10.1

---------------
gnome-software (3.26.1-0ubuntu2.17.10.1) artful; urgency=medium

  [ Robert Ancell ]
  * debian/patches/0001-snap-Don-t-crash-on-unknown-snap-types.patch:
    - Fix crash when broken snaps installed (LP: #1720442)
  * debian/patches/0001-snap-Protect-store-cache-with-a-lock.patch:
    - Fix crash due to multiple threads accessing a cache (LP: #1716633)
  * debian/patches/0001-snap-Don-t-attempt-to-refine-snaps-without-a-valid-n.patch:
    - Fix potential crash from invalid snaps
  * debian/patches/0001-snap-Remove-unused-variables.patch:
    - Trivial patch added to make above patches apply cleanly
  * debian/patches/0001-Add-a-cancellable-to-GsApp-objects.patch:
  * debian/patches/0001-Allow-to-cancel-app-ops-in-the-details-view-that-wer.patch:
    - Fix cancelling with multiple installs (LP: #1722183)
  * debian/control:
    - Add Vcs-Bzr link

  [ Jeremy Bicha ]
  * Cherry-pick 0001-Don-t-error-out-for-over-500-results.patch:
    - Fix empty Addons > Shell Extensions category (LP: #1722809)

 -- Robert Ancell <email address hidden> Wed, 15 Nov 2017 11:58:57 +1300

Changed in gnome-software (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-software has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.