Average rating for apps incorrect

Bug #1721419 reported by hants on 2017-10-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
Medium
Unassigned
Xenial
Medium
Unassigned

Bug Description

The average rating for apps in ubuntu-software seems to be calculated incorrectly. For example

"Genius Math Tool" had an average rating of 2 stars and 9 reviews each with 4-5 star rating. So i added another 4 star review. The expected average rating is 4 stars currently a 2 star rating is displayed.

Another package with obviously weird average rating is "Log File Viewer" currently at average 3 star rating. Considering the reviews it should be closer to 4.6.

Further Info:

$ lsb_release -rd
Description: Ubuntu 16.04.3 LTS
Release: 16.04

$apt-cache policy ubuntu-software
ubuntu-software:
  Installed: 3.20.5-0ubuntu0.16.04.6
  Candidate: 3.20.5-0ubuntu0.16.04.6

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubuntu-software 3.20.5-0ubuntu0.16.04.6
ProcVersionSignature: Ubuntu 4.10.0-35.39~16.04.1-generic 4.10.17
Uname: Linux 4.10.0-35-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.1-0ubuntu2.10
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Oct 5 01:51:14 2017
InstallationDate: Installed on 2017-05-22 (135 days ago)
InstallationMedia: Ubuntu 16.04.2 LTS "Xenial Xerus" - Release amd64 (20170215.2)
SourcePackage: gnome-software
UpgradeStatus: No upgrade log present (probably fresh install)

hants (andreowitsch) wrote :
Robert Ancell (robert-ancell) wrote :

This works correctly in Artful, but confirmed the issue in Xenial.

Changed in gnome-software (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Robert Ancell (robert-ancell) wrote :

Was fixed in gnome-software 3.22 (Zesty).

Changed in gnome-software (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-software (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → Medium
Changed in gnome-software (Ubuntu Xenial):
status: Triaged → Fix Committed

Hello hants, or anyone else affected,

Accepted gnome-software into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.20.5-0ubuntu0.16.04.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-xenial
Jean-Baptiste Lallement (jibel) wrote :

SRU verification for Xenial:
I have reproduced the problem with gnome-software 3.20.5-0ubuntu0.16.04.6 in xenial-updates and have verified that the version of gnome-software 3.20.5-0ubuntu0.16.04.7 in -proposed fixes the issue.

Marking as verification-done

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.20.5-0ubuntu0.16.04.7

---------------
gnome-software (3.20.5-0ubuntu0.16.04.7) xenial; urgency=medium

  * debian/patches/0016-Add-a-dpkg-plugin.patch:
  * debian/patches/0017-Add-an-APT-plugin.patch:
    - Fix overflow showing installed size (LP: #1713586)
  * debian/patches/0047-Use-the-developer-name-if-set-in-preference-to-the-p.patch:
    - Backport support for showing developer name
  * debian/patches/0018-Add-a-Snap-plugin.patch:
    - Show snap developer (LP: #1715054)
    - Set correct store name (LP: #1706500)
    - Show license field
    - Send Polkit interactive header (LP: #1736232)
    - Fix crash due to multiple threads accessing a cache (LP: #1716633)
  * debian/patches/0001-ubuntu-reviews-Fix-Wilson-score-calculation.patch:
    - Fix average rating calculation (LP: #1721419)

 -- Robert Ancell <email address hidden> Wed, 06 Dec 2017 10:36:16 +1300

Changed in gnome-software (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-software has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers