Firmware update seemingly not working

Bug #1719797 reported by Merlijn Sebrechts on 2017-09-27
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
fwupd (Ubuntu)
Undecided
Mario Limonciello
Bionic
Undecided
Mario Limonciello
gnome-software (Fedora)
Confirmed
Undecided
gnome-software (Ubuntu)
Medium
Robert Ancell
Bionic
Medium
Robert Ancell

Bug Description

The fix for this particular issue is tracked in SRU bug https://bugs.launchpad.net/ubuntu/+source/fwupd/+bug/1791999

Regression potential:
Fixes for this particular bug would have the risk to manifest in devices not showing up in gnome-software, but this risk is very low.

Test case:
1) Run a UEFI firmware update from Gnome software.
2) Make sure that the update disappears from the listing after pressing the update button.

Original bug:

Ubuntu 17.10

On a dell latitude 5580, the firmware update seems to not work while it actually does.

1. Gnome software reports there is a new firmware update.
2. I click "update now"
3. The update disappears for a few seconds, then reappears.
4. When I reboot my laptop, the laptop goes into firmware update modus, updates the firmware, and starts Ubuntu.

What I expect:

After clicking "update now", Gnome software tells me my computer has to restart the update. Either the update is listed and greyed out with a "reboot required" message, or the update is not visible.

Related branches

tags: added: artful
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. So the issue there is that it fails to restart the machine when acking the dialog that is supposed to do that, right?
What desktop environment are you using? Could you add your syslog after getting the problem?

Changed in gnome-software (Ubuntu):
importance: Undecided → Low
status: New → Incomplete

There seems to be two issues:

1. When clicking "update" on the firmware update, you do not get a notification to restart the machine. I do get a notification if I click the "Update All" button in the top-right corner.

2. After clicking "Update" but before the restart, the update re-appears in the list of updates. This gives me the impression that the update failed. I see two possible solutions: a) don't show the update after the update process has started. b) change the "update" button to a "restart to update" button that prompts to restart the machine on click.

Syslog output: https://paste.ubuntu.com/25793427/

I'm using default Ubuntu 17.10; DE is Gnome. This happens both in Xorg and in wayland session.

Sebastien Bacher (seb128) wrote :

the log has that warning
"Calling org.gnome.SessionManager.Reboot failed: GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._g_2dio_2derror_2dquark.Code19: Operation was cancelled"

Changed in gnome-software (Ubuntu):
status: Incomplete → New
no longer affects: fwupd (Ubuntu)
Mario Limonciello (superm1) wrote :

I've filed that issue upstream.

Changed in gnome-software (Ubuntu):
status: New → Triaged
Mario Limonciello (superm1) wrote :

I suspect it to actually be gnome-session is the problem, but let's see what they say.

Changed in gnome-software:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in gnome-software:
status: Confirmed → In Progress
Changed in gnome-software:
status: In Progress → Expired
Mario Limonciello (superm1) wrote :

That upstream issue has migrated to https://gitlab.gnome.org/GNOME/gnome-software/issues/253. It seems Launchpad can't track it anymore.

Description of problem:
When gnome-software finds a firmware update, and you hit the update button, it is unclear whether the update succeeded, and also unclear that you need to reboot your machine to actually apply the update.

Version-Release number of selected component (if applicable):
gnome-software-3.28.2-1.fc28.x86_64

How reproducible:
Always

Preconditions:
1. Have a machine with non-up-to-date firmware. I had a Dell XPS 13 9370 with the factory firmware.
2. Fresh Fedora 28 installation on said machine.

Steps to Reproduce:
1. Launch gnome-software
2. Go to updates
3. Hit the refresh button
4. Wait for it until it displays an update (in this case a bios update)
5. Click the "Update" button next to the BIOS update

Actual results:
- The update disappears for a while. Then it appears again.
- There is no indication of success
- Also no indication that tells me I should reboot the machine now.

Expected results:
- The update should not appear again
- It should tell me that the update was successful
- It should tell me I need to reboot the machine to apply the bios update

Additional info:
None.

This is the actual upstream issue. The reboot failed log seems to be a red herring.

https://gitlab.gnome.org/GNOME/gnome-software/issues/341

Changed in gnome-software:
importance: Medium → Undecided
status: Expired → New
Mario Limonciello (superm1) wrote :

This issue has been fixed upstream. It requires fixes in both gnome-software and fwupd.

gnome-software fix (on the Gnome Software 3-28 branch):
https://gitlab.gnome.org/GNOME/gnome-software/commit/057eea7cc03d647544b5819ff37951f7bfffb77e

fwupd fix (on the 1_0_X branch):
https://github.com/hughsie/fwupd/commit/80f6e995f68ad7559c4a386a58e9ee43750bf6aa

This is fixed upstream, but will require fixes in both gnome-software and fwupd.

Changed in fwupd (Ubuntu):
status: New → Triaged
Changed in fwupd (Ubuntu Bionic):
status: New → In Progress
Changed in gnome-software (Ubuntu Bionic):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in fwupd (Ubuntu Bionic):
assignee: nobody → Mario Limonciello (superm1)
Changed in gnome-software (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in fwupd (Ubuntu):
assignee: nobody → Mario Limonciello (superm1)
no longer affects: gnome-software
description: updated
Mario Limonciello (superm1) wrote :

fwupd
------
This has been fixed upstream in the 1.1.3 release, so marking the development release task complete.
The 1.0.9 SRU bug for bionic is here: https://bugs.launchpad.net/ubuntu/+source/fwupd/+bug/1791999

gnome-software
------------
There is an SRU in progress for 3.28.1-0ubuntu4.18.04.4 that I don't want to de-rail by uploading a new patch for this bug. Once that one is in https://gitlab.gnome.org/GNOME/gnome-software/commit/057eea7cc03d647544b5819ff37951f7bfffb77e should be added to this SRU bug.

Changed in fwupd (Ubuntu):
status: Triaged → Fix Released
Robert Ancell (robert-ancell) wrote :

Change queued up for gnome-software 3.28.1-0ubuntu4.18.04.5 SRU

Changed in gnome-software (Ubuntu Bionic):
importance: Undecided → Medium
status: New → Fix Committed
Changed in gnome-software (Ubuntu):
status: Triaged → Fix Released
importance: Low → Medium

Hello Merlijn, or anyone else affected,

Accepted fwupd into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/fwupd/1.0.9-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in fwupd (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Brian Murray (brian-murray) wrote :

Hello Merlijn, or anyone else affected,

Accepted fwupd into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/fwupd/1.0.9-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Mario Limonciello (superm1) wrote :

I've tested the fwupd half of this SRU (couldn't test the gnome-software as it's not yet in place). The fwupd half works properly.

tags: added: verification-done-bionic
removed: verification-needed-bionic
tags: added: verification-done
removed: verification-needed
Brian Murray (brian-murray) wrote :

Hello Merlijn, or anyone else affected,

Accepted gnome-software into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.28.1-0ubuntu4.18.04.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-bionic
removed: verification-done verification-done-bionic
Will Cooke (willcooke) wrote :

On Bionic, I'm running:

$ apt-cache policy fwupd
fwupd:
  Installed: 1.0.9-0ubuntu2
  Candidate: 1.0.9-0ubuntu2
  Version table:
 *** 1.0.9-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     1.0.6-2 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages

$ apt-cache policy gnome-software
gnome-software:
  Installed: 3.28.1-0ubuntu4.18.04.5
  Candidate: 3.28.1-0ubuntu4.18.04.5
  Version table:
 *** 3.28.1-0ubuntu4.18.04.5 500
        500 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     3.28.1-0ubuntu4.18.04.4 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
     3.28.1-0ubuntu4 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages

I have a firmware update pending (handy!).

Go to the firmware update tab, click Update on the fwupdate.

After a second or two it tells me that it's done and the update disappears from the list.
Clicking "refresh", the update stays hidden.

Quitting and reloading g-s, the update stays hidden, as expected.

All passed.

tags: added: verification-done-bionic
removed: verification-needed-bionic
tags: added: verification-done
removed: verification-needed
Changed in gnome-software (Fedora):
importance: Unknown → Undecided
status: Unknown → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.