Unable to install flatpakref on Ubuntu artful

Bug #1716409 reported by Alan Pope 🍺🐧🐱 πŸ¦„ on 2017-09-11
92
This bug affects 20 people
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
Medium
Unassigned
Artful
Medium
Unassigned

Bug Description

I saw a news article with a link to install a flatpak.

http://www.omgubuntu.co.uk/2017/09/download-pithos-pandora-app-1-4

I clicked the link expecting to be able to install the flatpak, but the experience appears broken. I'm on an up to date Artful install

What I did was:-

Click on http://www.omgubuntu.co.uk/2017/09/download-pithos-pandora-app-1-4
Click the flathub link:- https://flathub.org/repo/appstream/io.github.Pithos.flatpakref
This downloaded the flatpakref file.
I clicked the file in my browser, nothing happened

I then tried finding the file in nautilus and double clicked it.
GNOME Software launched and presented an error "Don't know how to handle 'file:///home/alan/Downloads/io.github.Pithos.flatpakref' (see screenshot).

If I search for pithos in GNOME Software I am able to find the older version from the deb repo, but not the newer version from flathub.

Do we not support flatpak/flathub out of the box? Or is my system uniquely hosed?

Matthias Klumpp (ximion) wrote :

The GNOME Software Flatpak plugin is not installed by default.
Does installing the `gnome-software-plugin-flatpak` package fix this for you?

You're right that I didn't have that plugin package installed. I installed it and double clicking the package still presents the same error. Apologies I omitted the screenshot in my initial report.

Martin Wimpress (flexiondotorg) wrote :

I installed `gnome-software-plugin-flatpak`.

I had to download the `flatpakref` file, then double click it via the file manager, which caused GNOME Software to spit assorted errors and claims of something going wrong. I was however presented with an Install button which when clicked prompted for a password and then dumped me back at an Install button.

I then searched GNOME Software for 'Pithos' and it found an entry where the source was flathub. I was able to install it by clicking the Install button.

I doubt what I've described is how the installation flatpaks is intended to work. Can someone confirm the intended experience so we can identify what might not be working correctly in Ubuntu?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu):
status: New → Confirmed

I killed gnome-software and tried again, got the same experience Martin did.

Matthias Klumpp (ximion) wrote :

Did you restart GNOME Software after installing the plugin? And with that I mean kill it completely, even its background process.

Screenshots showing me trying to install the pithos flatpak.

Changed in gnome-software (Ubuntu):
importance: Undecided → Low

I had the same error. So I installed gnome-software-plugin-flatpak and flatpak :

$ sudo add-apt-repository ppa:alexlarsson/flatpak && sudo apt update
$ sudo apt install flatpak

But still had the same error. I rebooted and had the install button (with the other error Martin noticed too on #3). Unfortunately that doesn't worked too. I had an other error (the third...) that I attached. Note the installation work from command line.

AsciiWolf (asciiwolf) wrote :

Is this still an issue on Ubuntu 18.04 with gnome-software-plugin-flatpak installed?

Andrew Hayzen (ahayzen) on 2018-03-15
summary: - Unable to install flatpak on Ubuntu artful
+ Unable to install flatpakref on Ubuntu artful
Andrew Hayzen (ahayzen) wrote :

On Ubuntu 18.04 daily with flatpak 0.11.3, gnome-software-plugin-flatpak 3.28.0 I have not been able to reproduce this issue. I did have a separate issue, which looks like a bug in cleanups between versions of gnome-software as removing all apps, remotes and caches resolved the issue - I have reported this upstream https://gitlab.gnome.org/GNOME/gnome-software/issues/328.

On Ubuntu 17.10, with flatpak 0.8.9 (which I am in the process of SRU'ing - bug 1752381) and gnome-software-plugin-flatpak 3.26.1 I am able to reproduce the issue - "failed to get related refs: using origin io.github.GnomeMpv-origin: Remote "io.github.GnomeMpv-origin" not found".

This appears to be an issue with gnome-software-plugin-flatpak, not flatpak itself - I have spoken to hugsie and kalev upstream and they confirmed this. It was also stated that "flatpakrefs in 3.26.1 are known buggy." and "I'd suggest retesting with 3.28.0 or 3.26.7" - 3.28.0 appears to have resolved the issue, 3.26.7 probably needs a SRU? Therefore I am marking this bug as invalid for flatpak.

Furthermore I have added a test for installing flatpakref's with gnome-software to the test plan for future flatpak releases https://wiki.ubuntu.com/Process/Merges/TestPlan/flatpak once this bug has been resolved.

Changed in flatpak (Ubuntu):
status: New → Invalid
Jeremy Bicha (jbicha) wrote :

Could you split the cache upgrade issue into a separate Launchpad bug?

We'll keep using this bug to track the clean install issue that only affects Ubuntu 17.10.

no longer affects: flatpak (Ubuntu)
Changed in gnome-software (Ubuntu Artful):
importance: Undecided → Low
status: New → Triaged
Changed in gnome-software (Ubuntu):
status: Confirmed → Fix Released
Andrew Hayzen (ahayzen) wrote :

@jbicha, sure reported an issue here to track the potential cache upgrade issue with 3.28 https://bugs.launchpad.net/ubuntu/+source/gnome-software/+bug/1756098

Ads20000 (ads20000) wrote :

For those wondering: I should've realized this much earlier, the importance being 'Low' is not some sort of anti-Flatpak conspiracy, it's because the bug satisfies the criteria for Low importance as per: https://wiki.ubuntu.com/Bugs/Importance

'Bugs that affect unusual end-user configurations or uncommon hardware
Bugs that affect a non-essential aspect and limited scope of the application
Non-ideal default configuration'

Though I think there's a case to make this higher importance:

'A bug that has a moderate impact on a core application' (Medium)
'Has a severe impact on a small portion of Ubuntu users (estimated)' (High)
'Renders essential features or functionality of the application or dependencies broken or ineffective' (High) - some would consider installing Flatpaks from their software center an 'essential feature', even if Flatpak and the plugin in question are in universe not main. (High)

Jeremy Bicha (jbicha) wrote :

Ok, I'll give you medium. Enjoy!

Changed in gnome-software (Ubuntu Artful):
importance: Low → Medium
Changed in gnome-software (Ubuntu):
importance: Low → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers