gnome-software fails to run on i386

Bug #1708998 reported by Juan Pablo Lozano on 2017-08-07
74
This bug affects 11 people
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
Critical
Robert Ancell

Bug Description

I have clicked on "Update All" button... after download all software in list, a message "GNOME Software need to be restarted to load new plugin", and then i clicked for restart GNOME Software crashing.

Errors on errors.u.c
https://errors.ubuntu.com/problem/bd33f0a209fd6f0763867baf63762b98fce573aa
https://errors.ubuntu.com/problem/ebc9a7077dfb68d1b800adcc46a9f6569227c42e

ProblemType: Crash
DistroRelease: Ubuntu 17.10
Package: gnome-software 3.25.4-1ubuntu1
ProcVersionSignature: Ubuntu 4.11.0-10.15-generic 4.11.8
Uname: Linux 4.11.0-10-generic i686
ApportVersion: 2.20.6-0ubuntu4
Architecture: i386
CurrentDesktop: Budgie:GNOME
Date: Mon Aug 7 02:02:08 2017
ExecutablePath: /usr/bin/gnome-software
InstallationDate: Installed on 2017-08-07 (0 days ago)
InstallationMedia: Ubuntu-Budgie 17.10 "Artful Aardvark" - Alpha i386 (20170806)
InstalledPlugins:
 gnome-software-plugin-flatpak N/A
 gnome-software-plugin-limba N/A
 gnome-software-plugin-snap 3.25.4-1ubuntu1
ProcCmdline: /usr/bin/gnome-software
SegvAnalysis:
 Segfault happened at: 0xb6590ba6 <__strchr_sse2+38>: movdqa (%edi),%xmm0
 PC (0xb6590ba6) ok
 source "(%edi)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%xmm0" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-software
StacktraceTop:
 g_param_spec_pool_lookup () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 g_object_new_valist () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 g_object_new () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 ?? ()
 gs_shell_change_mode ()
Title: gnome-software crashed with SIGSEGV in g_param_spec_pool_lookup()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Juan Pablo Lozano (libredeb) wrote :

StacktraceTop:
 g_param_spec_pool_lookup (pool=0x817947d0, param_name=0x1 <error: Cannot access memory at address 0x1>, owner_type=2174413016, walk_ancestors=1) at ../../../../gobject/gparam.c:1071
 g_object_new_valist (object_type=<optimized out>, first_property_name=<optimized out>, var_args=0xbfc2624c "m\213\025\200\001") at ../../../../gobject/gobject.c:2073
 g_object_new (object_type=2174413016, first_property_name=0x8015433a "action") at ../../../../gobject/gobject.c:1624
 gs_loading_page_load (self=0x832f7310) at ../src/gs-loading-page.c:134
 gs_loading_page_switch_to (page=0x832f7310, scroll_up=1) at ../src/gs-loading-page.c:159

Changed in gnome-software (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu):
status: New → Confirmed
information type: Private → Public
summary: - gnome-software crashed updating software updated list
+ gnome-software fails to run on i386
description: updated
Changed in gnome-software (Ubuntu):
importance: Medium → Critical
assignee: nobody → Robert Ancell (robert-ancell)
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1708998

tags: added: iso-testing
Robert Ancell (robert-ancell) wrote :

This is due to integers being read as 64 bits, so it fails (in many places) on 32 bit systems. Fixed in master:

commit 31c9dd212156afbb2422188cb59ee8acb5a0719f
Author: Robert Ancell <email address hidden>
Date: Wed Aug 30 14:16:14 2017 +1200

    Fix GObject arguments not working on 32 bit systems

Changed in gnome-software (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.25.91-1ubuntu2

---------------
gnome-software (3.25.91-1ubuntu2) artful; urgency=medium

  * debian/patches/0001-Fix-GObject-arguments-not-working-on-32-bit-systems.patch:
    - Fix crash running on i386 (LP: #1708998)

 -- Robert Ancell <email address hidden> Wed, 30 Aug 2017 15:51:51 +1200

Changed in gnome-software (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers