Update to 3.20.5

Bug #1703461 reported by Robert Ancell on 2017-07-10
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
Medium
Unassigned
Xenial
Wishlist
Robert Ancell

Bug Description

[Impact]
Ubuntu 16.04 is running a version of gnome-software based on 3.20.1 which is an older stable release (latest stable release is 3.20.5). The Ubuntu changes were managed in a git branch that is difficult to manage. We have not been able to bring in all the stable changes to this branch and it is difficult to modify. We have rebased our changes on 3.20.5 [1] and propose these as a Stable Release Update.

[1] https://lists.ubuntu.com/archives/ubuntu-desktop/2017-June/005011.html

[Test Case]
1. Run GNOME Software
2. Execute the test plan https://wiki.ubuntu.com/Process/Merges/TestPlans/gnome-software

Expected result:
Running latest stable release, no regressions from 3.20.1

Observed result:
Running older release.

[Regression Potential]
Due to the number of changes there is a risk of regression. These changes are all on a stable branch, so upstream considers them to be safe. We ran this version from a PPA to check for issues, and there don't seem to be any problems.

Changed in gnome-software (Ubuntu):
status: New → Fix Released
Changed in gnome-software (Ubuntu Xenial):
importance: Undecided → Wishlist
Changed in gnome-software (Ubuntu):
importance: Undecided → Medium
Changed in gnome-software (Ubuntu Xenial):
assignee: nobody → Robert Ancell (robert-ancell)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu Xenial):
status: New → Confirmed

Hello Robert, or anyone else affected,

Accepted gnome-software into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.20.5-0ubuntu0.16.04.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-software (Ubuntu Xenial):
status: Confirmed → Fix Committed
tags: added: verification-needed verification-needed-xenial
description: updated
Jean-Baptiste Lallement (jibel) wrote :

I tested gnome-software 3.20.5-0ubuntu0.16.04.5 on a fresh installation of xenial and executed the test plan linked in the description. I didn't find any regression and issues identified have been confirmed in version 3.20.1+git20170524.0.ea2fe2b0-0ubuntu0.16.04.1 in xenial-update.

Marking as verification-done.

tags: added: verification-done-xenial
removed: verification-needed-xenial

The verification of the Stable Release Update for gnome-software has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.20.5-0ubuntu0.16.04.5

---------------
gnome-software (3.20.5-0ubuntu0.16.04.5) xenial; urgency=medium

  * debian/patches/0018-Add-a-Snap-plugin.patch:
    - Fix crash when failing to load icons from cache (LP: #1702122)

gnome-software (3.20.5-0ubuntu0.16.04.4) xenial; urgency=medium

  * Rebase on stable 3.20.5 release (LP: #1703461).
  * debian/patches/*.patch:
    - Convert Ubuntu changes into patches
  * debian/patches/0018-Add-a-Snap-plugin.patch:
    - Fix snaps without icons not showing reliably (LP: #1697565)
    - Show featured snaps (LP: #1663097)

 -- Robert Ancell <email address hidden> Wed, 12 Jul 2017 16:24:08 +1200

Changed in gnome-software (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers