/usr/bin/gnome-software:11:load_icon:gs_plugin_refine_app:gs_plugin_loader_run_refine_app:gs_plugin_loader_run_refine_internal:gs_plugin_loader_run_refine

Bug #1702122 reported by errors.ubuntu.com bug bridge on 2017-07-03
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
High
Robert Ancell
Xenial
High
Robert Ancell
Zesty
High
Robert Ancell
Artful
High
Robert Ancell

Bug Description

[Impact]
The new icon cache code has a bug where it doesn't correctly handle errors loading from the cache. This was picked up in the error tracker [1].

[1] https://errors.ubuntu.com/problem/bc8baf24512d0c46f341376c9134e4f04ec284d0

[Test Case]
1. Run GNOME Software

Expected result:
Crash doesn't show on errors.ubuntu.com

Observed result:
Crash shows on errors.ubuntu.com

[Regression Potential]
Fix was to use correct variable (typo). Seems unlikely to be able to cause new issues (though may unmask other issues by now working correctly).

Sebastien Bacher (seb128) wrote :

The issue seems new with snaps and icons, Robert could you have a look to that one?

Changed in gnome-software (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
importance: Undecided → High
Changed in gnome-software (Ubuntu Zesty):
importance: Undecided → High
Changed in gnome-software (Ubuntu Artful):
status: New → Fix Committed
Changed in gnome-software (Ubuntu Zesty):
status: New → Fix Committed
assignee: nobody → Robert Ancell (robert-ancell)
Robert Ancell (robert-ancell) wrote :

This change also uploaded for the 3.20.5 xenial SRU (which has not reached any users yet).

description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.24.3-0ubuntu6

---------------
gnome-software (3.24.3-0ubuntu6) artful; urgency=medium

  * debian/patches/0001-snap-Fix-crash-when-fail-to-use-icon-from-cache.patch:
    - Fix crash when failing to load icons from cache (LP: #1702122)

 -- Robert Ancell <email address hidden> Wed, 12 Jul 2017 16:06:19 +1200

Changed in gnome-software (Ubuntu Artful):
status: Fix Committed → Fix Released

Hello errors.ubuntu.com, or anyone else affected,

Accepted gnome-software into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.20.5-0ubuntu0.16.04.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-software (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed verification-needed-xenial
Brian Murray (brian-murray) wrote :

Hello errors.ubuntu.com, or anyone else affected,

Accepted gnome-software into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.22.7-0ubuntu3.17.04.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed-zesty
Robert Ancell (robert-ancell) wrote :

I just noticed the zesty upload didn't have this patch in debian/patches/series - I will have to re-upload.

Changed in gnome-software (Ubuntu Xenial):
assignee: nobody → Robert Ancell (robert-ancell)
importance: Undecided → High
tags: added: verification-done-xenial
removed: verification-needed verification-needed-xenial

The verification of the Stable Release Update for gnome-software has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.20.5-0ubuntu0.16.04.5

---------------
gnome-software (3.20.5-0ubuntu0.16.04.5) xenial; urgency=medium

  * debian/patches/0018-Add-a-Snap-plugin.patch:
    - Fix crash when failing to load icons from cache (LP: #1702122)

gnome-software (3.20.5-0ubuntu0.16.04.4) xenial; urgency=medium

  * Rebase on stable 3.20.5 release (LP: #1703461).
  * debian/patches/*.patch:
    - Convert Ubuntu changes into patches
  * debian/patches/0018-Add-a-Snap-plugin.patch:
    - Fix snaps without icons not showing reliably (LP: #1697565)
    - Show featured snaps (LP: #1663097)

 -- Robert Ancell <email address hidden> Wed, 12 Jul 2017 16:24:08 +1200

Changed in gnome-software (Ubuntu Xenial):
status: Fix Committed → Fix Released

Hello errors.ubuntu.com, or anyone else affected,

Accepted gnome-software into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.22.7-0ubuntu3.17.04.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed

Do you have specific steps to reproduce this issue, just monitoring errors.u.c is not enough to perform a verification.

Robert Ancell (robert-ancell) wrote :

I don't have any specific steps, since I wasn't able to trigger this issue locally. I don't know what we do in this case because the crash reports do show it occurring and the fix is clear.

There is no crash reported in errors.u.c after a week for version 3.22.7-0ubuntu3.17.04.7 of gnome-software. I'm marking this report as verification-done.

tags: added: verification-done-zesty
removed: verification-needed-zesty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.22.7-0ubuntu3.17.04.7

---------------
gnome-software (3.22.7-0ubuntu3.17.04.7) zesty; urgency=medium

  * debian/patches/0001-snap-Use-title-field-if-available.patch:
    - Use new title field from snapd (LP: #1555569)
  * debian/patches/0001-snap-Remove-size-limit-on-snap-responses.patch:
  * debian/patches/0002-snap-Fix-failures-to-read-from-snapd.patch:
    - Fix icons larger than 65kB not loading (LP: #1704888)
  * debian/patches/0001-snap-Mark-non-app-snaps-as-runtimes.patch:
    - Stop 'core' snap showing as an app (LP: #1704904)
  * debian/patches/0001-snap-Fix-crash-when-fail-to-use-icon-from-cache.patch:
    - Add to debian/patches/series - was not enabled in last release
  * debian/patches/0001-snap-Replace-libsoup-icon-loading-code-with-AsIcon.patch:
    - Fix crash loading cached icons (LP: #1708140)
  * debian/patches/0001-snap-Run-before-hardcoded-popular-plugin.patch:
  * debian/patches/0018-Make-gs_app_list_filter_duplicates-not-change-app-or.patch:
  * debian/patches/0019-snap-Use-first-featured-snap-as-featured-app.patch:
  * debian/patches/0020-snap-Only-feature-snaps.patch:
  * debian/patches/0021-Don-t-randomize-editors-picks.patch:
    - Only show snaps in "Editor's picks" (LP: #1705953)
    - Show snap in "Featured" section (LP: #1706478)

gnome-software (3.22.7-0ubuntu3.17.04.6) zesty; urgency=medium

  * 0001-snap-Fix-crash-when-fail-to-use-icon-from-cache.patch:
    - Fix crash when failing to load icons from cache (LP: #1702122)

 -- Robert Ancell <email address hidden> Thu, 24 Aug 2017 13:46:31 +1200

Changed in gnome-software (Ubuntu Zesty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers