Gnome Software front end showed spinner on all actions; had to kill service process to fix

Bug #1697920 reported by Stuart Langridge on 2017-06-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
Medium
Unassigned

Bug Description

When opening Gnome Software, the front screen worked fine for me (showing the featured app, editor's picks and so on) but taking any action (clicking a different tab, or clicking an application, or doing a search) showed an empty window with a spinner. There was a long-running "/usr/bin/gnome-software --gapplication-service" process running; killing that process and then starting Gnome Software made everything work again (and updated the featured app to be the current one).

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: gnome-software 3.20.1+git20170208.0.a34b091-0ubuntu1~xenial1
ProcVersionSignature: Ubuntu 4.4.0-78.99-generic 4.4.62
Uname: Linux 4.4.0-78-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.5
Architecture: amd64
CurrentDesktop: GNOME
Date: Wed Jun 14 12:38:50 2017
InstallationDate: Installed on 2014-04-07 (1164 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
SourcePackage: gnome-software
UpgradeStatus: Upgraded to xenial on 2016-08-04 (314 days ago)

Stuart Langridge (sil) wrote :
Changed in gnome-software (Ubuntu):
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers