/usr/bin/gnome-software:11:g_source_attach:debconf_accept_cb:socket_source_dispatch:g_main_dispatch:g_main_context_dispatch

Bug #1689425 reported by errors.ubuntu.com bug bridge on 2017-05-09
58
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
Status tracked in Artful
Xenial
High
Robert Ancell
Yakkety
High
Robert Ancell
Zesty
High
Robert Ancell
Artful
High
Robert Ancell

Bug Description

[Impact]
The change to add debconf support (bug 1679435) caused new crashes to occur in errors.ubuntu.com. The stacktrace show this crash occurring when a g_socket_accept generates an error. The exact cause of this failing is unknown, but the fix is to handle this error like any other.

[Test Case]
1. Run GNOME Software

Expected result:
Doesn't crash

Observed result:
Crashes reported on errors.ubuntu.com

[Regression Potential]
Low, we not just exit a function when an error occurs instead of crashing.

Robert Ancell (robert-ancell) wrote :

This seems to be due to a missing error check accepting the debconf connection (bug 1679435)

Changed in gnome-software (Ubuntu Artful):
status: New → Fix Committed
Changed in gnome-software (Ubuntu Zesty):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in gnome-software (Ubuntu Artful):
assignee: nobody → Robert Ancell (robert-ancell)
importance: Undecided → High
Changed in gnome-software (Ubuntu Xenial):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in gnome-software (Ubuntu Zesty):
importance: Undecided → High
status: New → Triaged
Changed in gnome-software (Ubuntu Yakkety):
status: New → Triaged
Changed in gnome-software (Ubuntu Xenial):
status: New → Triaged
Changed in gnome-software (Ubuntu Yakkety):
importance: Undecided → High
Changed in gnome-software (Ubuntu Xenial):
importance: Undecided → High
Changed in gnome-software (Ubuntu Yakkety):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in gnome-software (Ubuntu Zesty):
status: Triaged → Fix Committed
Changed in gnome-software (Ubuntu Yakkety):
status: Triaged → Fix Committed
Changed in gnome-software (Ubuntu Xenial):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.24.1-0ubuntu4

---------------
gnome-software (3.24.1-0ubuntu4) artful; urgency=medium

  * debian/patches/0006-Add-an-APT-plugin.patch:
    - Fix crash when debconf socket fails (LP: #1689425)

 -- Robert Ancell <email address hidden> Tue, 09 May 2017 16:41:57 +1200

Changed in gnome-software (Ubuntu Artful):
status: Fix Committed → Fix Released

An upload of gnome-software to yakkety-proposed has been rejected from the upload queue for the following reason: "The changelog references a patch which does not appear in the diff / upload - debian/patches/0002-Add-an-APT-plugin.patch.".

Łukasz Zemczak (sil2100) wrote :

Please update the bug description to include the relevant SRU information [1]. We at least need to know the impact, possible test case and regression potential - otherwise it's not really easy and reliable to review.

[1] https://wiki.ubuntu.com/StableReleaseUpdates#SRU_Bug_Template

description: updated
Steve Langasek (vorlon) wrote :

Hi Robert, just so you know, we appear to be seeing bug reports also on the package upgrade side as a result of these dropped debconf socket connections, e.g.: bug #1691983. It's sensible for gnome-software not to crash on a failed connection, but I think ultimately what we need are succeeding connections :) so there may be more work to be done here. (unless the failing connections from the other side are because gnome-software has already crashed at that point?)

tags: added: verification-needed

Hello errors.ubuntu.com, or anyone else affected,

Accepted gnome-software into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.20.1+git20170509.0.8292905-0ubuntu1~xenial1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Steve Langasek (vorlon) wrote :

Hello errors.ubuntu.com, or anyone else affected,

Accepted gnome-software into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.20.1+git20170509.0.8292905-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Robert Ancell (robert-ancell) wrote :

Confirmed can still install a debconf triggering package with 3.20.1+git20170509.0.8292905-0ubuntu1~xenial1 on Xenial.

tags: added: verification-done-xenial verification-needed-yakkety verification-needed-zesty
removed: verification-needed
Robert Ancell (robert-ancell) wrote :

Confirmed can still install a debconf triggering package with 3.20.1+git20170509.0.8292905-0ubuntu1 on Yakkety.

tags: added: verification-done-yakkety
removed: verification-needed-yakkety

The verification of the Stable Release Update for gnome-software has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.20.1+git20170509.0.8292905-0ubuntu1~xenial1

---------------
gnome-software (3.20.1+git20170509.0.8292905-0ubuntu1~xenial1) xenial; urgency=medium

  * New upstream snapshot from the wip/ubuntu-3-20 branch at
    git://git.gnome.org/gnome-software.
    - Fix crash when debconf socket fails (LP: #1689425)

 -- Robert Ancell <email address hidden> Tue, 09 May 2017 16:58:47 +1200

Changed in gnome-software (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.20.1+git20170509.0.8292905-0ubuntu1

---------------
gnome-software (3.20.1+git20170509.0.8292905-0ubuntu1) yakkety; urgency=medium

  * New upstream snapshot from the wip/ubuntu-3-20 branch at
    git://git.gnome.org/gnome-software.
    - Fix crash when debconf socket fails (LP: #1689425)

 -- Robert Ancell <email address hidden> Fri, 12 May 2017 09:26:30 +1200

Changed in gnome-software (Ubuntu Yakkety):
status: Fix Committed → Fix Released

Hello errors.ubuntu.com, or anyone else affected,

Accepted gnome-software into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.22.7-0ubuntu3.17.04.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed

As part of a recent change in the Stable Release Update verification policy we would like to inform that for a bug to be considered verified for a given release a verification-done-$RELEASE tag needs to be added to the bug where $RELEASE is the name of the series the package that was tested (e.g. verification-done-xenial). Please note that the global 'verification-done' tag can no longer be used for this purpose.

Thank you!

Jeremy Bicha (jbicha) wrote :

I verified that there are no reports for this issue on https://errors.ubuntu.com/problem/c7ba5238c01adbb8a245dfc02bac9633a362ea44 for 17.04 after the 3.22.7-0ubuntu3.17.04.2 update. On 17.10, we haven't gotten any new reports of this bug since early May.

This issue is also a bit odd because it's already been fixed now in 16.04 LTS and 16.10 so let's not delay this fix further in 17.04.

tags: added: verification-done-zesty
removed: verification-needed verification-needed-zesty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.22.7-0ubuntu3.17.04.5

---------------
gnome-software (3.22.7-0ubuntu3.17.04.5) zesty; urgency=medium

  * debian/patches/0001-snap-Fix-icons-not-being-converted-to-pixbufs.patch:
    - Fix snaps without icons not showing reliably (LP: #1697565)
  * debian/patches/0001-snap-Backport-fixes-from-master.patch:
    - Show featured snaps (LP: #1663097)
  * debian/patches/0017-Use-snap-name-field-for-app-name.patch:
    - Dropped, merged into above patch

gnome-software (3.22.7-0ubuntu3.17.04.4) zesty; urgency=medium

  * debian/patches/0006-Add-an-APT-plugin.patch:
    - Handle multiple debconf connections (LP: #1688721)
  * debian/patches/0018-Limit-search-entry-to-100-characters.patch:
    - Limit search entry in case of accidental input (LP: #1692398)

gnome-software (3.22.7-0ubuntu3.17.04.3) zesty; urgency=medium

  * debian/patches/0002-Add-an-APT-plugin.patch:
    - Fix crash when debconf socket fails (LP: #1689425)

 -- Robert Ancell <email address hidden> Fri, 16 Jun 2017 13:42:12 +1200

Changed in gnome-software (Ubuntu Zesty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers