Packages that trigger multiple debconf prompts fail to install

Bug #1688721 reported by Rafael Belmonte on 2017-05-06
This bug affects 207 people
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
High
Robert Ancell
Xenial
High
Robert Ancell
Yakkety
High
Robert Ancell
Zesty
High
Robert Ancell
Artful
High
Robert Ancell

Bug Description

[Impact]
Some packages stall on installing. These are packages that generate multiple debconf prompts (the prompts may be empty and so not user visible, e.g. gconf2-common).

[Test Case]
1. Remove gconf2-common (warning, may uninstall packages like gnome-terminal):
$ sudo apt purge gconf2-common
2. Download the debian package of Chrome from www.google.com/chrome.
3. Install the package (browser will prompt, or double click on package in Nautilus).

Expected result:
Chrome installs correctly.

Observed result:
The installation hangs on 51%.

[Regression Potential]
The debconf conde was modified to support multiple requests. This could expose other debconf issues or break other .deb install code.

Rafael Belmonte (eaglescreen) wrote :
description: updated
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gconf (Ubuntu):
status: New → Confirmed

I got this same problem on Ubuntu GNOME 17.10 64-bit when trying to run the following in the terminal:

sudo apt update && sudo apt upgrade -y

tags: added: bugpattern-needed
tags: added: artful
Wild Man (wildmanne39) wrote :

Affects me while testing 17.10.

tags: added: yakkety
Jean-Baptiste Lallement (jibel) wrote :

setting to high given the frequency of this defect.

description: updated
Changed in gconf (Ubuntu):
importance: Undecided → High
Iain Lane (laney) wrote :

Robert, can you look please? Sounds to me like it's something to do with debconf support which you've worked on lately. The testcase in the original report was on zesty - not sure if it's still there in artful.

Changed in gnome-software (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
tags: added: trello-import
tags: added: desktop-trello-import
removed: trello-import
tags: removed: desktop-trello-import

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu):
status: New → Confirmed
Robert Ancell (robert-ancell) wrote :

I could reproduce in Zesty, but not Artful or Xenial.

Robert Ancell (robert-ancell) wrote :

All current duplicates are for Zesty, except for bug 1691599 (Artful) and bug 1692344 (Yakkety).

Changed in gnome-software (Ubuntu Zesty):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in gnome-software (Ubuntu):
status: Confirmed → Fix Released
Changed in gconf (Ubuntu):
status: Confirmed → Fix Released
Changed in gconf (Ubuntu Zesty):
importance: Undecided → High
Changed in gnome-software (Ubuntu Zesty):
importance: Undecided → High
Changed in gnome-software (Ubuntu):
importance: Undecided → High
Robert Ancell (robert-ancell) wrote :

By purging gconf2-common, I can reproduce in Artful.

i.e.
$ sudo apt purge gconf2-common
$ gnome-software --local-filename ~/Downloads/google-chrome-stable_current_amd64.deb

Changed in gnome-software (Ubuntu):
status: Fix Released → New
Changed in gconf (Ubuntu):
status: Fix Released → New
Changed in gconf (Ubuntu Yakkety):
importance: Undecided → High
Changed in gconf (Ubuntu Xenial):
importance: Undecided → High
Changed in gnome-software (Ubuntu Xenial):
importance: Undecided → High
Changed in gnome-software (Ubuntu Yakkety):
importance: Undecided → High
Robert Ancell (robert-ancell) wrote :

Using the purge technique I can also reproduce in Xenial. I suspect this problem isn't being seen much pre-Zesty because gconf is already installed (pulled in by aisleriot and probably other older pacakges).

I reproduced the same defect on Artful. Also while installing updates the libpam-systemd also failed to install with a similar trace.

no longer affects: gconf (Ubuntu)
no longer affects: gconf (Ubuntu Xenial)
no longer affects: gconf (Ubuntu Yakkety)
no longer affects: gconf (Ubuntu Zesty)
no longer affects: gconf (Ubuntu Artful)
description: updated
Robert Ancell (robert-ancell) wrote :

Cause is due to there being multiple debconf connections when gconf-common is configured (all of which close without any content being sent). The gnome-software debconf code only handled the first connection.

Changed in gnome-software (Ubuntu Artful):
status: New → Fix Committed
Changed in gnome-software (Ubuntu Zesty):
status: New → Fix Committed
Changed in gnome-software (Ubuntu Yakkety):
status: New → Fix Committed
Changed in gnome-software (Ubuntu Xenial):
status: New → Fix Committed
Changed in gnome-software (Ubuntu Yakkety):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in gnome-software (Ubuntu Xenial):
assignee: nobody → Robert Ancell (robert-ancell)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.24.3-0ubuntu3

---------------
gnome-software (3.24.3-0ubuntu3) artful; urgency=medium

  * debian/patches/0006-Add-an-APT-plugin.patch:
    - Handle multiple debconf connections (LP: #1688721)

 -- Robert Ancell <email address hidden> Tue, 23 May 2017 21:28:12 +1200

Changed in gnome-software (Ubuntu Artful):
status: Fix Committed → Fix Released
Robert Ancell (robert-ancell) wrote :
description: updated
description: updated
summary: - package gconf2-common 3.2.6-3ubuntu7 failed to install/upgrade:
- subprocess installed post-installation script returned error exit status
- 128
+ Packages that trigger multiple debconf prompts fail to install
Iain Lane (laney) wrote :

Well done!

Sorry, I can't understand how to fix the bug. Can you clarify me what to do?

Pier Luigi Bonucci

Hello Rafael, or anyone else affected,

Accepted gnome-software into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.20.1+git20170524.0.ea2fe2b0-0ubuntu0.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Hello Rafael, or anyone else affected,

Accepted gnome-software into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.20.1+git20170524.0.ea2fe2b0-0ubuntu0.16.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

An upload of gnome-software to zesty-proposed has been rejected from the upload queue for the following reason: "This upload also includes version 3.22.7-0ubuntu3.17.04.3 of gnome-software which fixes bug 1689425, however this bug does not appear in the Launchpad-Bugs-Fixed section of the .changes file (https://launchpadlibrarian.net/320895234/gnome-software_3.22.7-0ubuntu3.17.04.4_source.changes) as such that bug won't be tracked as a part of the SRU when it should be. Subsequently, I'm rejecting this upload.".

Brian Murray (brian-murray) wrote :

The latest upload to the zesty queue of gnome-software now contains the following in the changelog:

+ * debian/patches/0006-Add-an-APT-plugin.patch:
+ - Handle multiple debconf connections (LP: #1688721)

However, there isn't actually a 0006-Add-an-APT-plugin.patch file in the diff. There is a 0002-Add-an-APT-plugin.patch file in the diff and it looks to me (based off looking at the yakkety diff of the package in -proposed) like the multiple debconf connections work is included in the 0002 patch. If that is correct I'm happy to accept the package into -proposed with the typo in the changelog, I just want to confirm we really are getting the fix for this bug in zesty. Thanks!

Changed in gnome-software (Ubuntu Zesty):
status: Fix Committed → Incomplete
Robert Ancell (robert-ancell) wrote :

Yeah, this is just a typo copying the changelog from a artful back to zesty. The fix is in the 0002 patch.

Hello Rafael, or anyone else affected,

Accepted gnome-software into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.22.7-0ubuntu3.17.04.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-software (Ubuntu Zesty):
status: Incomplete → Fix Committed

As part of a recent change in the Stable Release Update verification policy we would like to inform that for a bug to be considered verified for a given release a verification-done-$RELEASE tag needs to be added to the bug where $RELEASE is the name of the series the package that was tested (e.g. verification-done-xenial). Please note that the global 'verification-done' tag can no longer be used for this purpose.

Thank you!

Jeremy Bicha (jbicha) wrote :

I verified that I can install Google Chrome now with 3.22.7-0ubuntu3.17.04.5 on Ubuntu GNOME 17.04 where gconf was not already pre-installed.

tags: added: verification-done-zesty
Jeremy Bicha (jbicha) wrote :

I also verified that Google Chrome now installs successfully with
3.20.1+git20170524.0.ea2fe2b0-0ubuntu0.16.10.1 on Ubuntu GNOME 16.10
3.20.1+git20170524.0.ea2fe2b0-0ubuntu0.16.04.1 on Ubuntu GNOME 16.04 LTS

tags: added: verification-done-xenial verification-done-yakkety
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.20.1+git20170524.0.ea2fe2b0-0ubuntu0.16.04.1

---------------
gnome-software (3.20.1+git20170524.0.ea2fe2b0-0ubuntu0.16.04.1) xenial; urgency=medium

  * New upstream snapshot from the wip/ubuntu-3-20 branch at
    git://git.gnome.org/gnome-software.
    - Handle multiple debconf connections (LP: #1688721)
    - Limit search entry in case of accidental input (LP: #1692398)

 -- Robert Ancell <email address hidden> Wed, 24 May 2017 09:49:56 +1200

Changed in gnome-software (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-software has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.20.1+git20170524.0.ea2fe2b0-0ubuntu0.16.10.1

---------------
gnome-software (3.20.1+git20170524.0.ea2fe2b0-0ubuntu0.16.10.1) yakkety; urgency=medium

  * New upstream snapshot from the wip/ubuntu-3-20 branch at
    git://git.gnome.org/gnome-software.
    - Handle multiple debconf connections (LP: #1688721)
    - Limit search entry in case of accidental input (LP: #1692398)

 -- Robert Ancell <email address hidden> Wed, 24 May 2017 09:49:56 +1200

Changed in gnome-software (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.22.7-0ubuntu3.17.04.5

---------------
gnome-software (3.22.7-0ubuntu3.17.04.5) zesty; urgency=medium

  * debian/patches/0001-snap-Fix-icons-not-being-converted-to-pixbufs.patch:
    - Fix snaps without icons not showing reliably (LP: #1697565)
  * debian/patches/0001-snap-Backport-fixes-from-master.patch:
    - Show featured snaps (LP: #1663097)
  * debian/patches/0017-Use-snap-name-field-for-app-name.patch:
    - Dropped, merged into above patch

gnome-software (3.22.7-0ubuntu3.17.04.4) zesty; urgency=medium

  * debian/patches/0006-Add-an-APT-plugin.patch:
    - Handle multiple debconf connections (LP: #1688721)
  * debian/patches/0018-Limit-search-entry-to-100-characters.patch:
    - Limit search entry in case of accidental input (LP: #1692398)

gnome-software (3.22.7-0ubuntu3.17.04.3) zesty; urgency=medium

  * debian/patches/0002-Add-an-APT-plugin.patch:
    - Fix crash when debconf socket fails (LP: #1689425)

 -- Robert Ancell <email address hidden> Fri, 16 Jun 2017 13:42:12 +1200

Changed in gnome-software (Ubuntu Zesty):
status: Fix Committed → Fix Released

Whenever i try to install any appliacation i have face this problem ?
Note : See the screenshot

On Fri, Jun 30, 2017 at 1:06 AM, Launchpad Bug Tracker <
<email address hidden>> wrote:

> This bug was fixed in the package gnome-software -
> 3.22.7-0ubuntu3.17.04.5
>
> ---------------
> gnome-software (3.22.7-0ubuntu3.17.04.5) zesty; urgency=medium
>
> * debian/patches/0001-snap-Fix-icons-not-being-converted-to-
> pixbufs.patch:
> - Fix snaps without icons not showing reliably (LP: #1697565)
> * debian/patches/0001-snap-Backport-fixes-from-master.patch:
> - Show featured snaps (LP: #1663097)
> * debian/patches/0017-Use-snap-name-field-for-app-name.patch:
> - Dropped, merged into above patch
>
> gnome-software (3.22.7-0ubuntu3.17.04.4) zesty; urgency=medium
>
> * debian/patches/0006-Add-an-APT-plugin.patch:
> - Handle multiple debconf connections (LP: #1688721)
> * debian/patches/0018-Limit-search-entry-to-100-characters.patch:
> - Limit search entry in case of accidental input (LP: #1692398)
>
> gnome-software (3.22.7-0ubuntu3.17.04.3) zesty; urgency=medium
>
> * debian/patches/0002-Add-an-APT-plugin.patch:
> - Fix crash when debconf socket fails (LP: #1689425)
>
> -- Robert Ancell <email address hidden> Fri, 16 Jun 2017
> 13:42:12 +1200
>
> ** Changed in: gnome-software (Ubuntu Zesty)
> Status: Fix Committed => Fix Released
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1694521).
> https://bugs.launchpad.net/bugs/1688721
>
> Title:
> Packages that trigger multiple debconf prompts fail to install
>
> Status in gnome-software package in Ubuntu:
> Fix Released
> Status in gnome-software source package in Xenial:
> Fix Released
> Status in gnome-software source package in Yakkety:
> Fix Released
> Status in gnome-software source package in Zesty:
> Fix Released
> Status in gnome-software source package in Artful:
> Fix Released
>
> Bug description:
> [Impact]
> Some packages stall on installing. These are packages that generate
> multiple debconf prompts (the prompts may be empty and so not user visible,
> e.g. gconf2-common).
>
> [Test Case]
> 1. Remove gconf2-common (warning, may uninstall packages like
> gnome-terminal):
> $ sudo apt purge gconf2-common
> 2. Download the debian package of Chrome from www.google.com/chrome.
> 3. Install the package (browser will prompt, or double click on package
> in Nautilus).
>
> Expected result:
> Chrome installs correctly.
>
> Observed result:
> The installation hangs on 51%.
>
> [Regression Potential]
> The debconf conde was modified to support multiple requests. This could
> expose other debconf issues or break other .deb install code.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/gnome-software/
> +bug/1688721/+subscriptions
>

Download full text (5.0 KiB)

Dear Sir. Mac Abdul,

This issue was solved as per previous instructions and correct way to install the program. Thanks all team involved for their efforts and results to provide a quick answer.

________________________________
De: <email address hidden> <email address hidden> em nome de Mac Abdul <email address hidden>
Enviado: quinta-feira, 6 de julho de 2017 08:45:19
Para: <email address hidden>
Assunto: Re: [Bug 1688721] Re: Packages that trigger multiple debconf prompts fail to install

Whenever i try to install any appliacation i have face this problem ?
Note : See the screenshot

On Fri, Jun 30, 2017 at 1:06 AM, Launchpad Bug Tracker <
<email address hidden>> wrote:

> This bug was fixed in the package gnome-software -
> 3.22.7-0ubuntu3.17.04.5
>
> ---------------
> gnome-software (3.22.7-0ubuntu3.17.04.5) zesty; urgency=medium
>
> * debian/patches/0001-snap-Fix-icons-not-being-converted-to-
> pixbufs.patch:
> - Fix snaps without icons not showing reliably (LP: #1697565)
> * debian/patches/0001-snap-Backport-fixes-from-master.patch:
> - Show featured snaps (LP: #1663097)
> * debian/patches/0017-Use-snap-name-field-for-app-name.patch:
> - Dropped, merged into above patch
>
> gnome-software (3.22.7-0ubuntu3.17.04.4) zesty; urgency=medium
>
> * debian/patches/0006-Add-an-APT-plugin.patch:
> - Handle multiple debconf connections (LP: #1688721)
> * debian/patches/0018-Limit-search-entry-to-100-characters.patch:
> - Limit search entry in case of accidental input (LP: #1692398)
>
> gnome-software (3.22.7-0ubuntu3.17.04.3) zesty; urgency=medium
>
> * debian/patches/0002-Add-an-APT-plugin.patch:
> - Fix crash when debconf socket fails (LP: #1689425)
>
> -- Robert Ancell <email address hidden> Fri, 16 Jun 2017
> 13:42:12 +1200
>
> ** Changed in: gnome-software (Ubuntu Zesty)
> Status: Fix Committed => Fix Released
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1694521).
> https://bugs.launchpad.net/bugs/1688721
>
> Title:
> Packages that trigger multiple debconf prompts fail to install
>
> Status in gnome-software package in Ubuntu:
> Fix Released
> Status in gnome-software source package in Xenial:
> Fix Released
> Status in gnome-software source package in Yakkety:
> Fix Released
> Status in gnome-software source package in Zesty:
> Fix Released
> Status in gnome-software source package in Artful:
> Fix Released
>
> Bug description:
> [Impact]
> Some packages stall on installing. These are packages that generate
> multiple debconf prompts (the prompts may be empty and so not user visible,
> e.g. gconf2-common).
>
> [Test Case]
> 1. Remove gconf2-common (warning, may uninstall packages like
> gnome-terminal):
> $ sudo apt purge gconf2-common
> 2. Download the debian package of Chrome from www.google.com/chrome<http://www.google.com/chrome>.
> 3. Install the package (browser will prompt, or double click on package
> in Nautilus).
>
> Expected result:
> Chrome installs correctly.
>
> Observed result:
> The installation hangs on 51%.
>
> [Regression Potential]
> The debconf conde was modi...

Read more...

Mac Abdul (macabdul) wrote :
Download full text (7.0 KiB)

In Ubuntu 17.10 the "show application" should have on top-left instead of
bottom-left and "minimize-maximize-close" buttons should have been on the
left side of the window instead of right side.

On Thu, Jul 6, 2017 at 5:49 PM, carlos roberto alves benevides <
<email address hidden>> wrote:

> Dear Sir. Mac Abdul,
>
>
> This issue was solved as per previous instructions and correct way to
> install the program. Thanks all team involved for their efforts and results
> to provide a quick answer.
>
> ________________________________
> De: <email address hidden> <email address hidden> em nome de Mac Abdul <
> <email address hidden>>
> Enviado: quinta-feira, 6 de julho de 2017 08:45:19
> Para: <email address hidden>
> Assunto: Re: [Bug 1688721] Re: Packages that trigger multiple debconf
> prompts fail to install
>
> Whenever i try to install any appliacation i have face this problem ?
> Note : See the screenshot
>
> On Fri, Jun 30, 2017 at 1:06 AM, Launchpad Bug Tracker <
> <email address hidden>> wrote:
>
> > This bug was fixed in the package gnome-software -
> > 3.22.7-0ubuntu3.17.04.5
> >
> > ---------------
> > gnome-software (3.22.7-0ubuntu3.17.04.5) zesty; urgency=medium
> >
> > * debian/patches/0001-snap-Fix-icons-not-being-converted-to-
> > pixbufs.patch:
> > - Fix snaps without icons not showing reliably (LP: #1697565)
> > * debian/patches/0001-snap-Backport-fixes-from-master.patch:
> > - Show featured snaps (LP: #1663097)
> > * debian/patches/0017-Use-snap-name-field-for-app-name.patch:
> > - Dropped, merged into above patch
> >
> > gnome-software (3.22.7-0ubuntu3.17.04.4) zesty; urgency=medium
> >
> > * debian/patches/0006-Add-an-APT-plugin.patch:
> > - Handle multiple debconf connections (LP: #1688721)
> > * debian/patches/0018-Limit-search-entry-to-100-characters.patch:
> > - Limit search entry in case of accidental input (LP: #1692398)
> >
> > gnome-software (3.22.7-0ubuntu3.17.04.3) zesty; urgency=medium
> >
> > * debian/patches/0002-Add-an-APT-plugin.patch:
> > - Fix crash when debconf socket fails (LP: #1689425)
> >
> > -- Robert Ancell <email address hidden> Fri, 16 Jun 2017
> > 13:42:12 +1200
> >
> > ** Changed in: gnome-software (Ubuntu Zesty)
> > Status: Fix Committed => Fix Released
> >
> > --
> > You received this bug notification because you are subscribed to a
> > duplicate bug report (1694521).
> > https://bugs.launchpad.net/bugs/1688721
> >
> > Title:
> > Packages that trigger multiple debconf prompts fail to install
> >
> > Status in gnome-software package in Ubuntu:
> > Fix Released
> > Status in gnome-software source package in Xenial:
> > Fix Released
> > Status in gnome-software source package in Yakkety:
> > Fix Released
> > Status in gnome-software source package in Zesty:
> > Fix Released
> > Status in gnome-software source package in Artful:
> > Fix Released
> >
> > Bug description:
> > [Impact]
> > Some packages stall on installing. These are packages that generate
> > multiple debconf prompts (the prompts may be empty and so not user
> visible,
> > e.g. gconf2-common).
> >
> > [Test Case]
> > 1. Remove gconf2-common (w...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers