Cannot install Debian files outside of the repositories

Bug #1672424 reported by Vague Entertainment on 2017-03-13
280
This bug affects 57 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
gnome-software (Ubuntu)
Critical
Unassigned
Xenial
Critical
Robert Ancell
Yakkety
Critical
Robert Ancell
Zesty
Critical
Robert Ancell

Bug Description

Impact
------
It is not possible to use the default Software app to install .debs for packages that are not already available in Ubuntu.

Test Case
---------
1.
a. Download the .deb for a simple app for your version of Ubuntu directly from Launchpad.
For 16.10, try https://launchpad.net/ubuntu/+source/gnome-clocks/3.22.1-0ubuntu1/
Click amd64 then download the last .deb on that page.

b. Open the .deb with gnome-software:
gnome-software --local-filename=gnome-clocks_3.22.1-0ubuntu1_amd64.deb

gnome-software should open to a page with an Install button for the package.

This test case should already work.

2.
a. Download a .deb that is not already in Ubuntu.
It is important that the package not be available in your local apt cache.
https://www.google.com/chrome/
https://itch.io/app

b. Open the .deb with gnome-software
gnome-software --local-filename=itch_23.2.1_amd64.deb

gnome-software should open to a page with an Install button for the package.

Click Install and verify that the app is installed.

What Happens
------------
The second test fails. On Ubuntu 17.04, I get a popup
"Sorry this did not work The file is not supported"

On Ubuntu 16.04 LTS or 16.10, I get "Sorry this did not work No file_to_app results to show"

Regression Potential
--------------------

Original Bug Report
-------------------
.deb files fail to install from non repository locations i.e. The file manager gnome-software claims "this file type is not supported".

Using dpkg from the command line works as expected so the files aren't corrupt. This happened last distribution as well when it was first released. Might be a regression caused by adding snap package capabilities to the software-center?

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: gnome-software 3.22.6-0ubuntu1
ProcVersionSignature: Ubuntu 4.10.0-13.15-generic 4.10.1
Uname: Linux 4.10.0-13-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.4-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity:Unity7
Date: Mon Mar 13 10:02:00 2017
InstallationDate: Installed on 2017-02-20 (20 days ago)
InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Release amd64 (20161012.2)
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-software
UpgradeStatus: Upgraded to zesty on 2017-02-28 (12 days ago)

Vague Entertainment (bflanagin) wrote :
Jeremy Bicha (jbicha) wrote :

What .deb are you trying to install?

Changed in gnome-software (Ubuntu):
status: New → Incomplete
Jeremy Bicha (jbicha) on 2017-03-14
Changed in gnome-software (Ubuntu):
status: Incomplete → Confirmed
importance: Undecided → Critical
importance: Critical → High
Jeremy Bicha (jbicha) on 2017-03-14
description: updated
Changed in gnome-software (Ubuntu Xenial):
importance: Undecided → High
status: New → Confirmed
Changed in gnome-software (Ubuntu Yakkety):
importance: Undecided → High
status: New → Confirmed
Jeremy Bicha (jbicha) on 2017-03-14
description: updated
tags: added: regression-update
Jeremy Bicha (jbicha) wrote :

Setting Importance to Critical per Step 7 of the SRU Procedure.

https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

I confirm that the test cases work with gnome-software 3.20.1+git20160426.1.a976144-ubuntu-xenial-0ubuntu1 on Ubuntu 16.04 LTS. (That was the famous SRU that fixed this kind of problem shortly after 16.04 LTS's release.)

Changed in gnome-software (Ubuntu):
importance: High → Critical
Changed in gnome-software (Ubuntu Xenial):
importance: High → Critical
Changed in gnome-software (Ubuntu Yakkety):
importance: High → Critical
Jeremy Bicha (jbicha) wrote :

For Ubuntu 16.04 LTS, this broke with

https://launchpad.net/ubuntu/+source/gnome-software/3.20.1+git20161013.0.d77d6cf-0ubuntu2~xenial1

since the test cases pass with the previous version 3.20.1+git20160923.2.7374bdc-0ubuntu1~xenial1

Will Cooke (willcooke) on 2017-03-14
Changed in gnome-software (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
Robert Ancell (robert-ancell) wrote :

I've tried this on Xenial, Yakkety (both QEMU VMs) and Zesty (running directly on my laptop) and all are able to show the downloaded switcheroo-control package. I talked with Jeremy on IRC and he could reproduce, so not sure what's different between the machines..

Jeremy Bicha (jbicha) wrote :

Robert, does it matter that your computer uses a solid state disk drive? I don't have a SSD.

tags: added: rls-z-incoming
Marcos Alano (mhalano) wrote :

I found a plot twist: the package doesn't install if in the same path as user.

So:
# both user and package are in ~/Downloads. Don't work
marcos@marcos-laptop:~/Downloads$ gnome-software --local-filename=google-chrome-stable_current_amd64.deb

# user is in one directory and package are in a subdirectory. Works
marcos@marcos-laptop:~$ gnome-software --local-filename=Downloads/google-chrome-stable_current_amd64.deb

# same as before, but indicating the full path using til. Don't work
marcos@marcos-laptop:~$ gnome-software --local-filename=~/Downloads/google-chrome-stable_current_amd64.deb

# same as before, but indicating the full path normally. Works
marcos@marcos-laptop:~$ gnome-software --local-filename=/home/marcos/Downloads/google-chrome-stable_current_amd64.deb

# different paths, but indicating the relative path using two dots. Don't work
marcos@marcos-laptop:~/Downloads$ gnome-software --local-filename=../google-chrome-stable_current_amd64.deb

# same path, but indicating the relative path using one dot. Works
marcos@marcos-laptop:~$ gnome-software --local-filename=./google-chrome-stable_current_amd64.deb

May be you could understand I can't understand. :)

Download full text (5.3 KiB)

Thats good info! Could this be fixed in by changing how gnome-software is
invoked during local installs or would it need to be done within the
program itself? Its not uncommon for a software (especially one run with
root permissions) to need a full system path. It would also explain why the
"~/" doesn't work as it is a built in alias for /home/$username <---which
changes once the software starts.

On Fri, Mar 24, 2017 at 12:06 PM Marcos Alano <email address hidden>
wrote:

> I found a plot twist: the package doesn't install if in the same path as
> user.
>
> So:
> # both user and package are in ~/Downloads. Don't work
> marcos@marcos-laptop:~/Downloads$ gnome-software
> --local-filename=google-chrome-stable_current_amd64.deb
>
> # user is in one directory and package are in a subdirectory. Works
> marcos@marcos-laptop:~$ gnome-software
> --local-filename=Downloads/google-chrome-stable_current_amd64.deb
>
> # same as before, but indicating the full path using til. Don't work
> marcos@marcos-laptop:~$ gnome-software
> --local-filename=~/Downloads/google-chrome-stable_current_amd64.deb
>
> # same as before, but indicating the full path normally. Works
> marcos@marcos-laptop:~$ gnome-software
> --local-filename=/home/marcos/Downloads/google-chrome-stable_current_amd64.deb
>
> # different paths, but indicating the relative path using two dots. Don't
> work
> marcos@marcos-laptop:~/Downloads$ gnome-software
> --local-filename=../google-chrome-stable_current_amd64.deb
>
> # same path, but indicating the relative path using one dot. Works
> marcos@marcos-laptop:~$ gnome-software
> --local-filename=./google-chrome-stable_current_amd64.deb
>
> May be you could understand I can't understand. :)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1672424
>
> Title:
> Cannot install Debian files outside of the repositories
>
> Status in gnome-software package in Ubuntu:
> Confirmed
> Status in gnome-software source package in Xenial:
> Confirmed
> Status in gnome-software source package in Yakkety:
> Confirmed
>
> Bug description:
> Impact
> ------
> It is not possible to use the default Software app to install .debs for
> packages that are not already available in Ubuntu.
>
> Test Case
> ---------
> 1.
> a. Download the .deb for a simple app for your version of Ubuntu
> directly from Launchpad.
> For 16.10, try
> https://launchpad.net/ubuntu/+source/gnome-clocks/3.22.1-0ubuntu1/
> Click amd64 then download the last .deb on that page.
>
> b. Open the .deb with gnome-software:
> gnome-software --local-filename=gnome-clocks_3.22.1-0ubuntu1_amd64.deb
>
> gnome-software should open to a page with an Install button for the
> package.
>
> This test case should already work.
>
> 2.
> a. Download a .deb that is not already in Ubuntu.
> It is important that the package not be available in your local apt
> cache.
> For this, I made sure that I was not using the GNOME3 Staging PPA. As of
> today, switcheroo-control is not accepted into Ubuntu 17.04.
>
> So I downloaded
> https://launchpad.net/~gnome3-team/+archive/ubuntu/gnome3-staging/+fil...

Read more...

tags: added: rls-aa-incoming
Changed in ubuntu-release-notes:
status: New → Fix Released
Jesse (jessedubord) wrote :

I can confirm this issue is happening to me as well on Ubuntu GNOME 17.04 x64, under X or Wayland (I believe my machines have Ubuntu on SSD's). Any .deb I click on to install will bring up the GNOME Software window. When I click the "install" button, the button presses down/reacts to the click, but it never proceeds with the install. This is confirmed with multiple .deb packages on different machines.

Robert Ancell (robert-ancell) wrote :

The reason this is not working is the gnome-software you are running is not the process that actually shows the package. You will already have gnome-software running so it just passes the string to the existing process. Since this process is probably running in your home directory it doesn't work on non-absolute paths unless you happen to be in your home dir.

summary: - Cannot install Debian files outside of the repositories
+ Installing .debs from the command line fails for non-absolute paths

Note that --local-filename=~/filename.deb doesn't work because '~' is a shell expansion that doesn't occur. It would have been substituted if the command line was --local-filename ~/filename.deb.

Jeremy Bicha (jbicha) wrote :

--local-filename ~/filename.deb doesn't work either

Robert Ancell (robert-ancell) wrote :

commit fd55e2a59f26e99d8daad41737d11145f3cf5ed8
Author: Robert Ancell <email address hidden>
Date: Fri Apr 21 14:15:54 2017 +1200

    Make filename passed with --local-filename absolute.

    If you already have gnome-software running this filename is passed to the
    existing process which is likely to be running in a different working directory.

Robert Ancell (robert-ancell) wrote :

Confirmed using the itch package the page shows but the install button does nothing. So there's at least two bugs here.

summary: - Installing .debs from the command line fails for non-absolute paths
+ Cannot install Debian files outside of the repositories
Robert Ancell (robert-ancell) wrote :

commit 7bd8bd838700682bf4f7fdb8dfc8f26ca5fce04a
Author: Robert Ancell <email address hidden>
Date: Fri Apr 21 16:53:10 2017 +1200

    dpkg: Mark local .debs as managed by APT

Changed in gnome-software (Ubuntu):
status: Confirmed → Fix Committed
Robert Ancell (robert-ancell) wrote :

Found it - the .debs are loaded by GNOME Software but they are not marked with a "management plugin". This cases the apt plugin to reject them when installing (it only installs apps marked as owned by apt).

Iain Lane (laney) wrote :

Robert, can you please check out wip/ubuntu-master when you've got time? These commits should go there I assume? It's a bit behind master atm - we should rev it again soon.

Do local .debs work properly with the packagekit-local plugin?

Robert Ancell (robert-ancell) wrote :

I didn't push the last change to master because I'm not sure of the correct solution there. The apt plugin is not upstream, so it doesn't make sense to set the management plugin to apt (should probably be packagekit?). I don't really get the point of management plugin so I need to ask Richard what to do here.

Changed in gnome-software (Ubuntu Zesty):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.22.7-0ubuntu4

---------------
gnome-software (3.22.7-0ubuntu4) artful; urgency=medium

  * debian/patches/0002-Add-an-APT-plugin.patch:
    - Support debconf prompts (LP: #1679435)
  * debian/patches/0015-dpkg-Mark-local-.debs-as-managed-by-APT.patch:
  * debian/patches/0016-Make-filename-passed-with-local-filename-absolute.patch:
    - Fix local .deb files not being installable: (LP: #1672424)

 -- Robert Ancell <email address hidden> Wed, 26 Apr 2017 15:47:47 +1200

Changed in gnome-software (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-software (Ubuntu Yakkety):
status: Confirmed → Fix Committed
Changed in gnome-software (Ubuntu Xenial):
status: Confirmed → Fix Committed
Changed in gnome-software (Ubuntu Yakkety):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in gnome-software (Ubuntu Xenial):
assignee: nobody → Robert Ancell (robert-ancell)

Hello Vague, or anyone else affected,

Accepted gnome-software into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.22.7-0ubuntu3.17.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Jeremy Bicha (jbicha) on 2017-04-28
description: updated
Jeremy Bicha (jbicha) wrote :

I successfully completed both tests cases on Ubuntu GNOME 17.04 with gnome-software 3.22.7-0ubuntu3.17.04.1. I downloaded the current 17.04 version of gnome-clocks and I downloaded itch and I installed them both with gnome-software (after making sure gnome-software was stopped after updating it).

tags: added: verification-done-zesty verification-needed-xenial verification-needed-yakkety
removed: verification-needed
Aere Greenway (aere) wrote :

Will not install keymusician-keyboard Debian package. gdebi installs it with no problems.

Jeremy Bicha (jbicha) wrote :

Aere, yes, unless you have gnome-software 3.22.7-0ubuntu3.17.04.1 or higher installed, you will experience this bug. If there aren't any problems found with this version, it will be pushed as an update soon, probably next week.

Brian Murray (brian-murray) wrote :

Hello Vague, or anyone else affected,

Accepted gnome-software into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.20.1+git20170427.0.3d09239-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Hello Vague, or anyone else affected,

Accepted gnome-software into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.20.1+git20170427.0.3d09239-0ubuntu1~xenial1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Verified, to work here on 17.04. Thanks for getting it working!

Jeremy Bicha (jbicha) wrote :

Vague Entertainment, thank you for taking the time to help make Ubuntu better. Could you be a bit more specific for the benefit of the Stable Release Update Team?

What specific version of gnome-software did you test? What did you do to test it?

My apologizes,

gnome-software 3.22.7

Downloaded Opera from their site. Installed deb package directly from firefox using "Open" instead of "Save" in download options. Gnome-Software opened and installed the application correctly

Installed Discord canary's deb file from ~/Downloads via Nautilus. This also installed as expected.

Neither scenario worked with earlier versions of gnome-software.

Jeremy Bicha (jbicha) wrote :

Vague Entertainment, thank you but we need a more exact version number.

Can you run apt policy gnome-software and report back what the Installed version is?

shiva (shivoam) wrote :

I have the same problem , can t install .deb in 17.04 (works fine in 16.10 and 16.04
(a vpn software)

Jeremy,

I learn a new command every day :) ...well more like 20

Here you go

gnome-software:
  Installed: 3.22.7-0ubuntu3.17.04.1
  Candidate: 3.22.7-0ubuntu3.17.04.1
  Version table:
 *** 3.22.7-0ubuntu3.17.04.1 500
        500 http://us.archive.ubuntu.com/ubuntu zesty-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     3.22.7-0ubuntu3 500
        500 http://us.archive.ubuntu.com/ubuntu zesty/main amd64 Packages

Will Cooke (willcooke) wrote :

Tested at the same time as #1679435 on Xenial, and I can confirm it fixes the problem.

gnome-software:
  Installed: 3.20.1+git20170427.0.3d09239-0ubuntu1~xenial1
  Candidate: 3.20.1+git20170427.0.3d09239-0ubuntu1~xenial1
  Version table:
 *** 3.20.1+git20170427.0.3d09239-0ubuntu1~xenial1 500
        500 http://gb.archive.ubuntu.com/ubuntu xenial-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     3.20.1+git20170208.0.a34b091-0ubuntu1~xenial1 500
        500 http://gb.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
     3.20.1+git20160420.1.ca63436.ubuntu-xenial-0ubuntu2 500
        500 http://gb.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

tags: added: verification-done-xenial
removed: verification-needed-xenial
Scott Burkhalter (soultech) wrote :

Confirm this passes on zesty

In addition to the requested test cases, I also tested my original use case,

* download a .deb pkg for software not included in ubuntu release - GitKraken v2.5.0 in this case (v.2.5.0.deb)
* open up Home/Desktop folder in Gnome file manager GUI
* double-click on a non-ubuntu .deb package
* once Software app opens up, click on Install button
* Installation proceeded correctly as expected
* Prior to this bug fix, clicking on Install resulted in no behavior at all

Ubuntu/zesty 17.04 64-bit

uname -a
Linux scottong-lt 4.10.0-20-lowlatency #22-Ubuntu SMP PREEMPT Thu Apr 20 10:18:38 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

apt policy gnome-software
gnome-software:
  Installed: 3.22.7-0ubuntu3.17.04.1
  Candidate: 3.22.7-0ubuntu3.17.04.1
  Version table:
 *** 3.22.7-0ubuntu3.17.04.1 100
        100 /var/lib/dpkg/status
     3.22.7-0ubuntu3 500
        500 http://us.archive.ubuntu.com/ubuntu zesty/main amd64 Packages

Rafael Belmonte (eaglescreen) wrote :

Hello, testing gnome-software 3.22.7-0ubuntu3.17.04.2 from zesty-proposed, I tried to install google-chrome-stable.deb version 58.0.3029.96-1 and I could not install it.
Please take a look at bug (LP: #1688721).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gconf2 (Ubuntu Xenial):
status: New → Confirmed
Changed in gconf2 (Ubuntu Yakkety):
status: New → Confirmed
Changed in gconf2 (Ubuntu Zesty):
status: New → Confirmed
Changed in gconf2 (Ubuntu):
status: New → Confirmed
Steve Langasek (vorlon) on 2017-05-06
no longer affects: gconf2 (Ubuntu)
no longer affects: gconf2 (Ubuntu Xenial)
no longer affects: gconf2 (Ubuntu Yakkety)
no longer affects: gconf2 (Ubuntu Zesty)
CrazySky (makarovdenis11) wrote :

Zesty affected too and fix not released!

Will Cooke (willcooke) wrote :

@CrazySky - have you enabled the Proposed repository?
See: https://wiki.ubuntu.com/Testing/EnableProposed

Once you have done that and installed the updated version of GNOME Software then you should be able to install .debs as described above. I have confirmed this is fixed on Zesty, so if you're still having problems please report back.

CrazySky (makarovdenis11) wrote :

@willcooke Is Proposed for testing only?

I mean, why new version not in main repository?

Jorge Morais (jorgemorais) wrote :

@CrazySky
The Ubuntu developers added the potential fix to "proposed" (which is not enabled by default in Ubuntu) so that testers could opt in to get and test it. When the developers are satisfied that the fix has had enough testing, and has passed the tests, then they will add the fix to some other repository ("updates" I think) which is enabled by default.

tags: removed: verification-needed
Robert Ancell (robert-ancell) wrote :

Confirmed fixed in Yakkety (3.20.1+git20170427.0.3d09239-0ubuntu1) by installing Itch from https://itch.io/app.

tags: added: verification-done-yakkety
removed: verification-needed-yakkety
CrazySky (makarovdenis11) wrote :

@jorgemorais Sorry for my question, but can I enable proposed, test the gnome-software and then disable it?

Will this package be updated from updates repo after fix released status?

Jeremy Bicha (jbicha) on 2017-05-08
Changed in gnome-software (Ubuntu Zesty):
status: Fix Committed → Fix Released
Pablo Axeitos (meganoy) wrote :

Trying to install steam right now, opening the deb package with double-click or with the command gnome-software --local-filename=steam_latest.deb opens gnome software, but "install" button does not work.

Proposed activated and software up to date.

Will Cooke (willcooke) wrote :

@meganoy - which version of Ubuntu are you running? I just testing this on 16.04 and it works for me with the steam_latest.deb.

Pablo Axeitos (meganoy) wrote :

I'm actually using a fresh install of Zesty.

gnome-software:
  Instalados: 3.22.7-0ubuntu3.17.04.2
  Candidato: 3.22.7-0ubuntu3.17.04.2
  Tabla de versión:
 *** 3.22.7-0ubuntu3.17.04.2 500
        500 http://es.archive.ubuntu.com/ubuntu zesty-updates/main amd64 Packages
        500 http://es.archive.ubuntu.com/ubuntu zesty-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     3.22.7-0ubuntu3 500
        500 http://es.archive.ubuntu.com/ubuntu zesty/main amd64 Packages

Will Cooke (willcooke) wrote :

Tested here on Zesty and it works for me. Could you check that you've got the latest version of gconf2 installed as well?

gconf2:
  Installed: 3.2.6-3ubuntu7
  Candidate: 3.2.6-3ubuntu7
  Version table:
 *** 3.2.6-3ubuntu7 500
        500 http://archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
        100 /var/lib/dpkg/status

Pablo Axeitos (meganoy) wrote :

gconf2 was not installed (?):

gconf2:
  Instalados: (ninguno)
  Candidato: 3.2.6-3ubuntu7
  Tabla de versión:
     3.2.6-3ubuntu7 500
        500 http://es.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages

After installing gconf2 it works flawlessly.

Thank you very much for your help!!

ryan (raiian12362) wrote :

Still not working. Tried to install Dropbox 64bit deb from Dropbox site. Click install, no response. gdebi worked fine.

Ubuntu Gnome 17.04 x64 kernel 4.10.0-20-generic

I've just made a fresh install of Linux Ubuntu GNOME 17.04 Zesty Zapus, and I immediately ran into the same problem while installing the Opera browser on my system from a .deb package.

The install button STILL DOES NOTHING.

Jeremy Bicha (jbicha) wrote :

Because of how the Software app works, you should restart your computer after installing all updates to get this fix.

Sam Korson (sam-korson) wrote :

Hello,

I still cannot install .deb packages in Software under Ubuntu 17.04, even after enabling zesty-proposed and updating and restarting my computer this morning. I also tried installing gconf2 as suggested by other posts in this topic. I tested trying to install the .deb package opera-stable (opera-stable_44.0.2510.1449_amd64.deb downloaded from their site). The install button reacts to me clicking it but nothing else happens, no longer how long I wait (waited at least 15 minutes). I also tried the instructions in post #8 saying to invoke gnome-software from the command line using an absolute path for the file: gnome-software --local-filename=/home/sam/Downloads/opera-stable_44.0.2510.1449_amd64.deb. Please advise me as to what else I should try. Also, this is on a fresh install of Ubuntu; the only thing I did before trying to install this package is configure my system settings the way I wanted everything.

Thanks,
Sam

gnome-software:
  Installed: 3.22.7-0ubuntu3
  Candidate: 3.22.7-0ubuntu3.17.04.2
  Version table:
     3.22.7-0ubuntu3.17.04.2 500
        500 http://us.archive.ubuntu.com/ubuntu zesty-updates/main amd64 Packages
 *** 3.22.7-0ubuntu3 500
        500 http://us.archive.ubuntu.com/ubuntu zesty/main amd64 Packages
        100 /var/lib/dpkg/status

gconf2:
  Installed: 3.2.6-3ubuntu7
  Candidate: 3.2.6-3ubuntu7
  Version table:
 *** 3.2.6-3ubuntu7 500
        500 http://us.archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
        100 /var/lib/dpkg/status

Jeremy Bicha (jbicha) wrote :

Sam, could you please open a new bug for that issue? Although it may look similar to this bug, it might be something different. You can run this command to open a bug with useful information about your system for the bug triagers:

ubuntu-bug gnome-software

Sam Korson (sam-korson) wrote :

Thanks for the reply but my issue seems to have been resolved now either way; I just noticed that there were some "system updates" available from inside Software and I installed those and rebooted. I can now install .deb files without problems. Great!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.20.1+git20170427.0.3d09239-0ubuntu1

---------------
gnome-software (3.20.1+git20170427.0.3d09239-0ubuntu1) yakkety; urgency=medium

  * New upstream snapshot from the wip/ubuntu-3-20 branch at
    git://git.gnome.org/gnome-software.
    - Support debconf prompts (LP: #1679435)
    - Fix local .deb files not being installable: (LP: #1672424)
  * debian/control:
    - Recommend debconf, libgtk2-perl

 -- Robert Ancell <email address hidden> Thu, 27 Apr 2017 10:44:19 +1200

Changed in gnome-software (Ubuntu Yakkety):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-software has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.20.1+git20170427.0.3d09239-0ubuntu1~xenial1

---------------
gnome-software (3.20.1+git20170427.0.3d09239-0ubuntu1~xenial1) xenial; urgency=medium

  * New upstream snapshot from the wip/ubuntu-3-20 branch at
    git://git.gnome.org/gnome-software.
    - Support debconf prompts (LP: #1679435)
    - Fix local .deb files not being installable: (LP: #1672424)
  * debian/control:
    - Recommend debconf, libgtk2-perl
  * debian/README.source:
    - Update branch name (wip/ubuntu-xenial -> wip/ubuntu-3-20).

 -- Robert Ancell <email address hidden> Thu, 27 Apr 2017 10:44:19 +1200

Changed in gnome-software (Ubuntu Xenial):
status: Fix Committed → Fix Released
Ads20000 (ads20000) wrote :

Jeremy I've filed a bug as requested at bug 1693463. Maybe you could clarify there what's happening in Sam's case, should users be expected to go to the Updates bit of Ubuntu Software to fix this when people expect Software Update to automatically deal with system updates? Is there a way we can prevent users from running into this bug in the first place?

Jeremy Bicha (jbicha) wrote :

I don't see how we can prevent people from running into this bug if they do not install available updates that fix bugs. Some updates like this one also require restarting the computer (or at least the background service).

Ads20000 (ads20000) wrote :

I don't understand why updates have to be manually installed from Ubuntu Software though (and, in this case, it does have to be installed from there), most people expect updates to be installed via the Software Updater? Is there any documentation on this situation where people should update via two separate GUIs?

Jeremy Bicha (jbicha) wrote :

You can install this update from Software Updater like any other system update.

Ads20000 (ads20000) wrote :

My apologies, there was a conflict preventing updates from working and that's why I didn't get the update via Software Updater (filed as bug 1693488 but I don't know how reproducible it is or if it was caused by PPAs). Sorry for taking up your time!

Jai Salzwedel (quantumfuzz) wrote :

For what it's worth, I also had to install this update through the "Updates" tab of Software Center. This was one of several updates there that did not appear in the Software Updater. I didn't try `sudo apt update ; sudo apt upgrade`, so I cannot confirm if I had the same problem as Ads20000.

Changed in gnome-software (Ubuntu):
assignee: Robert Ancell (robert-ancell) → Joo Heung Lee (jooheunglee)
Jeremy (son9ne-junk) wrote :

I too have this issue with third-party .deb files. I have just installed 16.04 in UEFI with / and /home on their own partitions.

When I booted, I updated my box and was able to install Slack using the Software Center. After that, I went to install Chrome and it wouldn't work. Now, no third-party .deb files will install through the software center. I am able to install any default package from the Ubuntu Software Center but I am not able to install any .deb files unless I manually install them using:
`sudo dpkg -i PATH_TO_DEB_FILE.deb`

I have fully updated my system after a fresh install. I ran:

```
sudo apt update
Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:2 http://dl.google.com/linux/chrome/deb stable Release
Hit:4 http://us.archive.ubuntu.com/ubuntu xenial InRelease
Get:5 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Get:6 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Get:7 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]
Fetched 306 kB in 0s (542 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
```

```
sudo apt upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
```

```
sudo apt dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
```

This issue still persists. At this point, I can only install manually.

Changed in gnome-software (Ubuntu):
assignee: Joo Heung Lee (jooheunglee) → Andrew Bumbarger (andrewbumbarger)
Marcel Nemet (marcelnem) wrote :

I still cannot install chrome from the .deb package using Ubuntu software on 16.04.3 with all updates downloaded from us.archive.ubuntu.com/ubuntu.

John Steeves (jstevz4teh1337) wrote :

It used to work with Ubuntu 16.04, but after updating to 16.04.3 and the latest software updates (with the newest version of gnome-software) the issue has re-appeared again. I can't install any .deb packages anymore.
I was able to replicate this issue on 2 clean VMs, so it's not just my computer.

John Steeves (jstevz4teh1337) wrote :

After looking into the release history for gnome-software, I found that the issue might have re-appeared after re-basing gnome-software from version 3.20.1 to the upstream 3.20.5.

AgRoot (agroot82) wrote :

Any ETA on the fix (again) for 16.04? Not only once, but twice, the primary GUI tool to install packages on a LTS release is failing. Things like this don't help in making Linux more appealing to end users.

Robert Ancell (robert-ancell) wrote :

If you are still getting this issue can you please open a new bug with the version of gnome-software you have installed. Since there's been a number of releases it's getting confusing as to what version people are having issues with.

Will Cooke (willcooke) wrote :

I tested this on the version of Software in proposed (3.20.5-0ubuntu0.16.04.6) and it's working there.

So it seems that the fix is already in proposed and should roll out as an update soon.

sam tygier (samtygier) wrote :

I opened Bug #1716230

sun lf (sunblues) on 2017-09-29
Changed in gnome-software (Ubuntu):
assignee: Andrew Bumbarger (andrewbumbarger) → sun lf (sunblues)
assignee: sun lf (sunblues) → nobody
assignee: nobody → sun lf (sunblues)
assignee: sun lf (sunblues) → nobody
Jeremy Bicha (jbicha) wrote :

One problem is that the 3.20.5-0ubuntu0.16.04.6 update got stuck in phased-updates. Also, the similar bug for Ubuntu 17.04 has *never* been fixed for all users because of phased-updates.

https://people.canonical.com/~ubuntu-archive/phased-updates.html

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers