Snaps do not show in categories

Bug #1665126 reported by Dev on 2017-02-15
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
High
Robert Ancell
Xenial
High
Robert Ancell
Artful
Medium
Unassigned
Bionic
High
Robert Ancell

Bug Description

[Impact]
Snaps are not shown in categories.

[Test Case]
1. Open GNOME Software
2. Select "Games" category at the bottom of the page.
3. Select "All"
4. Look for pin-town (a snap game)

Expected result:
Game is shown

Observed result:
Game is not shown.

[Regression Potential]
Loading snap information in category screens could trigger new bugs.

1- I uploaded a snap on myapps.developer.ubuntu.com
2- I choose Category: Games (note that I cannot choose a sub-category (Kids))
3- Default type: ? (I choose application, but not sure what it does exactly)
4- Opening Ubuntu Software on Ubuntu 16.04 I can find and install it when using the search bar
5- BUT my application is not listed in any categories, not even in Games - All
6- After installing the application, I can see it listed in Games - Kids (because the .desktop file have this entry Categories=Game;KidsGame?)

Looks like only .deb are listed in categories within Ubuntu Software?

Dev (devtobo) on 2017-02-15
tags: added: snap
Kyle Fazzari (kyrofa) on 2017-02-15
description: updated
Changed in gnome-software (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
summary: - snap not listed in categories
+ Snaps do not show in categories
Robert Ancell (robert-ancell) wrote :
Changed in gnome-software (Ubuntu):
importance: Medium → High
tags: added: rls-bb-incoming
tags: added: bionic
Robert Ancell (robert-ancell) wrote :
Changed in gnome-software (Ubuntu):
status: Triaged → Fix Committed
assignee: nobody → Robert Ancell (robert-ancell)
Changed in gnome-software (Ubuntu Xenial):
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Robert Ancell (robert-ancell)
Changed in gnome-software (Ubuntu Artful):
status: New → Triaged
importance: Undecided → Medium
Łukasz Zemczak (sil2100) wrote :

This bug is missing the SRU template information. Also, it seems that both the bionic and artful tasks are still not Fix Released? It's hard for me to see if this has been fixed at least in bionic already? If the bug is present in artful as well, we would need it backported to that series as well to make sure users upgrading from xenial to artful do not regress in functionality.

An upload of gnome-software to xenial-proposed has been rejected from the upload queue for the following reason: "Rejected due to various formalities. Please address the questions left on each of the bugs affected and re-upload. Thank you!".

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.27.90-1ubuntu1

---------------
gnome-software (3.27.90-1ubuntu1) bionic; urgency=medium

  * Merge with Debian, remaining changes:
    + debian/patches/*.patch: Various Ubuntu changes from ubuntu-master
      branch - see patch headers for more information.
    + Add an "ubuntu-software" package with some branding for Ubuntu.
    + debian/gnome-software.gsettings-override.in:
      - Mark universe packages as Free.
    + debian/control.in:
      - Recommend Snap plugin
      - GNOME Software provides the PackageKit session interface.
        Sessioninstaller wants to do that too - Conflict with it to get it
        off user systems.
  * Upstream changes fix (LP: #1665126) and (LP: #1750030)

 -- Robert Ancell <email address hidden> Tue, 20 Feb 2018 11:36:59 +1300

Changed in gnome-software (Ubuntu Bionic):
status: Fix Committed → Fix Released
Will Cooke (willcooke) on 2018-03-06
tags: removed: rls-bb-incoming
Changed in gnome-software (Ubuntu Artful):
status: Triaged → Won't Fix
description: updated

Hello Dev, or anyone else affected,

Accepted gnome-software into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.20.5-0ubuntu0.16.04.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-xenial
Robert Ancell (robert-ancell) wrote :

On a fully updated Xenial VM with -proposed enabled I can see pin-town in the games section.

tags: added: verification-done-xenial
removed: verification-needed verification-needed-xenial

The verification of the Stable Release Update for gnome-software has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.20.5-0ubuntu0.16.04.10

---------------
gnome-software (3.20.5-0ubuntu0.16.04.10) xenial; urgency=medium

  * debian/patches/0020-Add-a-Snap-plugin.patch:
  * debian/patches/0015-Don-t-reject-unexpected-state-changes-external-event.patch:
    - Correctly launch snaps with multiple apps (LP: #1661590)
    - Fix snaps not being shown correctly after install from command line
      (LP: #1754655)

gnome-software (3.20.5-0ubuntu0.16.04.9) xenial; urgency=medium

  * debian/patches/0001-Make-app-name-sorting-case-insensitive.patch:
  * debian/patches/0018-Add-a-Snap-plugin.patch:
    - Show snaps in categories (LP: #1665126)
  * debian/patches/0001-trivial-Include-the-fwupd-version-in-the-useragent.patch:
    - Report fwupd version in user agent (LP: #1750030)
  * debian/patches/0050-snap-Support-channels.patch:
    - Support channels (LP: #1750288)
  * debian/README.source:
    - Update git repository to point to gitlab.gnome.org

 -- Robert Ancell <email address hidden> Wed, 28 Mar 2018 17:04:55 +1300

Changed in gnome-software (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers