Some app screenshots wrongly stretched in Ubuntu version of Gnome Software

Bug #1626494 reported by Stuart Langridge on 2016-09-22
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
appstream-dep11 (Ubuntu)
Medium
Unassigned
appstream-generator (Ubuntu)
Medium
Unassigned
gnome-software (Ubuntu)
Medium
Unassigned

Bug Description

Looking at Thunar in Gnome Software, the Ubuntu version of GS stretches the screenshot, making it look ugly. Upstream apparently doesn't do this and uses grey letterboxing. (See attached screenshots.)

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: gnome-software 3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1~16.04.1
ProcVersionSignature: Ubuntu 4.4.0-38.57-generic 4.4.19
Uname: Linux 4.4.0-38-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Sep 22 12:02:12 2016
InstallationDate: Installed on 2014-04-07 (899 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
SourcePackage: gnome-software
UpgradeStatus: Upgraded to xenial on 2016-08-04 (49 days ago)

Stuart Langridge (sil) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu):
status: New → Confirmed
Robert Ancell (robert-ancell) wrote :

I'll pick gnome-calculator as an example since it shows stretched in both Xenial and Yakkety.

The issue seems to be the appstream generator is making stretched thumbnails and gnome-software / appstream-glib is choosing these over the original images. For gnome-calculator (which shows the problem in both Xenial and Yakkety) the dep11 data [1] gives:

From
    source-image:
      height: 285
      url: g/gn/gnome-calculator.desktop/849e24a42d3d86f364e068fc3be7f680/screenshots/source/scr-1.png
      width: 312
    thumbnails:
      - height: 702
        url: g/gn/gnome-calculator.desktop/849e24a42d3d86f364e068fc3be7f680/screenshots/1248x702/scr-1.png
        width: 1248
      - height: 423
        url: g/gn/gnome-calculator.desktop/849e24a42d3d86f364e068fc3be7f680/screenshots/752x423/scr-1.png
        width: 752
      - height: 351
        url: g/gn/gnome-calculator.desktop/849e24a42d3d86f364e068fc3be7f680/screenshots/624x351/scr-1.png
        width: 624
      - height: 63
        url: g/gn/gnome-calculator.desktop/849e24a42d3d86f364e068fc3be7f680/screenshots/112x63/scr-1.png
        width: 112

The large thumbnails are distorted and should not be used/generated.

[1] /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_yakkety_main_dep11_Components-amd64.yml.gz

Robert Ancell (robert-ancell) wrote :

gnome-software / appstream has picked this URL since it most closely matches the desired size:

http://appstream.ubuntu.com/media/main/g/gn/gnome-calculator.desktop/849e24a42d3d86f364e068fc3be7f680/screenshots/624x351/scr-1.png

Changed in gnome-software (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Changed in appstream-generator (Ubuntu):
status: New → Fix Released
importance: Undecided → Medium
Changed in appstream-dep11 (Ubuntu):
importance: Undecided → Medium
Matthias Klumpp (ximion) wrote :

Will never be fixed in appstream-dep11, but is already fixed in appstream-generator (or rather, has never been a bug there).
So, as soon as we switch to asgen, this bug should be gone.

Changed in appstream-dep11 (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers