gnome-software won't open

Bug #1606238 reported by Jaufré Aligé on 2016-07-25
104
This bug affects 23 people
Affects Status Importance Assigned to Milestone
GNOME Software
New
Undecided
Unassigned
gnome-software (Ubuntu)
Critical
william
Nominated for Xenial by Alberto Salvia Novella

Bug Description

Hello,

I upgrade the system from Ubuntu 14.04 to 16.04 some time ago.
At beginning, gnome-software refused to open and I had to remove old ubuntu software and "--reinstall" the gnome-software.
Everything was fine, except for many sorts of packages it can't install so I installed synaptic.

Some days ago, gnome software went on a strike but claimed nothing !
I can open a terminal and call gnome-software : nothing
The launcher turns around in the dock.

Any Idea ?

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: gnome-software 3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1~16.04.1
ProcVersionSignature: Ubuntu 4.4.0-31.50-generic 4.4.13
Uname: Linux 4.4.0-31-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Jul 25 15:28:05 2016
SourcePackage: gnome-software
UpgradeStatus: No upgrade log present (probably fresh install)

Jaufré Aligé (jaufre) wrote :
Jaufré Aligé (jaufre) wrote :

This time, it's a laptop. Old one with amd cpu and 911 nvidia GPU. Nvidia driver 340.

Gnome-software opens and asks for update so every package can be displayed.

I installed updates, removed nvidia driver (nouveau is more stable on this old machine), installed vlc, ffmpeg, libavcodec-extra, libavtools, synaptic, chromium-browser (everything with sudo apt update | remove | install).

Jaufré Aligé (jaufre) wrote :

sry "Old one with AMD cpu and 9100 Nvidia gpu.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu):
status: New → Confirmed
Changed in gnome-software (Ubuntu):
importance: Undecided → Critical
status: Confirmed → Triaged

jaufre, plz type in terminal and show the result: ls ~/.local/share/gnome-software/

Jaufré Aligé (jaufre) wrote :

ls ~/.local/share/gnome-software/
install-queue ubuntu-reviews.db

File install-queue contains the list of package names you were trying to installed. Renaming, moving or deleting this file will restore the normal launching of the gnome-software. Although nothing can be installed (in my case).

I think the reason for this bug lies in gnome-software plugin packagekit-refine. I have no a clue is it upstream big or incorrect building.

gnome-software always building without packagekit support, because configuration script checking its version >= 1.1.0 (libpackagekit-glib2-18), while the current version of libpackagekit-glib2-dev has version number 0.8.17 (libpackagekit-glib2-16). So, we are waiting for the new libpackagekit-glib2.

Jaufré Aligé (jaufre) wrote :

On the desktop machine (from where I reported this bug for the first time)
I just removed every file inside ~/.local/share/gnome-software/ folder.
A moment later (didn't touch the machine), I installed the updates. "sudo apt update && sudo apt full-upgrade -y"
Then I had to go, so I shutted down the computer.
When I turned it on again, I could open ubuntu|gnome software from the dash and installed mypaint without any problem...
The laptop is not mine, so I'll try with it next week.

Well, I downloaded the necessary libraries for yakkety and recompiled the gnome-software with packagekit support, but i got the same result as before.

I found that if you have uncontrolled or unstable network connection, gnome software could not see it and places the selected packages into the queue, instead of installing. After this, gnome software won't open.

For example, if using pppoe with network manager, gnome-software works perfectly, but the sites are opened too slow (in my case, that is why i am using pppoeconf). From other hand, after setting pppoe connection with pppoeconf, the sites are opened quickly, bug gnome-software affected with many assigned bugs which were opened here.

You can check this by starting GS, selecting the tab "upgrades" and clicking update button in the upper left hand corner of the application window. If a message Network is unreachable or something about pop up, than thats the problem.

The logic is very clear - "have no network - can't install".

In any case it is not only ubuntu problem, so this bug can be closed.

Jaufré Aligé (jaufre) wrote :

The problem is that the old ubuntu-software was replaced by GS in 16.04. It is a LTS, it is supposed to be stable and trust me, some professionnals are really pissed of. I have to fix it for free for my customers or they will ask to leave Ubuntu...

I deleted all files from ~/.local/share/gnome-software/ and ran gnome-software
Works well now

stormhike (stormhike) wrote :

I did the same, deleted the contents of ~/.local/share/gnome-software/ and it worked for me too.
By the way, I also renamed the directory gnome-software and that worked as well, a new dir called gnome-software was created during application startup.
It's a workaround but not a fix.

Same problem with Xubuntu 16.04.1 LTS, fully updated (gnome-software 3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1~16.04.1).

Launching gnome-software with terminal does nothing.

Removing the ~/.local/share/gnome-software/ worked as workaround.

Udara Madubhashana (udara) wrote :

Removing the ~/.local/share/gnome-software/ worked for in 16.10 (Yakkety Yak)

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1606238

tags: added: iso-testing
Henk Terhell (hterhell) wrote :

attached error report running gnome-software in Yakkety i386 Lubuntu desktop build 20160921 updated on 2016-09-23.

sudodus (nio-wiklund) wrote :

This bug is valid directly after installation of Lubuntu i386 beta 2 (dated 2016 09 21), but after update & upgrade (2016-09-23 15:17:21 UTC ) it is squashed, so in the next released daily version gnome-software should work.

sudodus (nio-wiklund) wrote :

added 'Yakkety' to the previous post: Lubuntu Yakkety i386 beta 2 (beta testing)

Willem Hobers (whobers) wrote :

I am wondering whether I am seeing the same bug, or something else. Please advice:

Running live session of Xubuntu Yakkety.
Linux xubuntu 4.8.0-11-generic #12-Ubuntu SMP Sat Sep 17 19:59:56 UTC 2016 i686 athlon i686 GNU/Linux

Starting gnome-software through the menu or through typing gnome-software in a terminal, the gnome-software window appears, but freezes. Then, after a few moments, I get an "Invalid error report" dialogue with "No such file or directory".

In the terminal I see: Segmentation fault (core dumped).

In /var/crash/ there is this file _usr_bin_gnome-software.999.crash
Double clicking it gives the same "Invalid error report".

I'm on Ubuntu Gnome 17.04 and experience the very same thing, it loads, but never opens.

Changed in gnome-software (Ubuntu):
status: Triaged → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu):
status: New → Confirmed
hikmah gumelar (hikmahgumelar) wrote :

removing or moved ~/.local/share/gnome-software/install-queue work for 16.04 (xenial)
thank's

Changed in gnome-software (Ubuntu):
assignee: nobody → Mensah Blankson (ebo204199blankson)
Jeremy Bicha (jbicha) on 2017-07-02
Changed in gnome-software (Ubuntu):
assignee: Mensah Blankson (ebo204199blankson) → nobody
william (teoh04) on 2017-08-19
Changed in gnome-software (Ubuntu):
assignee: nobody → william (teoh04)
G Williams (linux4us) on 2017-08-28
Changed in gnome-software (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers