Ubuntu Software tab Installed refreshing endlessly every 2 seconds

Bug #1589585 reported by grofaty on 2016-06-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fwupd (Ubuntu)
High
Unassigned
Xenial
High
Unassigned
Yakkety
High
Unassigned
gnome-software (Ubuntu)
High
Unassigned
Xenial
High
Unassigned
Yakkety
High
Unassigned

Bug Description

I have fresh installed Ubuntu 16.04 Desktop 32-bit. After each install for years one of the first thing I do is uninstall some of the applications that I don't need to preserve some downloading/installing of applications that I don't need.

I opened Ubuntu Software, click on Installed tab and now the problem appears. Every two seconds whole screen gets to gray and refreshing appears which takes 2 seconds. This loops endlessly. It is very frustrating, because Ubuntu Software is unusable in my case.

I have asked the question on forum: http://ubuntuforums.org/showthread.php?t=2326701&p=13498876 and one of suggestion was to remove the software and install it back.

I did:
sudo apt install gnome-software
sudo apt purge gnome-software
sudo apt autoremove
sudo apt autoclean
sudo apt install gnome-software

Started Ubuntu Software and the problem remains the same.

P.S. New problem appeared now Ubuntu Software icon on Launcher is not the same (orange color), but it has changed (white color). But this is not huge problem, just annoyance.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: gnome-software 3.20.1+git20160426.1.a976144-ubuntu-xenial-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-22.40-generic 4.4.8
Uname: Linux 4.4.0-22-generic i686
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: i386
CurrentDesktop: Unity
Date: Mon Jun 6 18:18:47 2016
InstallationDate: Installed on 2016-06-03 (3 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release i386 (20160420.1)
SourcePackage: gnome-software
UpgradeStatus: No upgrade log present (probably fresh install)

grofaty (grofaty) wrote :
description: updated
grofaty (grofaty) wrote :
grofaty (grofaty) wrote :
grofaty (grofaty) wrote :

And one more thing I forgot to write. Don't know if this is related or is separate problem. I have also noticed that despite I close down Ubuntu Software center GUI "gnome-software" process is still occupying 50% of CPU endlessly. In top it gets 50%, then gets lower to 20%, to 0% and after two three seconds it gets back to 50 sometimes 60%.

This is another pain because on my laptop battery is eaten up.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, the journal log suggests the issue is due to fwupd

Changed in gnome-software (Ubuntu):
importance: Undecided → High
Mario Limonciello (superm1) wrote :

It does look like it might be fwupd spinning on some device or gnome-software spinning on fwupd's output.
Can you share the output of the following commands:

# sudo lsusb -vv
# fwupdmgr get-devices

Hopefully that should help in debugging.

Richard Hughes (richard-hughes) wrote :

Also, a "fwupd --verbose" log would be really useful when the CPU is spinning, thanks.

grofaty (grofaty) wrote :

I have executed commands and redirected them in output file.

grofaty (grofaty) wrote :
grofaty (grofaty) wrote :

"fwupd --verbose" command returned error:
fwupd: command not found
also tried with: "sudo fwupd --verbose" and the same result.

Mario Limonciello (superm1) wrote :

Thanks for sharing.

For the --verbose on fwupd, do it like this:

# sudo killall fwupd
# sudo /usr/lib/x86_64-linux-gnu/fwupd/fwupd -v

grofaty (grofaty) wrote :

I have killed the fwupd, but bellow command returns no output. I have checked and there is no x86_64-linux-gnu subdirectory.

Just in case if you have overlooked I have 32-bit PC (see my first post in bug report).

Mario Limonciello (superm1) wrote :

Oh sorry, 32 bit does have a different location. I forgot your report was on 32 bit.

Try:

# sudo /usr/lib/i386-linux-gnu/fwupd/fwupd -v

grofaty (grofaty) wrote :

I have put both standard error and standard output to file. It looks like this command gets into endless loop. After few minutes I have terminated the command. I compressed the file. Please extract it with: tar xf fwupd_v.tar.gz

Changed in fwupd (Ubuntu):
importance: Undecided → High

Can someone decompress that and put the important bits on a pastebin pls? I'm on holiday and only have my phone and slow internet.

Mario Limonciello (superm1) wrote :

Here's that snapshot:
http://paste.ubuntu.com/17413188/

Your logs say you have two USB devices; that mouse and a fingerprint reader. I think the one that keeps dropping on and off the bus is the fingerprint reader.

Are you doing anything special with fprint or some other finger print software that might be fighting with fwupd on trying to take this device?

grofaty (grofaty) wrote :

On this laptop several years back I had Windows installed and I configured figerprint to work. When using it I got my hair grey. I can type very fast with 10 finger blind, so I can type password much faster then use the fingerprint. Fingerprint is problem, sometimes it works, sometimes id does not. Don't like it.

Then when I have purge Windows I installed Ubuntu (don't know with version it was several years back) and never have any problem with spinning or CPU eating. Now when I have fresh install Ubuntu 16.04 I got directly into a problem.

It may be a driver problem or something similar. Don't know.

The answer: I don't do anything special with figerprint reader. Actually if special means I am not using it, then I'm doing something special. :)

Is there a way to disable this device or uninstall driver, because I just don't need it.

By the way if it helps I am using Thinkpad T60 laptop (at the time I have got it, it was IBM laptop, now this laptops are Lenovo). It looks like this is hardware specification: https://support.lenovo.com/si/sl/documents/migr-62722

I'd be interested to hear if the no-open-device fix for fwupd would also help here, although this does look like the device reconnecting wildly (hardware issue?) like Mario said.

Mario Limonciello (superm1) wrote :

That no-open fix was specifically for the DFU endpoint wasn't it? So if something like that is what's needed for this scenario probably still needs to be put together.

Alright so I think there are a few more interesting data point that are needed here.
1) What's the kernel got to say about all these disconnects and reconnects? Can you share your dmesg from a boot with fwupd present and running.
If you've got some dying hardware, it's possible that fwupd is just behaving badly based upon what it's seeing.

2) It would also be interesting to see what it looks like when fwupd is not running. To see this move the auto start service out the way, power off, power on, share your dmesg, and put it back.
# sudo mv /etc/xdg/autostart/gnome-software-service.desktop ~
# sudo poweroff
<turn on machine>
<check dmesg>
# sudo mv ~/gnome-software-service.desktop /etc/xdg/autostart

3) Check and see if you can turn off your finger print reader in the BIOS. If you can, that should at least help with this problem for now until we can figure out what's really going on.

grofaty (grofaty) wrote :

@Mario,
I hope I understood you correctly. I am not an expert on this field...

At 1) I did a "ps" to check if fwupd is running see 1_ps.txt
Then I executed "dmesg > 1_dmesg.txt"

At 2) First free steps I did as instructed. Don't know what exactly "<check dmesg>" means. I did "dmesg > 2_dmesg.txt"

At 3) I have check the BIOS and can't see any option to turn off finger print reader. There are only some Normal/High and similar options in BIOS in Security section. Can't see an option to completely disable a device.

Additional info 1: I have tried to 'lsusb' for several times in about one second each and I see bumping up and disappearing and bump up again and disappearing. Don't know if this is normal. It looks strange to me... See lsusb.txt file.

Additional info 2: My laptop battery has died and now I have to have power cable stuck into electric power non-stop. This is an old laptop and I don't use it at road, so I don't intent to by another battery. Don't know if this is related to this problem or not.

grofaty (grofaty) wrote :
grofaty (grofaty) wrote :
grofaty (grofaty) wrote :
grofaty (grofaty) wrote :
grofaty (grofaty) wrote :

I have also executed "lsusb -t" and it looks like it is displaying new device, then disappearing and appearing with new device again. See lsusb_t.txt attachment.

grofaty (grofaty) wrote :

Hi,
just a quick question. I also have a problem with audio. Is this problem related to "fwupd and audio"? When starting "VLC Media Player" I get error:
==============
Audio output failed:
The audio device "default" could not be used:
Connection refused.
==============

looking into "System Setting" | Sound and on Ouput and Input there are no devices specified and on "Sound Effects" there is only "default". I know this was working before seeing the devices here. The "default" from VLC error is probably the "default" from "Sound Effects".

I was searching the web and found this "USB audio device is not recognized after startup in 16.04" with URL: https://bugs.launchpad.net/ubuntu/+source/fwupd/+bug/1574079 and there is reference to "fwupd" and gnome-software.

What I am wondering maybe there is common cause for my problem "gnome-sofware" endless spinning (current bug report) and VLC/audio problem.

Looks like there were some fixed developed and are currently in "proposed" repository.

What do you think? Are this problems related?

P.S. I have also posted a question on Lenovo forum, to see if someone knows how to disable (if possible) figerprint device in BIOS: https://forums.lenovo.com/t5/ThinkPad-T61-and-prior-T-series/How-to-disable-Figerprint-Reader-in-BIOS-or-in-Ubuntu-16-04/td-p/3353318

Regards

Sebastien Bacher (seb128) wrote :

what you describe with audio seems like the bug that SRU is trying to resolve
https://launchpad.net/ubuntu/+source/fwupd/0.7.0-0ubuntu4.2

could you try if the update helps for your issue?

Mario Limonciello (superm1) wrote :

@seb128:
Although he mentions audio and that other issue mentions audio I don't believe them to be the same issue. Specifically that issue deals with USB Audio devices that contain a DFU endpoint. He doesn't have a USB audio device contained here.

@grofaty:
As long as you followed the steps properly and fwupd wasn't running when you collected the second dmesg (dmesg_2.txt) to me it looks like there is a hardware or kernel issue with your machine causing the USB device to drop off the bus continually. Since not caused by fwupd, there's not much fwupd can do in this instance. It is reporting new USB devices just like the kernel is (which is causing it to check for updates every time a new device is reported).

This is exacerbated by the fact that the combination of gnome-software 3.20.x and fwupd 0.7.0 will check for updates every time a USB device is hotplugged.
More information about that is here:
https://github.com/hughsie/fwupd/issues/48

In order to resolve that, Ubuntu would need to move to gnome-software >= 3.21.0 and fwupd >= 0.7.1.

Changed in fwupd (Ubuntu):
status: New → Invalid
Sebastien Bacher (seb128) wrote :

@Mario, even if the usb is flacky those fwupd warnings could/should be fixed no? it could probably happen on normal use with user connecting/disconnecting some device as well right?

Changed in fwupd (Ubuntu):
status: Invalid → New
Mario Limonciello (superm1) wrote :

What @grofaty was seeing was that his gnome-software was refreshing constantly. He didn't say any warnings were emitted other than when he ran fwupd in verbose mode.

If a user disconnected/reconnected a device gnome-software will refresh, yes. But as mentioned in https://github.com/hughsie/fwupd/issues/48 that's the behavior of gnome-software 3.20.x. Moving to g-s 3.21 and fwupd >= 0.7.1 will prevent that, but won't fix the underlying problem that @grofaty is encountering with a USB device that's dropping on and off the bus.

grofaty (grofaty) wrote :

At #26, I have updated "sudo apt get update && sudo apt full-upgrade -f" Ubuntu from official repository (according to fuwpd/audio bug report, fix was moved out of proposed) and fwupd update was upgraded in my case. I restarted computer and audio problem still persists. OK, this is another problem I will need to solve in the near future and it looks like not related to current bug report.

At #26, I tried to get help from Lenovo forum how to disable "figerprint reader" and first attempt was not successful. I asked for additional explanation. Hope there is some BIOS setting to turn it of.

Mario Limonciello (superm1) wrote :

I'm going to set both of these to triaged. In order to resolve the warnings being emitted continually, it will require moving to:

fwupd 0.7.1+
gnome-software 3.21

It won't fix grofaty's underlying issue (stuff falling off the bus continually) but it will at least prevent that from causing a check for FW updates over and over.

Changed in fwupd (Ubuntu):
status: New → Triaged
Changed in gnome-software (Ubuntu):
status: New → Triaged
Changed in fwupd (Ubuntu Xenial):
status: New → Triaged
Changed in gnome-software (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → High
Changed in fwupd (Ubuntu Xenial):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fwupd - 0.7.2-0ubuntu1

---------------
fwupd (0.7.2-0ubuntu1) yakkety; urgency=medium

  * new upstream version.
  * fixes fwupd half of (LP: #1589585)
  * drop patches upstream.
  * update symbols.

 -- Mario Limonciello <email address hidden> Fri, 19 Aug 2016 12:32:05 -0500

Changed in fwupd (Ubuntu Yakkety):
status: Triaged → Fix Released
Changed in gnome-software (Ubuntu):
status: Triaged → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers