Install button still shows after Installing app

Bug #1583403 reported by SunBear on 2016-05-19
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
Undecided
Unassigned

Bug Description

[What Happens]
==============
Installing
----------
1. Open the Software app (GNOME Software). Search for clocks.
2. Click Install next to Clocks.
3. The Install button becomes insensitive and changes to Installing...
4. The Install button becomes sensitive again and changes back to Install (it should have changed to Remove)
5. If you click the Clocks row (still in the All page), the Clocks info page opens with an Install button (it should have a Launch button and a Remove button).
6. If you switch to the Installed page, Clocks correctly shows up with a Remove button.
7. If you click the Clocks row in the Installed page, the Clocks info page correctly opens with a Launch button and a Remove button.
8. Close the Software app then reopen it. Same results as #4-7 above.
9. $ pkill gnome-software
10. Open the Software app. Now Clocks shows up correctly in the All page with a Remove button and the Clocks info page correctly includes the Launch and Remove buttons but not the Install button.

Removing
--------
11. Click the Remove button to uninstall Clocks.
12. The Remove button becomes insensitive again and changes to Removing...
12. We basically get the same broken results as before. In the All page, the Clocks row shows Remove still. Clicking the Clocks row shows the Info page with Launch and Remove.
One change is that in the Installed page, Clocks shows up twice, once with an Install button, once with a Remove button.
Completely stopping the gnome-software process (via logging out or the pkill trick mentioned in #9) is necessary for the Software app to correctly register Clocks as being removed.

I was unable to reproduce this bug with Fedora 24.

[Original Bug Report]
=====================
Problems & Actions:
- I noticed that after removing an app, the status button of the App do not correctly reflect the updated status. Neither is the removed App removed from the Installed tab immediately after a removal.
- I notice a lot failures and warnings in my syslog within just 10 mins of using gnome-software.
- I hope these info can help figure out the issues and provide a bug fix soon.

(removed warnings that don't seem relevant)

Jeremy Bicha (jbicha) wrote :

The packagekit.trigger-offline-update warning is bug 1592123.

I hope you don't mind that I added more information to what I think is the issue you experienced and removed the warning messages from the bug description.

description: updated
summary: - gnome-software Button widget status do not correctly reflect updated
- status and generates a lot of Gs-WARNING in syslog
+ Install button still shows after Installing app
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2016-06-13
description: updated
tags: added: xenial yakkety
kim (kim--e) on 2016-06-14
Changed in gnome-software (Ubuntu):
status: Confirmed → Incomplete
Jeremy Bicha (jbicha) on 2016-06-14
Changed in gnome-software (Ubuntu):
status: Incomplete → Confirmed
Kev Bowring (flocculant) wrote :

possibly a dupe of bug 1551599

Jeremy Bicha (jbicha) wrote :

Thanks, I copied my verbose bug description over there and am marking this a duplicate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers