after pressing the refresh icon in "udpates", all available software dissapear except the ones already installed

Bug #1572669 reported by Set Hallstrom on 2016-04-20
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
High
Unassigned

Bug Description

To reproduce:

- Start Gnome software
- Go to "Updates"
- Press circular arrow button for refresh
- Go back to "all".

Result: all software proposition are gone, except the ones already installed
Expected result: The main panel should list all available software from the repository.

- Press the "close window button"
- Restart Gnome software

Result: nothing happened
Expected result: The main panned should show all available software from the repository.

- Press "Quit" in the upper-left menu
- Restart Gnome software

Result: now gnome software lists all apps from repository as expected.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: gnome-software 3.20.1+git20160419.2.b8d2e40.ubuntu-xenial-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-21.37-lowlatency 4.4.6
Uname: Linux 4.4.0-21-lowlatency x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CurrentDesktop: XFCE
Date: Wed Apr 20 18:48:46 2016
InstallationDate: Installed on 2016-04-20 (0 days ago)
InstallationMedia: Ubuntu-Studio 16.04 LTS "Xenial Xerus" - Release amd64 (20160419)
SourcePackage: gnome-software
UpgradeStatus: No upgrade log present (probably fresh install)

Set Hallstrom (sakrecoer) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1572669

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, that should be fixed in https://launchpad.net/ubuntu/+source/gnome-software/3.20.1+git20160420.1.ca63436.ubuntu-xenial-0ubuntu1 ... could you try if you still get the issue?

Changed in gnome-software (Ubuntu):
importance: Undecided → High
status: Confirmed → Incomplete
Ross Gammon (rosco2) wrote :

Although I can not see any reference to the bug in the changelog, this problem seems to have gone away during the two uploads on the 20th April 2016.

It works for me and Set also confirms that it is OK now. So closing the bug.

Changed in gnome-software (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers