Version unknown of not-installed applications, it appears for installed ones

Bug #1564621 reported by Amr Ibrahim on 2016-03-31
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
gnome-software (Ubuntu)
High
Unassigned
Xenial
High
Unassigned

Bug Description

Impact
non-installed software don't have a version info

Test case
start gnome-software, click on a non installed software, the version should be a number instead of "unknown"

Regression potential
having this information requires adding infos to items which didn't have some, so means more backend work which might slow down things

----------------------

Applications show their version unknown in the Details section when they are not installed. The version shows up for installed applications.

Version should appear for both not-installed and installed applications.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu):
status: New → Confirmed
tags: added: xenial
Changed in gnome-software (Ubuntu):
importance: Undecided → High
tags: added: rls-x-incoming
Changed in gnome-software (Ubuntu):
importance: High → Medium
Changed in ubuntu-release-notes:
status: New → Fix Released
Changed in gnome-software (Ubuntu):
importance: Medium → High
summary: - Version unkown of not-installed applications, it appears for installed
+ Version unknown of not-installed applications, it appears for installed
ones
tags: added: trello-import
Will Cooke (willcooke) on 2016-04-25
tags: removed: trello-import
Changed in gnome-software (Ubuntu):
status: Confirmed → Fix Committed
description: updated

Hello Amr, or anyone else affected,

Accepted gnome-software into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.20.1+git20160426.1.a976144-ubuntu-xenial-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-software (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Amr Ibrahim (amribrahim1987) wrote :

After updating to the version in xenial-proposed, I had to end the gnome-software process because it was open in the background.

It is fixed. I can see the version of non-installed apps.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.20.1+git20160426.1.a976144-ubuntu-xenial-0ubuntu1

---------------
gnome-software (3.20.1+git20160426.1.a976144-ubuntu-xenial-0ubuntu1) xenial; urgency=medium

  * New upstream snapshot from the wip/ubuntu-xenial branch at
    git://git.gnome.org/gnome-software.
    - Recognize apt: urls (LP: #1559185)
    - Increase the number of displayed reviews from 10 to 30 (LP: #1559284)
    - Show version information for non-installed apps (LP: #1564621)
    - Show size information for non-installed apps (LP: #1571414)
    - Fix sideloading of local .deb files (LP: #1573408)
    - Enable the Snappy backend (LP: #1575104)

 -- William Hua <email address hidden> Tue, 26 Apr 2016 14:55:05 +0200

Changed in gnome-software (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-software (Ubuntu Xenial):
importance: Undecided → High
Changed in gnome-software (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-software has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in ubuntu-release-notes:
assignee: nobody → Francis Bwalya (74kays+mcfrance)
Changed in ubuntu-release-notes:
assignee: Francis Bwalya (74kays+mcfrance) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers