Activity log for bug #1551599

Date Who What changed Old value New value Message
2016-03-01 08:11:04 Kev Bowring bug added bug
2016-03-01 08:11:04 Kev Bowring attachment added installed.png https://bugs.launchpad.net/bugs/1551599/+attachment/4585157/+files/installed.png
2016-03-01 08:11:15 Kev Bowring summary Optioon to remove missing after package installation Option to remove missing after package installation
2016-03-01 08:11:38 Kev Bowring attachment added now can uninstall.png https://bugs.launchpad.net/ubuntu/+source/gnome-software/+bug/1551599/+attachment/4585161/+files/now%20can%20uninstall.png
2016-03-03 16:35:24 Kev Bowring summary Option to remove missing after package installation Option to remove icon missing after package installation
2016-03-04 13:46:24 Launchpad Janitor gnome-software (Ubuntu): status New Confirmed
2016-03-04 14:16:10 Ubuntu QA Website tags amd64 apport-bug xenial amd64 apport-bug iso-testing xenial
2016-03-06 19:51:06 Alberto Salvia Novella gnome-software (Ubuntu): importance Undecided High
2016-03-06 19:51:20 Alberto Salvia Novella bug task added hundredpapercuts
2016-03-06 19:51:25 Alberto Salvia Novella hundredpapercuts: status New Confirmed
2016-03-06 19:51:27 Alberto Salvia Novella hundredpapercuts: importance Undecided High
2016-04-20 13:35:26 William Hua summary Option to remove icon missing after package installation Remove button missing after package installation
2016-04-24 04:05:43 Mathew Hodson bug task added ubuntu-release-notes
2016-04-24 04:05:49 Mathew Hodson ubuntu-release-notes: status New Fix Released
2016-04-24 04:05:53 Mathew Hodson gnome-software (Ubuntu): importance High Medium
2016-05-05 05:34:29 Alberto Salvia Novella hundredpapercuts: importance High Medium
2016-05-05 05:35:04 Alberto Salvia Novella gnome-software (Ubuntu): importance Medium Low
2016-05-05 05:35:07 Alberto Salvia Novella hundredpapercuts: importance Medium Low
2016-05-05 05:35:12 Alberto Salvia Novella hundredpapercuts: importance Low Medium
2016-05-05 05:35:14 Alberto Salvia Novella gnome-software (Ubuntu): importance Low Medium
2016-05-18 01:49:08 Jeremy Bicha bug added subscriber Jeremy Bicha
2016-06-14 16:46:21 Jeremy Bicha description Used gnome-software to install a package. Once it was installed I expected to see an option to remove it. As can be seen all I see is the option to Install the package. If you click Install you are then given the option to remove the package. ProblemType: Bug DistroRelease: Ubuntu 16.04 Package: gnome-software 3.19.91~git20160229.ceb6b9d-0ubuntu1 ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2 Uname: Linux 4.4.0-8-generic x86_64 ApportVersion: 2.20-0ubuntu3 Architecture: amd64 CurrentDesktop: XFCE Date: Tue Mar 1 08:05:06 2016 InstallationDate: Installed on 2015-10-29 (123 days ago) InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20151029) SourcePackage: gnome-software UpgradeStatus: No upgrade log present (probably fresh install) [What Happens] ============== Installing ---------- 1. Open the Software app (GNOME Software). Search for clocks. 2. Click Install next to Clocks. 3. The Install button becomes insensitive and changes to Installing... 4. The Install button becomes sensitive again and changes back to Install (it should have changed to Remove) 5. If you click the Clocks row (still in the All page), the Clocks info page opens with an Install button (it should have a Launch button and a Remove button). 6. If you switch to the Installed page, Clocks correctly shows up with a Remove button. 7. If you click the Clocks row in the Installed page, the Clocks info page correctly opens with a Launch button and a Remove button. 8. Close the Software app then reopen it. Same results as #4-7 above. 9. $ pkill gnome-software 10. Open the Software app. Now Clocks shows up correctly in the All page with a Remove button and the Clocks info page correctly includes the Launch and Remove buttons but not the Install button. Removing -------- 11. Click the Remove button to uninstall Clocks. 12. The Remove button becomes insensitive again and changes to Removing... 12. We basically get the same broken results as before. In the All page, the Clocks row shows Remove still. Clicking the Clocks row shows the Info page with Launch and Remove. One change is that in the Installed page, Clocks shows up twice, once with an Install button, once with a Remove button. Completely stopping the gnome-software process (via logging out or the pkill trick mentioned in #9) is necessary for the Software app to correctly register Clocks as being removed. I was unable to reproduce this bug with Fedora 24. See also bug 1582959 which is similar but a bit different. [Original bug report] ===================== Used gnome-software to install a package. Once it was installed I expected to see an option to remove it. As can be seen all I see is the option to Install the package. If you click Install you are then given the option to remove the package. ProblemType: Bug DistroRelease: Ubuntu 16.04 Package: gnome-software 3.19.91~git20160229.ceb6b9d-0ubuntu1 ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2 Uname: Linux 4.4.0-8-generic x86_64 ApportVersion: 2.20-0ubuntu3 Architecture: amd64 CurrentDesktop: XFCE Date: Tue Mar 1 08:05:06 2016 InstallationDate: Installed on 2015-10-29 (123 days ago) InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20151029) SourcePackage: gnome-software UpgradeStatus: No upgrade log present (probably fresh install)
2017-01-10 14:41:22 Temondong gnome-software (Ubuntu): assignee Temondong (temondong787)
2017-03-24 17:04:26 Jeremy Bicha gnome-software (Ubuntu): importance Medium High
2017-03-24 17:04:29 Jeremy Bicha gnome-software (Ubuntu): assignee Temondong (temondong787)
2017-04-03 23:29:57 Jeremy Bicha description [What Happens] ============== Installing ---------- 1. Open the Software app (GNOME Software). Search for clocks. 2. Click Install next to Clocks. 3. The Install button becomes insensitive and changes to Installing... 4. The Install button becomes sensitive again and changes back to Install (it should have changed to Remove) 5. If you click the Clocks row (still in the All page), the Clocks info page opens with an Install button (it should have a Launch button and a Remove button). 6. If you switch to the Installed page, Clocks correctly shows up with a Remove button. 7. If you click the Clocks row in the Installed page, the Clocks info page correctly opens with a Launch button and a Remove button. 8. Close the Software app then reopen it. Same results as #4-7 above. 9. $ pkill gnome-software 10. Open the Software app. Now Clocks shows up correctly in the All page with a Remove button and the Clocks info page correctly includes the Launch and Remove buttons but not the Install button. Removing -------- 11. Click the Remove button to uninstall Clocks. 12. The Remove button becomes insensitive again and changes to Removing... 12. We basically get the same broken results as before. In the All page, the Clocks row shows Remove still. Clicking the Clocks row shows the Info page with Launch and Remove. One change is that in the Installed page, Clocks shows up twice, once with an Install button, once with a Remove button. Completely stopping the gnome-software process (via logging out or the pkill trick mentioned in #9) is necessary for the Software app to correctly register Clocks as being removed. I was unable to reproduce this bug with Fedora 24. See also bug 1582959 which is similar but a bit different. [Original bug report] ===================== Used gnome-software to install a package. Once it was installed I expected to see an option to remove it. As can be seen all I see is the option to Install the package. If you click Install you are then given the option to remove the package. ProblemType: Bug DistroRelease: Ubuntu 16.04 Package: gnome-software 3.19.91~git20160229.ceb6b9d-0ubuntu1 ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2 Uname: Linux 4.4.0-8-generic x86_64 ApportVersion: 2.20-0ubuntu3 Architecture: amd64 CurrentDesktop: XFCE Date: Tue Mar 1 08:05:06 2016 InstallationDate: Installed on 2015-10-29 (123 days ago) InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20151029) SourcePackage: gnome-software UpgradeStatus: No upgrade log present (probably fresh install) [What Happens] ============== Installing ---------- 1. Open the Software app (GNOME Software). Search for clocks. 2. Click Install next to Clocks. 3. The Install button becomes insensitive and changes to Installing... 4. The Install button becomes sensitive again and changes back to Install (it should have changed to Remove) 5. If you click the Clocks row (still in the All page), the Clocks info page opens with an Install button (it should have a Launch button and a Remove button). 6. If you switch to the Installed page, Clocks correctly shows up with a Remove button. 7. If you click the Clocks row in the Installed page, the Clocks info page correctly opens with a Launch button and a Remove button. 8. Close the Software app then reopen it. Same results as #4-7 above. 9. $ pkill gnome-software 10. Open the Software app. Now Clocks shows up correctly in the All page with a Remove button and the Clocks info page correctly includes the Launch and Remove buttons but not the Install button. Removing -------- 11. Click the Remove button to uninstall Clocks. 12. The Remove button becomes insensitive again and changes to Removing... 12. We basically get the same broken results as before. In the All page, the Clocks row shows Remove still. Clicking the Clocks row shows the Info page with Launch and Remove. One change is that in the Installed page, Clocks shows up twice, once with an Install button, once with a Remove button. Completely stopping the gnome-software process (via logging out or the pkill trick mentioned in #9) is necessary for the Software app to correctly register Clocks as being removed. I was unable to reproduce this bug with Fedora 24. Other Info ========== See also bug 1582959 which is similar but a bit different. In bug 1679417, a user reported that the package disappears from the Installed list if Remove is selected but password authentication is cancelled or failed. [Original bug report] ===================== Used gnome-software to install a package. Once it was installed I expected to see an option to remove it. As can be seen all I see is the option to Install the package. If you click Install you are then given the option to remove the package. ProblemType: Bug DistroRelease: Ubuntu 16.04 Package: gnome-software 3.19.91~git20160229.ceb6b9d-0ubuntu1 ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2 Uname: Linux 4.4.0-8-generic x86_64 ApportVersion: 2.20-0ubuntu3 Architecture: amd64 CurrentDesktop: XFCE Date: Tue Mar 1 08:05:06 2016 InstallationDate: Installed on 2015-10-29 (123 days ago) InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20151029) SourcePackage: gnome-software UpgradeStatus: No upgrade log present (probably fresh install)
2017-05-14 16:59:27 Jeremy Bicha nominated for series Ubuntu Xenial
2017-05-14 16:59:27 Jeremy Bicha bug task added gnome-software (Ubuntu Xenial)
2017-05-14 16:59:27 Jeremy Bicha nominated for series Ubuntu Zesty
2017-05-14 16:59:27 Jeremy Bicha bug task added gnome-software (Ubuntu Zesty)
2017-05-14 16:59:27 Jeremy Bicha nominated for series Ubuntu Yakkety
2017-05-14 16:59:27 Jeremy Bicha bug task added gnome-software (Ubuntu Yakkety)
2017-05-14 16:59:37 Jeremy Bicha gnome-software (Ubuntu Xenial): status New Confirmed
2017-05-14 16:59:40 Jeremy Bicha gnome-software (Ubuntu Xenial): importance Undecided High
2017-05-14 16:59:43 Jeremy Bicha gnome-software (Ubuntu Yakkety): status New Confirmed
2017-05-14 16:59:47 Jeremy Bicha gnome-software (Ubuntu Yakkety): importance Undecided High
2017-05-14 16:59:50 Jeremy Bicha gnome-software (Ubuntu Zesty): importance Undecided High
2017-05-14 16:59:54 Jeremy Bicha gnome-software (Ubuntu Zesty): status New Confirmed
2017-05-14 16:59:57 Jeremy Bicha gnome-software (Ubuntu): status Confirmed Fix Released