It only shows installed apps, not available ones

Bug #1548933 reported by corrado venturini on 2016-02-23
76
This bug affects 12 people
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
High
Robert Ancell

Bug Description

I have gnome-software Version: 3.19.91~git20160223.1794342-0ubuntu1 and I see only apps already installed. No way to install new apps.

Linux corrado-xenial 4.4.0-7-generic #22-Ubuntu SMP Thu Feb 18 20:50:38 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu):
status: New → Confirmed
shankao (shankao) on 2016-02-25
summary: - 3.19.91~git20160223.1794342 I see only apps already installed Asked by
- corrado venturini 2 hours ago
+ It only shows installed apps
summary: - It only shows installed apps
+ It only shows installed apps, not available ones
Iain Lane (laney) wrote :

(I removed a part of the description that was describing a different bug)

I see this too with 3.19.91~git20160225.dbf5b5d-0ubuntu2.

If I roll back to version 3.19.5+git20160212.a64f331-0ubuntu1 then they appear again, so I believe that gnome-software itself is responsible here. appstreamcli can find uninstalled components just the same.

On the console I see this

description: updated
Iain Lane (laney) wrote :

oops, forgot to tab away before collecting this output :)

I see:

  (gnome-software:10370): Gs-DEBUG: app invalid as state unknown robocode.desktop

for all uninstalled applications.

Changed in gnome-software (Ubuntu):
importance: Undecided → High
amjjawad  (amjjawad) wrote :

Testing Ubuntu GNOME amd64 16.04 beta (build: 20160225.1) on Oracle VirtualBox. It happens with the Live Session and it is also happening after I install the system.

To re-produce it:
1- Open GNOME Software
2- Type any package
3- You should see "No application found" message.
4- You're suppose to see only the installed packages.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: gnome-software 3.19.91~git20160225.dbf5b5d-0ubuntu2
ProcVersionSignature: Ubuntu 4.4.0-7.22-generic 4.4.2
Uname: Linux 4.4.0-7-generic x86_64
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CurrentDesktop: GNOME
Date: Thu Feb 25 23:28:02 2016
InstallationDate: Installed on 2016-02-25 (0 days ago)
InstallationMedia: Ubuntu-GNOME 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160225.1)
SourcePackage: gnome-software
UpgradeStatus: No upgrade log present (probably fresh install)

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1548933

tags: added: iso-testing
Changed in gnome-software (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.19.91~git20160229.ceb6b9d-0ubuntu1

---------------
gnome-software (3.19.91~git20160229.ceb6b9d-0ubuntu1) xenial; urgency=medium

  * New upstream snapshot
  * debian/control:
    - Bump build-depends on libappstream-glib-dev
  * debian/patches/apt-plugin.patch:
    - Fix setting of app state (LP: #1548933)

 -- Robert Ancell <email address hidden> Mon, 29 Feb 2016 14:49:12 +1300

Changed in gnome-software (Ubuntu):
status: Confirmed → Fix Released
Kev Bowring (flocculant) wrote :

Just got this upgrade - not sure this is fixed.

attached screenshot to show

(also - it tells me the system is up to date - checked recently - I know for a fact it's not, postfix is still not upgrading)

Changed in gnome-software (Ubuntu):
status: Fix Released → Triaged
Kev Bowring (flocculant) wrote :

appstream upgraded this morning - I now see the repos

featured and editors picks gone

Sebastien Bacher (seb128) wrote :

That issue has been fixed, a new bug should be reported about the featured/editor picks one

Changed in gnome-software (Ubuntu):
status: Triaged → Fix Released
Jeff Lane (bladernr) wrote :

What version is this fixed in?

gnome-software:
  Installed: 3.19.91~git20160229.ceb6b9d-0ubuntu1
  Candidate: 3.19.91~git20160229.ceb6b9d-0ubuntu1
  Version table:
 *** 3.19.91~git20160229.ceb6b9d-0ubuntu1 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
        100 /var/lib/dpkg/status

bladernr@galactica:~/Downloads$ apt-cache policy emacs
emacs:
  Installed: (none)
  Candidate: 46.1
  Version table:
     46.1 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
        500 http://us.archive.ubuntu.com/ubuntu xenial/main i386 Packages

And note the screen shot does not show emacs as an installable option.

Jeff Lane (bladernr) wrote :

tuxpaint:
  Installed: (none)
  Candidate: 1:0.9.22-2
  Version table:
     1:0.9.22-2 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages

That makes two things from Universe that "should" be there but are not. As far as I can tell, the current gnome-software is still only showing me the things that are already installed, it does NOT show anything that "could be" installed.

Changed in gnome-software (Ubuntu):
status: Fix Released → Triaged
Sebastien Bacher (seb128) wrote :

What appstream-util version do you have? could you try refreshing your apt index using update-manager?

Changed in gnome-software (Ubuntu):
status: Triaged → Incomplete
Kev Bowring (flocculant) wrote :

working here in 3.19.91~git20160229.ceb6b9d-0ubuntu1

do you have appstream-data installed - if so purge that and see if you still don't see apps

Sebastien Bacher (seb128) wrote :

note that emacs is not listed but it's a different issue than the one described here (appstreamcli doesn't list it either)

Jeff Lane (bladernr) wrote :

Hrmmm... appstream-util was not installed (why is that not installed by default, or perhaps it is now but wasn't when I installed Xenial originally a couple weeks ago).

Since appstream-util was never installed in the first place, the first thing I did was simply run update-manager to update the cache (isn't that the same action as apt-get update?)

That seems to have fixed it... so, are the apt-cache and whatever update-manager is using not the same cache? (I don't tend to use GUI tools, this is Linux, I use CLI stuff and have been using apt for years to maintain and install packages).

I also manage this system with landscape, so how does that tie into this? am I now going to need to remember to run update manager before trying to use gnome-software even though the system is kept up to date daily via Landscape?

Jeff Lane (bladernr) wrote :

Also, since appstream-util was never installed in the first place, do I need that installed now?

Jeff Lane (bladernr) wrote :

Oh, and last but not least, thanks for the suggestions to get the cache properly updated.

Matthias Klumpp (ximion) wrote :

Nope, you don't need appstream-util at all, simply because there is no cache GS is reading from - GS is always parsing the data directly and creating an in-memory cache.

However, there is some setup needed for GS to work, and there is a cache which some apps consume instead of the raw data. Those are updated via `appstreamcli refresh`, which is exactly what you did when running `àpt update`, since an apt-update will trigger that.
Looks like for some reason your data was broken or out of date, I unfortunately have no idea how that could happen, unless APT screwed up or someone deleted the previous files in the cache and metadata locations.

Jeff Lane (bladernr) wrote :

Fair enough. we can count it as "weirdness when running an alpha" :) it's working so I've reset the status to Fix Released now that I understand the underlying mechanics a bit better. Of course, now I'm also seeing the other issue that flocculant mentioned, but as discussed in earlier comments, that's a different bug.

Changed in gnome-software (Ubuntu):
status: Incomplete → Fix Released
Albert (dingoslav) wrote :

Dear Sirs,

I would like to fix this thing that is preventing ubuntu software center to work. But reading your sites I still unfortunately do not understand how.
Thank you if any help is available.

Kind regards,
Albert

This is still broken. Was working, now not.

Version gnome-software 3.20.1. Only installed apps are showing. This is after another issue where gnome-software was using 6.5 gigs of memory.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions