[ffe] Enable firmware support

Bug #1544376 reported by Robert Ancell on 2016-02-11
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
appstream-glib (Ubuntu)
High
Unassigned
gnome-software (Ubuntu)
High
Unassigned

Bug Description

Firmware support has been temporarily disabled because the dependencies aren't all in main yet. Once they are, re-enable it.

Robert Ancell (robert-ancell) wrote :

Relevant MIRs - gcab (bug 1475021), fwupdate (bug 1508926), fwupd (bug 1536871)

Changed in gnome-software (Ubuntu):
status: New → Triaged
importance: Undecided → High
tags: added: gnome-software-ubuntu
Changed in appstream-glib (Ubuntu):
status: New → Triaged
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package appstream-glib - 0.5.8-1ubuntu6

---------------
appstream-glib (0.5.8-1ubuntu6) xenial; urgency=medium

  * Re-enable firmware support. (LP: #1544376)
    - debian/rules
    - debian/control
    - debian/libappstream-glib8.symbols
  * Add back dependency on gcab (LP: #1475021)
    - drop no-gcab.patch

 -- Mario Limonciello <email address hidden> Wed, 17 Feb 2016 16:49:13 -0600

Changed in appstream-glib (Ubuntu):
status: Triaged → Fix Released
Mario Limonciello (superm1) wrote :

fwupdate/fwupdate-signed's MIR was approved:
https://bugs.launchpad.net/ubuntu/+source/fwupdate/+bug/1508926/comments/9

Still waiting on fwupd.

Sebastien Bacher (seb128) wrote :

We need a ffe there, I'm unsure, subscribing the release team.

rational copied from the fwupdate MIR

"[Rationale]
fwupdate is a new EFI component for processing firmware updates for systems which support it. It will be used to allow users to run these upgrades, if their EFI BIOS allows, without the need to boot into Windows since it might not be available to them. This is only available for users with UEFI."

summary: - Enable firmware support
+ [ffe] Enable firmware support
Changed in gnome-software (Ubuntu):
status: Triaged → New
Iain Lane (laney) wrote :

Nice, this should happen.

Approved if someone can test it either before or very soon after uploading - asking the QA team to do that would be fine.

Changed in gnome-software (Ubuntu):
status: New → Confirmed
Matthias Klumpp (ximion) wrote :

I think Mario Limonciello will be happy to help with testing - at least on Debian, he is a great help with moving the fwupd stuff forward :)

Mario Limonciello (superm1) wrote :

Yes, happy to help with testing on some real hardware.

@laney , @seb128, @robert-ancell
what's the intention for moving to a new gnome-software snapshot between now and release? There was a flurry of upstream work in gnome-software specifically related to firmware yesterday.
I'd hope that there will be at least one more snapshot update to at least pull that stuff in.

Some of it is dependent upon moving to the soon to be released fwupd 0.7 (due to some API changes to make the experience better), but I don't have a concern in doing that shortly after the MIR for fwupd is done and before firmware support is turned on.

Robert Ancell (robert-ancell) wrote :

@superm1 we're sticking with GNOME Software 3.20, but happy to backport any patches that are appropriate. You're probably the best to let us know exactly what we need, feel free to file bugs with requests (or you can do it).

@richard,

Any chance you can backport some of what you did in master to 3.20 upstream
branch for the purpose of a 3.20.x maintenance release?

I'm happy to make a stab at picking the important ones for Ubuntu, but I
think it would be generally better for all distros picking this up to not
do Ubuntu specific backports.

On Sun, Mar 20, 2016, 15:40 Robert Ancell <email address hidden>
wrote:

> @superm1 we're sticking with GNOME Software 3.20, but happy to backport
> any patches that are appropriate. You're probably the best to let us
> know exactly what we need, feel free to file bugs with requests (or you
> can do it).
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1544376
>
> Title:
> [ffe] Enable firmware support
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/appstream-glib/+bug/1544376/+subscriptions
>

Hey Mario,

After the 3.20.0 tarball and the lifting of the hard code freeze I'm intending to backport a few more patches indeed.

Mario Limonciello (superm1) wrote :

Richard,

Now that 3.20.0 is dropped, is the hard code freeze lifted on 3.20 so you can backport these? At least in anticipation of the MIR for bug 1536871 finally getting finished I'd like to at least make sure we have good coverage on a PPA with the various backport changes.

Mario Limonciello (superm1) wrote :

@Robert,

Richard has backported the relevant fixes to the 3.20 stable branch. There are 6 patches. I've added them to a packaging branch here for when this is ready to be turned on:
https://code.launchpad.net/~superm1/gnome-software/enable-firmware

I've also done a test build on my PPA here:
https://launchpad.net/~superm1/+archive/ubuntu/uefi/+packages?field.name_filter=gnome-software&field.status_filter=published&field.series_filter=

Robert Ancell (robert-ancell) wrote :

The next gnome-software release will contain the latest gnome-3-20 branch changes.

Mario Limonciello (superm1) wrote :

@robert
fwupd has entered main and is seeded in the default installation. You should be able to include the reset of the patches from gnome-3-20-branch now and add fwupd to build depends.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.20.1~git20160331.78d1aab-0ubuntu2

---------------
gnome-software (3.20.1~git20160331.78d1aab-0ubuntu2) xenial; urgency=medium

  * Enable firmware support (LP: #1544376)

 -- Mario Limonciello <email address hidden> Fri, 01 Apr 2016 08:31:12 -0500

Changed in gnome-software (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers