gnome-software does not report installing a desktop environment as a dependency

Bug #1528028 reported by Alberto Salvia Novella on 2015-12-20
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
GNOME Software
Expired
Medium
gnome-software (Ubuntu)
Medium
Unassigned

Bug Description

The average user cannot tell when they are installing a desktop environment as a dependency of a package.

Having various desktop environments can reduce system performance sensibly, as processes from various desktops are running simultaneously in the background. Moreover the autoremove tool cannot always identify the dependencies when removing some of those installed packages.

For example if I install the "cortina" package, it takes with it the GNOME Display Manager and plenty of wallpapers. Then if I uninstall it and do "sudo apt-get autoremove" those packages are not detected as unused.

Another example: if I install the "rkward" package plenty of KDE services, like the Akonadi indexing service, are installed. Then launching applications in my Inter Core 2 Quad becomes noticeably slower, because my system is running both GNOME and KDE services simultaneously.

If I remove rkward and then I perform an autoremove, the system still stays slow. If I uninstall all the packages in the universe repository, perform an autoremove, and then reinstall the applications I had, the system becomes fast again.

The user shall know these potential problems beforehand.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: apt 1.0.10.2ubuntu1
ProcVersionSignature: Ubuntu 4.2.0-22.27-generic 4.2.6
Uname: Linux 4.2.0-22-generic x86_64
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Dec 20 18:54:54 2015
InstallationDate: Installed on 2015-11-14 (36 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
SourcePackage: apt
UpgradeStatus: No upgrade log present (probably fresh install)

Changed in aptitude (Ubuntu):
importance: Undecided → Medium
Changed in synaptic (Ubuntu):
importance: Undecided → Medium
Changed in muon (Ubuntu):
importance: Undecided → Medium
Changed in gnome-software (Ubuntu):
importance: Undecided → Medium
description: updated
Changed in gdebi (Ubuntu):
importance: Undecided → Medium
Changed in qapt (Ubuntu):
importance: Undecided → Medium
tags: added: xenial
Changed in apt (Ubuntu):
assignee: nobody → Alberto Salvia Novella (es20490446e)
Changed in aptitude (Ubuntu):
assignee: nobody → Alberto Salvia Novella (es20490446e)
Changed in gdebi (Ubuntu):
assignee: nobody → Alberto Salvia Novella (es20490446e)
Changed in gnome-software (Ubuntu):
assignee: nobody → Alberto Salvia Novella (es20490446e)
Changed in muon (Ubuntu):
assignee: nobody → Alberto Salvia Novella (es20490446e)
Changed in qapt (Ubuntu):
assignee: nobody → Alberto Salvia Novella (es20490446e)
Changed in synaptic (Ubuntu):
assignee: nobody → Alberto Salvia Novella (es20490446e)
Changed in apt (Ubuntu):
status: New → In Progress
Changed in aptitude (Ubuntu):
status: New → In Progress
Changed in gdebi (Ubuntu):
status: New → In Progress
Changed in gnome-software (Ubuntu):
status: New → In Progress
Changed in muon (Ubuntu):
status: New → In Progress
Changed in qapt (Ubuntu):
status: New → In Progress
Changed in synaptic (Ubuntu):
status: New → In Progress
Changed in apt:
status: New → In Progress

Snappy developers, please check if this bug affects Snappy too.

Oliver Grawert (ogra) on 2015-12-20
Changed in snappy:
status: New → Invalid
no longer affects: snappy
Julian Andres Klode (juliank) wrote :

This is not a bug in APT. Please do not go mass bug filing stupid bugs everywhere. Thank you.

Changed in apt (Ubuntu):
assignee: Alberto Salvia Novella (es20490446e) → nobody
status: In Progress → Invalid
Changed in apt:
status: In Progress → Invalid
Julian Andres Klode (juliank) wrote :

The same applies for the aptitude people.

Changed in aptitude (Ubuntu):
status: In Progress → Invalid
Julian Andres Klode (juliank) wrote :

gnome-software will show if a package integrates with your desktop environment in a future release.

Julian Andres Klode (juliank) wrote :

Like APT, synaptic shows the packages to be installed; as such the user sees that a lot of packages are installed and can make a descision. If the user cannot make a decision based on that fact, said user is not the target audience.

Changed in synaptic (Ubuntu):
assignee: Alberto Salvia Novella (es20490446e) → nobody
status: In Progress → Invalid

After speaking with some Ubuntu developers, I realized that the bug is not in the package management but rather in the autoremove tool. It seems that it keeps recommended packages, even when the ones that installed them as dependency are no longer there.

Changed in gdebi (Ubuntu):
status: In Progress → Invalid
Changed in gnome-software (Ubuntu):
status: In Progress → Invalid
Changed in muon (Ubuntu):
status: In Progress → Invalid
Changed in qapt (Ubuntu):
status: In Progress → Invalid
Changed in aptitude (Ubuntu):
assignee: Alberto Salvia Novella (es20490446e) → nobody
Changed in gdebi (Ubuntu):
assignee: Alberto Salvia Novella (es20490446e) → nobody
Changed in gnome-software (Ubuntu):
assignee: Alberto Salvia Novella (es20490446e) → nobody
Changed in muon (Ubuntu):
assignee: Alberto Salvia Novella (es20490446e) → nobody
Changed in qapt (Ubuntu):
assignee: Alberto Salvia Novella (es20490446e) → nobody
Changed in apt (Debian):
status: Unknown → Fix Released
affects: apt → ubuntu
Changed in ubuntu:
status: Invalid → New
no longer affects: ubuntu
no longer affects: apt (Ubuntu)
no longer affects: aptitude (Ubuntu)
no longer affects: synaptic (Ubuntu)
no longer affects: qapt (Ubuntu)
affects: apt (Debian) → ubuntu
Changed in ubuntu:
importance: Unknown → Undecided
status: Fix Released → New
no longer affects: ubuntu
Mathew Hodson (mathew-hodson) wrote :

Comment #5 indicated that gnome-software might be able to help by showing more information.

There is a similar upstream bug that talks about related problems. The displayed size doesn't take into account all the dependencies that need to be pulled in, which can be very large, and when an application is removed all the dependencies that were pulled in are not automatically uninstalled.

https://bugzilla.gnome.org/show_bug.cgi?id=734645

"1) Size estimation is off. So for 0ad for example we show it's 3.2MB, while it requires a -data package that is a 546MB download and 1.3GB on disk.

2) When removing the game from Software, the -data package will not be removed. This can either be solved with some special-casing in Software (easy) or convincing the maintainers to "do the right thing" (probably not easy)."

Changed in gnome-software (Ubuntu):
status: Invalid → New
Changed in gnome-software (Ubuntu):
status: New → Triaged
Changed in gnome-software:
importance: Unknown → Medium
status: Unknown → In Progress
no longer affects: gdebi (Ubuntu)
no longer affects: muon (Ubuntu)
summary: - The package manager does not report installing a desktop environment as
- a dependency
+ gnome-software does not report installing a desktop environment as a
+ dependency
AsciiWolf (asciiwolf) wrote :

Any news?

tags: added: zes
tags: added: artful bionic zesty
removed: zes

I'm unsubscribing to this report.

Changed in gnome-software:
status: In Progress → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.