Ubuntu

Partitions displayed as removable devices

Reported by mac.ryan on 2012-05-15
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Medium
Unassigned

Bug Description

This is my /etc/fstab:

# / was on /dev/sda1 during installation
UUID=<my-uuid-here> / ext4 defaults,relatime,discard,errors=remount-ro 0 1
# /home was on /dev/sdb1 during installation
UUID=<my-uuid-here> /home ext4 defaults,relatime 0 2
# /home/mac/runtime was on /dev/sda3 during installation
UUID=<my-uuid-here> /media/runtime-mac ext4 defaults,relatime,discard 0 2

sda1 and 3 are ext4 partitions of the same SSD, while sdb1 is an ext4 partition of a regular spinning HD.

My problem is that while the mounting process works flawlessly, the sda3 partition is displayed as a "removable device" in gnome (although of course a regular user can't even unmount it).

RELATED LINKS:
Askubuntu related question (opened by me):
http://askubuntu.com/q/137100/2952
Fedoraforum identical problem (I'm not the author of the post):
http://forums.fedoraforum.org/showthread.php?t=272249

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: mount 2.20.1-1ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-24.38-generic 3.2.16
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Tue May 15 17:04:24 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64+mac (20120425.1)
SourcePackage: util-linux
UpgradeStatus: No upgrade log present (probably fresh install)

mac.ryan (macryan) wrote :
affects: ubuntu → util-linux (Ubuntu)
Changed in util-linux (Ubuntu):
importance: Undecided → Medium
Daniel Letzeisen (dtl131) wrote :

I believe that is intended behavior, because SATA devices are hot-pluggable. Thunar/xfce also shows my non-root partitions as removable.

mac.ryan (macryan) wrote :

Thank you for the extra-quick follow up to the bug report!

Interesting observation about SATA being hot-pluggable. Still, I think that would explain *why* the partition shows up like it does, but I would argue that if the behaviour is intended, I disagree with the design choice that was made for at least two reasons:

1. you might well remove a device, but not a single partition,
2. the partition is mounted with the nouser option at boot time, so its typical usage won't be that of a removable device such a usb stick or external hard drive that a user can plug/unplug freely, but rather it will be handled by the sysadmin via CLI.
3. SATA is taking over desktop computing, and users would simply be alienated by having their internal drives listed among the removable ones.

IMO, a good compromise would be to display as "removable" only those partitions that the user has the possiblity to mount/unmount. I am unaware how the fedora team solved the issue in v17 though.

Anyhow: I just wrote the above to illustrate my own thinking and support debate. I would be very interested in reading alternative takes on this. :)

mac.ryan (macryan) wrote :

It might be an upstream problem:
https://bugzilla.gnome.org/show_bug.cgi?id=660595

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in util-linux (Ubuntu):
status: New → Confirmed
codeslinger (codeslinger) wrote :

yes, this is a pain, especially when you have a lot of partitions, you desktop becomes very cluttered. it is a bad design decision for the primary disk to have it's partitions displayed on the desktop. it is probably ok for secondary drives to do it though...

the work-around is to add all of your partitions to fstab, then they no longer show up as removable devices.

Phillip Susi (psusi) wrote :

It looks like this was fixed.

affects: util-linux (Ubuntu) → gnome-shell (Ubuntu)
Changed in gnome-shell (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.