[powerpc] Unsatisfiable dependency in oneiric

Bug #903382 reported by Onkar Shinde on 2011-12-12
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

There was a build failure for gnome-shell in oneiric-proposed on powerpc. It seems that afterwards the binary from precise got copied to oneiric-propopsed (or -updates). This binary has a wrong dependency on package 'gir1.2-coglpango-1.0' which exists only in precise and not in oneiric. When I tried to rebuild on buildd, the binary fails to upload because same version is already present in archive.
I believe there are two ways to fix this.
1. Remove current powerpc binary from archive and then rebuild current source on powerpc. I am not sure if this is possible in practice.
2. Just bump the version of package in oneiric-proposed and let it rebuild for all architectures.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-shell (not installed)
ProcVersionSignature: Ubuntu 3.0.0-14.23-powerpc 3.0.9
Uname: Linux 3.0.0-14-powerpc ppc
ApportVersion: 1.23-0ubuntu4
Architecture: powerpc
Date: Tue Dec 13 01:46:09 2011
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_IN
 SHELL=/bin/bash
SourcePackage: gnome-shell
UpgradeStatus: Upgraded to oneiric on 2011-10-16 (57 days ago)

Micah Gersten (micahg) wrote :

I think you'll just need to bump the version and rebuild in -proposed.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Micah Gersten (micahg) wrote :

Ok, so gnome-shell needs to be sync'd/merged from Debian in precise, then you can bump the version in -proposed for oneiric to pick up powerpc.

Evan Broder (broder) wrote :

I've uploaded a no-change rebuild to oneiric-proposed, so somebody from the SRU team should be through shortly to handle things from here.

Martin Pitt (pitti) wrote :

This needs a precise fix first. I can sync the package if that's appropriate, but don't have time for merging.

Jeremy Bicha (jbicha) wrote :

I just uploaded a merge of gnome-shell from Debian to precise.

Martin Pitt (pitti) wrote :

Nevermind, Jeremy just uploaded a precise gnome-shell.

Changed in gnome-shell (Ubuntu):
status: Confirmed → Fix Released
Changed in gnome-shell (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed

Hello Onkar, or anyone else affected,

Accepted gnome-shell into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Onkar Shinde (onkarshinde) wrote :

Confirmed that the package from oneiric-proposed is installable on powerpc.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.2.1-0ubuntu1.1

---------------
gnome-shell (3.2.1-0ubuntu1.1) oneiric-proposed; urgency=low

  * No-change rebuild to fix up dependencies (LP: #903382)
 -- Evan Broder <email address hidden> Mon, 19 Dec 2011 23:13:06 -0800

Changed in gnome-shell (Ubuntu Oneiric):
status: Fix Committed → Fix Released
alecive (alecive) wrote :

I'm on oneiric. I enabled oneiric proposed but I can't get the problem fixed.

I typed "sudo apt-get update", "sudo apt-get upgrade" and "sudo apt-get dist-upgrade", but my gnome-shell is still broken. I also saw that it's the wrong version:

"alecive@calliope:~$ apt-cache show gnome-shell
Package: gnome-shell
Priority: optional
Section: universe/gnome
Installed-Size: 4864
Maintainer: Ubuntu Developers <email address hidden>
Original-Maintainer: Gustavo Noronha Silva <email address hidden>
Architecture: i386
Version: 3.2.0-0ubuntu1"

How to install 3.2.1-0-ubuntu1.1 version?

alecive (alecive) wrote :
Download full text (8.6 KiB)

Ok I downloaded 3.2.1-0ubuntu1.1 version from here -> https://launchpad.net/ubuntu/oneiric/i386/gnome-shell/3.2.1-0ubuntu1.1

But firstly, the problem is not solved:

"
alecive@calliope:~$ gnome-shell --replace

(gnome-shell:4052): GConf-CRITICAL **: gconf_value_get_string: assertion `value->type == GCONF_VALUE_STRING' failed

(gnome-shell:4052): GConf-CRITICAL **: gconf_value_get_string: assertion `value->type == GCONF_VALUE_STRING' failed

(gnome-shell:4052): GConf-CRITICAL **: gconf_value_get_string: assertion `value->type == GCONF_VALUE_STRING' failed
    JS ERROR: !!! Exception was: Error: Requiring Clutter, version 1.0: Typelib file for namespace 'CoglPango', version '1.0' not found
    JS ERROR: !!! lineNumber = '0'
    JS ERROR: !!! fileName = '"gjs_throw"'
    JS ERROR: !!! stack = '"("Requiring Clutter, version 1.0: Typelib file for namespace 'CoglPango', version '1.0' not found")@gjs_throw:0
@/usr/share/gnome-shell/js/ui/environment.js:9
"'
    JS ERROR: !!! message = '"Requiring Clutter, version 1.0: Typelib file for namespace 'CoglPango', version '1.0' not found"'
    JS ERROR: !!! Exception was: Error: Requiring Clutter, version 1.0: Typelib file for namespace 'CoglPango', version '1.0' not found
    JS ERROR: !!! lineNumber = '0'
    JS ERROR: !!! fileName = '"gjs_throw"'
    JS ERROR: !!! stack = '"("Requiring Clutter, version 1.0: Typelib file for namespace 'CoglPango', version '1.0' not found")@gjs_throw:0
@/usr/share/gnome-shell/js/ui/environment.js:9
"'
    JS ERROR: !!! message = '"Requiring Clutter, version 1.0: Typelib file for namespace 'CoglPango', version '1.0' not found"'
Avviso del window manager: Log level 32: Execution of main.js threw exception: Error: Requiring Clutter, version 1.0: Typelib file for namespace 'CoglPango', version '1.0' not found

"

Secondly, when I run "apt-cache show gnome-shell" it seems that now I have two different versions of gnome-shell installed, that is, 3.2.0-0ubuntu1 AND 3.2.1-0ubuntu1.1:

"
alecive@calliope:~$ apt-cache show gnome-shell
Package: gnome-shell
Priority: optional
Section: universe/gnome
Installed-Size: 4864
Maintainer: Ubuntu Developers <email address hidden>
Original-Maintainer: Gustavo Noronha Silva <email address hidden>
Architecture: i386
Version: 3.2.0-0ubuntu1
Depends: gir1.2-atk-1.0, gir1.2-clutter-1.0, gir1.2-cogl-1.0, gir1.2-folks-0.6, gir1.2-freedesktop, gir1.2-gdkpixbuf-2.0, gir1.2-gee-1.0, gir1.2-glib-2.0, gir1.2-gmenu-3.0, gir1.2-gtk-3.0, gir1.2-json-1.0, gir1.2-mutter-3.0, gir1.2-networkmanager-1.0, gir1.2-pango-1.0, gir1.2-soup-2.4, gir1.2-telepathyglib-0.12, gir1.2-telepathylogger-0.2, gjs (>= 1.29.18), gnome-bluetooth (>= 3.0.0), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.7), libcairo2 (>= 1.10.0), libcanberra0 (>= 0.2), libclutter-1.0-0 (>= 1.7.6), libcogl5 (>= 1.7.4), libcroco3 (>= 0.6.2), libdbus-glib-1-2 (>= 0.78), libecal1.2-10 (>= 3.2.0), libedataserver1.2-15 (>= 3.2.0), libedataserverui-3.0-1 (>= 3.2.0), libfolks25 (>= 0.5.2), libgconf2-4 (>= 2.31.1), libgdk-pixbuf2.0-0 (>= 2.22.0), libgee2 (>= 0.5.0), libgirepository-1.0-1 (>= 0.9.2), libgjs0c (>= 1.29.18), libgl1-mesa-glx | libgl1, libg...

Read more...

Jeremy Bicha (jbicha) wrote :

apt-cache show is showing you that gnome-shell is in both the "oneiric" repository (which is frozen when oneiric was released) and the "oneiric-updates" repository. Try running apt-cache policy gnome-shell to see which one is actually installed.

I don't have a powerpc machine so this is difficult for me to test but I believe it's working as the original bug reporter confirms.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers