GNOME Shell 3.2.0 falsely states: "Network Disconnected - you are now offline"

Bug #883443 reported by Detlef Lechner on 2011-10-29
54
This bug affects 12 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Undecided
Unassigned
network-manager-applet (Ubuntu)
Undecided
Unassigned

Bug Description

GNOME Shell 3.2.0 falsely reports in the bottom middle for more than 30 minutes: "Network Disconnected - you are now offline".
The contrary is true: I am online and I can connect to an arbitrary Internet address web site via Firefox.
I expect that GNOME Shell does not make this false notification.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-shell 3.2.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.20-server 3.0.4
Uname: Linux 3.0.0-12-server x86_64
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Sat Oct 29 13:32:59 2011
InstallationMedia: Ubuntu-Server 11.04 "Natty Narwhal" - Release amd64 (20110426)
ProcEnviron:
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-shell
UpgradeStatus: Upgraded to oneiric on 2011-09-29 (30 days ago)

Related branches

Detlef Lechner (detlef-lechner) wrote :
Detlef Lechner (detlef-lechner) wrote :

I suspect that GNOME Shell muddeled "Network" and "WLAN".

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Timo Kluck (tkluck) wrote :

I think this has to do with the persistency of the notification. My guess is that the ubuntu network manager (or some other software) sends the notification with the 'persistent' flag set. In Unity, this doesn't matter (all notifications are transient), but in gnome-shell, it makes a difference.

Can you confirm that this only happens when you have been disconnected before? Also, does ik go away when you click it? That's the behaviour I'm observing.

Jason D. Cupp (forrestcupp-s) wrote :

This is my experience with this bug. It only happens when I am disconnected, usually from going into suspend mode when shutting my laptop lid. When I open the lid and come back into live mode, I get this notification, and it doesn't disappear until I click it.

But one thing I have noticed is that it didn't start happening until after I did two things. The first thing I did was turn off notifications in the profile menu in the upper right corner. The second thing I did was click the button that said something like "Never show this message again". I don't know which is the cause, but I suspect it is from turning off notifications in that menu.

I just had to reinstall Ubuntu, and I can verify that with a fresh install and after setting up everything how I need it, the notification disappears after the timeout, like it is supposed to. I haven't done either of the two things mentioned earlier, and it is still working normally.

Timo Kluck (tkluck) wrote :

At least part of this is ubuntu specific. The distribution patch

lp341684_device_sensitive_disconnect_notify.patch

in the package network-manager-applet sets this notification importance to NOTIFY_URGENCY_CRITICAL. I can confirm that if you change this to NOTIFY_URGENCY_NORMAL, the notification disappears after the timeout

Apparently, gnome-shell keeps on showing NOTIFY_URGENT_CRITICAL notifications, even if they are marked as "transient". The ubuntu-specific patch assumes the unity behavior. This is probably the cause of the bug.

I'm marking network-manager-applet as affected.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-applet (Ubuntu):
status: New → Confirmed

Timo; changing the behavior of the CRITICAL notifications should at least be discussed with GNOME Shell developers. Can you please file the bug upstream or otherwise contact GNOME developers to ask their opinion of this change?

The reason for making the notification urgency NOTIFY_URGENCY_CRITICAL is in bug 354420; it was a concious decision so I'd very much like to know if the current gnome-shell behavior is expected before attempting to reverse this.

Changed in network-manager-applet (Ubuntu):
status: Confirmed → Incomplete

Mirroring the info I put in the merge request-- I agree with upstream that it probably best be fixed in nm-applet. I'll make sure the urgency gets dropped on the offending messages (with info from design).

Marking the bug task for gnome-shell to incomplete; Timo, could you check the merge request and see if it's worth setting it to Work in Progress or dropping it altogether?

Timo Kluck (tkluck) wrote :

Mathieu: How do you feel about the upstream suggestion to drop gnome-shell/f65826b3ba2cf03a859819e6706046fff376c65c and get native network messages?

By the way, I've got a patch for nm-applet too (I wrote that earlier). However, that might also affect the Unity experience, so my guess was that that would be a lot harder to get merged.

I'll put my merge request on work in progress in the mean time.

You don't need a patch to nm-applet to do this; it's a modification that can be reverted in a patch that's already included.

I don't think reverting that commit in shell is a good idea, it will mean modifying both gnome-shell to drop that commit, and nm-applet to not start on shell, with the added possible issues from things failing to work in that case. Not sure if the VPNs still depend on nm-applet running; but that used to be an issue. I'm not really prepared to deal with this so late in the cycle.

I'm testing with the nm-applet patch changed to use just the NORMAL priority. Things seem to look reasonable. You risk missing the notification anyway even when it's critical (when it times out or if it's overriden by another critical notification somehow), and applications themselves already track network status. I think it's reasonable to drop the priority.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.4.1-0ubuntu1

---------------
network-manager-applet (0.9.4.1-0ubuntu1) precise; urgency=low

  * New upstream release 0.9.4.1.
    - Bugfix release.
    - mobile: fix some memory leaks
    - applet: don't call nm_secret_agent_register() when the agent is registered
    - applet: fix an uninitialized variable
    - applet: track GNOME Shell version, not just whether it's running
    - Add NotShowIn=KDE to .desktop files (bgo #660046)
    - applet: fix pixbuf leak when mobile broadband is connected (lp:939802)
  * debian/control: bump Build-Depends and Depends for libnm-*-dev and the
    network-manager(-dev) packages to 0.9.4.
  * debian/control: drop unused Build-Depends on libpolkit-gobject-1-dev.
  * debian/patches/04-autostart.patch: dropped, applied upstream.
  * debian/patches/lp939802_fix_mobile_icon_leak.patch: dropped, applied
    upstream.
  * debian/patches/lp289466_always_show_tray_icon.patch: refreshed.
  * debian/patches/nm-applet-use-indicator.patch: refreshed and cleaned up.
  * debian/patches/revert_git_policy_error_dialog_ba8381a.patch: revert commit
    ba8381a: don't show an error dialog when connection creation, disconnects,
    or activations fail; we already have a warning message.
  * debian/patches/lp341684_device_sensitive_disconnect_notify.patch: drop the
    notification urgency back to NORMAL from CRITICAL for offline notifications
    since they otherwise "stick around" in Gnome Shell. (LP: #883443)
 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 29 Mar 2012 14:19:26 -0400

Changed in network-manager-applet (Ubuntu):
status: Incomplete → Fix Released
Changed in gnome-shell (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.