Frequently crashes on Oneiric (often occurs running Libreoffice and Debconf)

Bug #881861 reported by Cherrot on 2011-10-26
76
This bug affects 16 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Undecided
Unassigned

Bug Description

System: Ubuntu 11.10 64bit
Gnome-shell version: 3.2.0-0ubuntu1

My gnome-shell frequently crashes on my Ubuntu 11.10.
It often occurs when I has downloaded a file using Google Chrome 15 beta, rolled pages in LibreOffice, or just simply installed a software (which would run Debconf) in the software center.
It also occurs when I'm running a java program. And I don't precisely know when It will crash.

In most cases, the gnome-shell would restart itself but not always do that. Especially if I try to roll pages in LibreOffice writer, the gnome-shell usually crashed and won't restart itself.

The following are the logs which I thought would be helpful :)
In syslog:

Oct 25 08:00:57 cherrot-TA880G-HD gnome-session[16830]: WARNING: Application 'gnome-shell.desktop' killed by signal
Oct 25 08:00:57 cherrot-TA880G-HD gnome-session[16830]: WARNING: App 'gnome-shell.desktop' respawning too quickly
Oct 25 08:00:57 cherrot-TA880G-HD kernel: [76208.203802] gnome-shell[18682]: segfault at 31 ip 00007fe59f103c21 sp 00007fe580ed09b0 error 4 in libfontconfig.so.1.4.4[7fe59f0fa000+34000]
Oct 25 08:22:04 cherrot-TA880G-HD gnome-session[31949]: WARNING: App 'gnome-shell.desktop' respawning too quickly
Oct 25 21:35:50 cherrot-TA880G-HD gnome-session[7087]: WARNING: App 'gnome-shell.desktop' respawning too quickly

Oct 26 09:52:39 cherrot-TA880G-HD kernel: [ 1950.062869] gnome-shell[24985]: segfault at 34 ip 00007f60ee7f9998 sp 00007f60f069b860 error 6 in libpixbufloader-gif.so[7f60ee7f8000+6000]
Oct 26 09:52:39 cherrot-TA880G-HD gnome-session[1274]: WARNING: Application 'gnome-shell.desktop' killed by signal
Oct 26 09:53:20 cherrot-TA880G-HD gnome-session[1274]: WARNING: App 'gnome-shell.desktop' respawning too quickly
Oct 26 10:03:20 cherrot-TA880G-HD kernel: [ 2591.242850] gnome-shell[12237]: segfault at 34 ip 00007f99a150a998 sp 00007f99927f9860 error 6 in libpixbufloader-gif.so[7f99a1509000+6000]
Oct 26 10:03:21 cherrot-TA880G-HD gnome-session[8653]: WARNING: Application 'gnome-shell.desktop' killed by signal

In .xsession-errors I found countless following log:

(gnome-shell:5762): Clutter-CRITICAL **: clutter_actor_set_text_direction: assertion `text_dir != CLUTTER_TEXT_DIRECTION_DEFAULT' failed

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Christian Obst (christian-obst) wrote :

I have the same problem. I am running Linux Mint 12 RC, which is based on Oneiric, and the MintMenu seems to crash gnome-shell sometimes, too. I know it is considered a different distro, but maybe this is helpful.

It also crashes frequently when running debconf.

If gnome-shell doesn't restart, you can switch to a console and run 'DISPLAY=:0.0 gnome-shell &' to get it back.

Cherrot (cherrot) wrote :

Thanks Christian.
Since it crashed too often, I have switched to Unity now, slower, but safer :)

gticlayauri (gticlayauri) wrote :

Uninstall libreoffice-gtk & libreoffice-gnome.. is not the best solution, but I still can work with gnome-shell without crashing....

While this may not be helpful, I get this only when configuring my nVidia XServer to use my 2nd monitor as an additional XScreen....The messages below are all I get, and the X session is unusuable, I have to kill it from a Virtual Terminal.

Feb 2 09:41:10 salderman-lp kernel: [ 335.032942] gnome-shell[1981] trap int3 ip:7f32bed37313 sp:7fff32dd8a70 error:0
Feb 2 09:41:11 salderman-lp gnome-session[1903]: WARNING: Application 'gnome-shell.desktop' killed by signal
Feb 2 09:41:12 salderman-lp kernel: [ 336.834862] gnome-shell[2061] trap int3 ip:7f7fe1e58313 sp:7fff77868e50 error:0
Feb 2 09:41:12 salderman-lp gnome-session[1903]: WARNING: App 'gnome-shell.desktop' respawning too quickly
Feb 2 09:41:12 salderman-lp gnome-session[1903]: CRITICAL: We failed, but the fail whale is dead. Sorry....
Feb 2 09:41:12 salderman-lp gnome-session[1903]: WARNING: Application 'gnome-shell.desktop' killed by signal

I've got a Dell E6510, running 64bit Ubuntu 11.10.

On a side note, the reason I ran into this, was attempting to use both monitors, as in gnome-shell, configuring the XServer in twinning mode, does not function. In Unity, however it does just fine in twinning mode, but 2 Xscreens doesn't work either... no immeidately relevant errors appear in the log though.

Fabian (fabian-markus) wrote :

Also happens to me at least once a day!
I am using 64 bit Ubuntu 11.10 together with Gnome 3.2.1. There are attached 2 Monitors on a nvidia 460 gtx with the official nvidia driver 280.13. After installing the 295 driver I switched back to the 280s driver due to many more problems with the gnome shell.

I just had a gnome-shell crash and the syslog says as follows:

Feb 19 15:15:08 quad goa[10556]: goa-daemon version 3.2.1 starting [main.c:112, main()]
Feb 19 15:16:01 quad kernel: [12996.155428] gnome-shell[10608]: segfault at 18 ip 00007f6f66749f40 sp 00007f6f642fd840 error 6 in libpixbufloader-gif.so[7f6f66746000+6000]
Feb 19 15:16:02 quad gnome-session[8472]: WARNING: Application 'gnome-shell.desktop' killed by signal
Feb 19 15:16:03 quad bluetoothd[1321]: Can't init device hci0: Operation not possible due to RF-kill (132)
Feb 19 15:16:04 quad gnome-session[8472]: WARNING: Application 'gnome-shell.desktop' killed by signal
Feb 19 15:16:04 quad gnome-session[8472]: WARNING: App 'gnome-shell.desktop' respawning too quickly
Feb 19 15:16:04 quad gnome-session[8472]: CRITICAL: We failed, but the fail whale is dead. Sorry....
Feb 19 15:17:01 quad CRON[10654]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)

Fabian (fabian-markus) on 2012-02-19
Changed in gnome-shell (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Confirmed

I have had this problem pop up for a week now. It started suddently, I'm not sure what changed on my system. It also seems to be associated with specific profiles. I tried creating a new user account, and I can scroll back and forth with LibreOffice without a hitch. I have tried getting rid of all my configuration files in .config, .local, and .libreoffice, but the affected account still causes the same problem. Did anybody have any luck in tracking the source of the bug?

Normunds (Alistek) (3pm) wrote :

I have the same on Ubuntu 12.04.1 LTS
And yes, nvidia with dual monitors.

Jeremy Bicha (jbicha) wrote :

Thank you for reporting this bug to Ubuntu. Ubuntu 12.04 LTS reached End of Life in April. See this document for currently supported Ubuntu releases: https://wiki.ubuntu.com/Releases

Please upgrade to Ubuntu 16.04 LTS and re-test. If the bug is still reproducible, increase the verbosity of the steps to recreate it so we can try again.

I apologize that we are not always to respond to bug reports promptly. Do feel free to report any other bugs you may find.

Changed in gnome-shell (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers