Ubuntu

Enabling on screen keyboard in GNOME Shell starts both caribou and onboard

Reported by Michael Heyns on 2011-10-22
72
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Onboard
Undecided
Unassigned
gnome-shell (Ubuntu)
Medium
Unassigned
onboard (Ubuntu)
Undecided
Unassigned

Bug Description

Enabling on screen keyboard in ubuntu 11.10 with Gnome 3.2 installed starts both caribou and onboard simultaniously.

In Ubuntu 11.10 there is no way to specify default on screen keyboard.

Michael Heyns (mike-bean-heyns) wrote :

removing onboard autostart from /etc/xdg/autostart helps but is it a solution?

Jeremy Bicha (jbicha) wrote :

Michael, thanks for you bug report.

I tried working on this a few weeks ago but had trouble getting only onboard to load in GNOME Fallback (caribou doesn't work well at all there) but only caribou to load in GNOME Shell. In Ubuntu 11.10, both GNOME Shell & GNOME Fallback share the same xdg-desktop name "Gnome" which makes this more complicated.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
tags: added: a11y
removed: accessibility
Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
Victor Zamanian (victorz) wrote :

This affects me still in 12.04.

Same here 12.04 64bit. Running gnome-shell 3.4.2.

--
*Michael Heyns*

+27-78-279-4717
 <http://twitter.com/beanaroo> | <http://facebook.com/beanaroo> |
<http://gplus.to/beanaroo> |
<http://www.stumbleupon.com/stumbler/mikebeanheyns/> |
<http://za.linkedin.com/pub/michael-heyns/22/4b4/538>

------------------------------

On Mon, Jun 4, 2012 at 1:11 PM, Victor Zamanian
<email address hidden>wrote:

> This affects me still in 12.04.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/879942
>
> Title:
> Enabling on screen keyboard starts both caribou and onboard
>
> Status in “gnome-shell” package in Ubuntu:
> Confirmed
>
> Bug description:
> Enabling on screen keyboard in ubuntu 11.10 with Gnome 3.2 installed
> starts both caribou and onboard simultaniously.
>
> In Ubuntu 11.10 there is no way to specify default on screen keyboard.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/879942/+subscriptions
>

I'm adding onboard to this bug report. I think onboard should check for org.gnome.Shell on dbus and refuse to run since GNOME Shell has its own screen keyboard.

Yelp has some code to sniff dbus:
http://git.gnome.org/browse/yelp/tree/libyelp/yelp-settings.c#n263

summary: - Enabling on screen keyboard starts both caribou and onboard
+ Enabling on screen keyboard in GNOME Shell starts both caribou and
+ onboard
Jeremy Bicha (jbicha) wrote :

In Ubuntu 12.04, only the caribou library is a dependency of gnome-shell not the standalone caribou so this shouldn't be a problem in GNOME Classic or Unity unless someone intentionally installs caribou.

marmuta (marmuta) wrote :

Jeremy, do you know why GNOME Shell & GNOME Fallback share the same xdg-desktop name? Is that something that's set in stone? Those DE's are different enough, why are they lumped together under the same name? "NotShowIn=GNOME;" would probably do the job if it wasn't for this.

Did I understand you right, are you asking to lock Onboard out of GNOME Shell entirely? Me thinks a solution should tackle the auto-start problem, rather than outright ban $ALTERNATIVE-OSK. I'm open to suggestions, though.

Jeremy Bicha (jbicha) wrote :

Marmuta, I agree that GNOME Shell & Classic are very different desktops and they are becoming more different with each GNOME release as GNOME adopts new technologies that no one bothers to port to the old desktop. Those names are part of the freedesktop desktop menu spec which can be changed (MATE was added fairly recently, I don't see Cinnamon yet though): http://standards.freedesktop.org/menu-spec/latest/apb.html

Yes, updating the spec would fix this bug but I don't think that will happen in time for 12.10.

Since GNOME Shell hard-depends on caribou, it's not really practical to use an alternate screen keyboard there. Maybe the GNOME developers would consider allowing alternate screen keyboards since their built-in keyboard is very lacking.

I guess it shouldn't be a hard ban though because it's possible to run onboard without having the org.gnome.desktop.a11y.applications screen-reader-enabled key set. Maybe onboard should not automatically start if that key is set and it can detect that it's running in Shell, but manually running onboard should still work.

marmuta (marmuta) wrote :

Ok, I don't see a way around this either now. I'll try something like: if is-auto-starting and is-gnome-shell then fail, basically a working replacement for "NotShowIn=GNOME;". Manually starting Onboard will then stay possible, no matter the system state.

What about X-GNOME-AutoRestart=true, is there a clean way to opt out of restarting at termination? I can see rate limiting in the gnome-session source, but must have missed a clear way to end restarts.

> Maybe the GNOME developers would consider allowing alternate
> screen keyboards since their built-in keyboard is very lacking.
Getting GMOME to support alternative osks may not be easy. As I understand it, the Activities view is inaccessible to portable keyboards, so only shell extensions can fully replace the built-in keyboard. It's either GNOME Shell only or the rest of the world. That's a sad state of affairs IMO, and it isn't only an obstacle for Onboard, but hurts a whole eco-system of brilliant input devices like Dasher and Cellwriter.

marmuta (marmuta) wrote :

Fixed in trunk, I believe.
http://bazaar.launchpad.net/~onboard/onboard/trunk/revision/946
X-GNOME-AutoRestart doesn't seem to be a problem.

Changed in onboard:
status: New → Fix Committed
Francesco Fumanti (frafu) wrote :

A snapshot of revision 969 that contains the fix is available in our Snapshots PPA for precise and quantal as soon as they are finished building.
https://launchpad.net/~onboard/+archive/snapshots

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in onboard (Ubuntu):
status: New → Confirmed
marmuta (marmuta) wrote :

I'll close this for upstream Onboard, the fix was released with Onboard 0.98.1.

Changed in onboard:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package onboard - 0.98.2-0ubuntu1

---------------
onboard (0.98.2-0ubuntu1) raring; urgency=low

  * Sponsorship request for Ubuntu Raring (LP: #1071888)
  * Fix keys with operators (+,-,*,/) on the number keypad of Onboard
  * Fix failure to instantiate Config singleton with python 3.3
  * Fix distutils-extra build with python3.3
  * Sync translations files with the 0.98 branch in rosetta as of 2012-10-26
  * debian/control: demote mousetweaks from Recommends to Suggests
  * debian/rules: build for all python3 versions, by Matthias Klose
  * debian/patches: add defaults file with values appropriate for Ubuntu
 -- Francesco Fumanti <email address hidden> Fri, 26 Oct 2012 22:06:50 +0200

Changed in onboard (Ubuntu):
status: Confirmed → Fix Released
Thomas (tom-rosary) wrote :

bug still there in 12.04.2
3.5.0-36-generic
GNOME Shell 3.4.1
furthermore gnmoe-shell can't start with the onscreen keyboard

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers