gnome-shell missing dependency on gir1.2-coglpango-1.0

Bug #877135 reported by Anders Kaseorg
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

As of cogl 1.8.0-1 in precise, gir1.2-coglpango-1.0 and libcogl-pango0 are split out from the main gir1.2-cogl and libcogl packages. So gnome-shell now needs a dependency on gir1.2-coglpango-1.0. Otherwise it fails to start with a message like

/usr/bin/gnome-shell: error while loading shared libraries: libcogl-pango.so.0: cannot open shared object file: No such file or directory

or

    JS ERROR: !!! Exception was: Error: Requiring Clutter, version 1.0: Typelib file for namespace 'CoglPango', version '1.0' not found

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnome-shell 3.2.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: openafs
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Tue Oct 18 02:46:12 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101202)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Anders Kaseorg (andersk) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Revision history for this message
Jonathan Hudson (jh+lpd) wrote :

Breaks gnome-shell on ppc.

Revision history for this message
Yotam Benshalom (benshalom) wrote :

This happens for me on oneiric, after downgrading from ppa using ppa-purge. It is worse because there is no cogl-pango package in oneiric anymore; I have no way of repairing gnome-shell.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.2.1-8ubuntu1

---------------
gnome-shell (3.2.1-8ubuntu1) precise; urgency=low

  * Sync with Debian (LP: #877135). Remaining changes:
  * debian/control.in: Recommend gnome-user-guide
  * debian/gnome-shell.gsettings-override: Update for Ubuntu defaults
  * Watch for unstable releases
 -- Jeremy Bicha <email address hidden> Tue, 20 Dec 2011 02:25:09 -0500

Changed in gnome-shell (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Jeremy Bicha (jbicha) wrote :

The oneiric-specific bug is bug 903382.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers