gnome-shell crashed with SIGSEGV in g_object_newv()

Bug #858109 reported by Alexander Hunziker on 2011-09-24
48
This bug affects 12 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Medium
Unassigned

Bug Description

I tried to enable the on screen keyboard.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: gnome-shell 3.1.92-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Sat Sep 24 11:00:58 2011
ExecutablePath: /usr/bin/gnome-shell
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcCmdline: /usr/bin/gnome-shell
SegvAnalysis:
 Segfault happened at: 0x7fc4393a7f75: mov (%rax),%rsi
 PC (0x7fc4393a7f75) ok
 source "(%rax)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%rsi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-shell
StacktraceTop:
 ?? () from /usr/lib/libcaribou.so.0
 ?? () from /usr/lib/libcaribou.so.0
 g_object_newv () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/libgjs.so.0
 ?? () from /usr/lib/libmozjs185.so.1.0
Title: gnome-shell crashed with SIGSEGV in g_object_newv()
UpgradeStatus: Upgraded to oneiric on 2011-09-23 (1 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

StacktraceTop:
 caribou_keyboard_model_on_group_changed (self=0x7fc450072320, group=<optimized out>, variant=<optimized out>, grpid=<optimized out>) at keyboard-model.c:439
 caribou_keyboard_model_constructor (type=<optimized out>, n_construct_properties=<optimized out>, construct_properties=<optimized out>) at keyboard-model.c:648
 g_object_newv (object_type=<optimized out>, n_parameters=1, parameters=<optimized out>) at /build/buildd/glib2.0-2.29.92/./gobject/gobject.c:1493
 gjs_object_instance_constructor (context=0x1ebbeb0, argc=<optimized out>, vp=0x7fc45413f4f8) at gi/object.c:693
 CallJSNative (vp=<optimized out>, argc=<optimized out>, native=<optimized out>, cx=0x1ebbeb0) at jscntxtinlines.h:701

Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2011-09-25
visibility: private → public
Changed in gnome-shell (Ubuntu):
status: Confirmed → Triaged
Jeremy Bicha (jbicha) wrote :

Thank you for reporting this bug.

I only figured out how to get caribou (GNOME's new screen keyboard system) working yesterday (& the GNOME Shell version only started working with Fedora 16 this week) so it's not as fully tested.

To workaround this until it gets fixed properly:
1. Install caribou
2. Add this line to /etc/xdg/autostart/onboard-autostart.desktop
AutostartCondition=GNOME3 unless-session gnome
3. And add this line to /etc/xdg/autostart/caribou-autostart.desktop
AutostartCondition=GNOME3 unless-session gnome-fallback

That will disable Ubuntu's default screen keyboard (onboard) in GNOME Shell because having 2 onscreen keyboards on the screen at once is ridiculous. Step 3 also makes onboard the default for screen keyboard in GNOME Classic since onboard still works better than caribou's standalone mode.

DeBø (black-painkiller) wrote :

#6 solved for me!

i also do this (not sure if it's correct)
Add this line to /etc/xdg/autostart/onboard-autostart.desktop
OnlyShowIn=Unity;

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.2.0-0ubuntu1

---------------
gnome-shell (3.2.0-0ubuntu1) oneiric; urgency=low

  * New upstream stable release.
    - Prevent the fallback on-screen keyboard from showing up while
      GNOME Shell is running.
    - Disable code to reposition windows around the on-screen keyboard;
      it wasn't finished or working properly.
    - Fix interaction between on-screen keyboard and notifications
    - Fix menu-sizing problems in right-to-left locales.
    - Update chat icons in the message tray when an avatar image changes
    - Fix problem with empty notification bubbles being left.
    - Fix problem with chat notifications bouncing when new messages come in.
    - Fix bug that was causing SIP calls to automatically be accepted in some
      circumstances.
    - Fix string that should have been marked translatable.
    - Fix a crash that could happen during CSS transitions.
    - Build fixes.
  * debian/control.in: Depend on caribou instead of gir-caribou-1.0
    (LP: #858109)
 -- Jeremy Bicha <email address hidden> Wed, 28 Sep 2011 06:48:58 +0200

Changed in gnome-shell (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers