gnome-shell-extension-tool crashed with NameError in __main__: name 'extensionjs_path' is not defined

Bug #853882 reported by Wildjiji on 2011-09-19
104
This bug affects 16 people
Affects Status Importance Assigned to Milestone
GNOME Shell
Fix Released
Low
gnome-shell (Ubuntu)
Low
Unassigned
Nominated for Oneiric by Jeremy Bicha

Bug Description

gnome-shell-extension-tool is is terminated without starting editor.

maybe, upstream bug.

[how to fix]
attached fix patch.

[Test Case]
Run gnome-shell-extension-tool --create-extension and fill in the blanks. It should work without crashing and open an extension template in your text editor when finished.

ProblemType: CrashDistroRelease: Ubuntu 11.10
Package: gnome-shell 3.1.90.1-0ubuntu4
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic i686
ApportVersion: 1.23-0ubuntu1
Architecture: i386
Date: Mon Sep 19 22:39:09 2011
ExecutablePath: /usr/bin/gnome-shell-extension-tool
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110531.1)
InterpreterPath: /usr/bin/python2.7
ProcCmdline: /usr/bin/python /usr/bin/gnome-shell-extension-tool --create-extension
PythonArgs: ['/usr/bin/gnome-shell-extension-tool', '--create-extension']SourcePackage: gnome-shell
Title: gnome-shell-extension-tool crashed with NameError in __main__: name 'extensionjs_path' is not defined
Traceback:
 Traceback (most recent call last):
   File "/usr/bin/gnome-shell-extension-tool", line 151, in <module>
     subprocess.Popen(['gnome-open', extensionjs_path])
 NameError: name 'extensionjs_path' is not defined
UpgradeStatus: Upgraded to oneiric on 2011-09-09 (9 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Wildjiji (wildjiji) wrote :
visibility: private → public

The attachment "Fix patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

Thank you for reporting this bug and helping to make Ubuntu better.

Please report this bug to the GNOME Shell developers so that we can ensure it gets fixed correctly.

https://wiki.ubuntu.com/Bugs/Upstream/GNOME

Wildjiji (wildjiji) wrote :

I reported this bug to gnome.

This bug has been filed here: https://bugzilla.gnome.org/show_bug.cgi?id=661623

Jeremy Bicha (jbicha) on 2011-10-15
Changed in gnome-shell (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Changed in gnome-shell:
importance: Unknown → Low
status: Unknown → New
Changed in gnome-shell:
status: New → Fix Released
Michael Steger (m-steger) wrote :

Traceback (most recent call last):
  File "/usr/bin/gnome-shell-extension-tool", line 151, in <module>
    subprocess.Popen(['gnome-open', extensionjs_path])
NameError: name 'extensionjs_path' is not defined

ii gnome-shell 3.2.0-0ubuntu1

Chris McIntosh (gnu-know-who) wrote :

Traceback (most recent call last):
  File "/usr/bin/gnome-shell-extension-tool", line 151, in <module>
    subprocess.Popen(['gnome-open', extensionjs_path])
NameError: name 'extensionjs_path' is not defined

Also in gnome-shell-extensions-common 3.2.0-2~webupd8~oneiric

Chris McIntosh (gnu-know-who) wrote :

oops! Make that gnome-shell 3.2.1-0ubuntu1

Wang Tai (danny00wong) wrote :

at line 151:
subprocess.Popen(['gnome-open', extensionjs_path]) ==> subprocess.Popen(['gnome-open', extension_path])

can fix it

vanlong (pcvl441) wrote :

followed #9 and problem solved

at line 151:
subprocess.Popen(['gnome-open', extensionjs_path]) ==> subprocess.Popen(['gnome-open', extension_path])

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.2.2.1-0ubuntu1

---------------
gnome-shell (3.2.2.1-0ubuntu1) precise; urgency=low

  [ Jeremy Bicha ]
  * New upstream release
    - Fix broken gnome-shell-extension-tool (LP: #853882)
    - Fixes lots of crashes and some memory leaks
    - extensions.gnome.org should now work with Webkit-based browsers
  * Dropped upstream patches:
    - 05-NetworkMenu-don-t-query-DBus-properties-of-removed-o.patch
    - 06-NetworkMenu-fix-regression-in-access-point-removed.patch

  [ Timo Kluck ]
  * debian/patches/10-bluetooth-fix-connection-from-gs-menu.patch:
    - Fix bluetooth panel switch moving independently from actual
      connection status (LP: #918208)
 -- Jeremy Bicha <email address hidden> Mon, 23 Jan 2012 12:03:42 -0500

Changed in gnome-shell (Ubuntu):
status: Triaged → Fix Released
Jeremy Bicha (jbicha) on 2012-01-25
description: updated

Hello Wildjiji, or anyone else affected,

Accepted gnome-shell into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.