Depend gnome-session-fallback

Bug #852950 reported by Githlar on 2011-09-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Undecided
Unassigned

Bug Description

I think the gnome-shell package should depend on gnome-session-fallback. I had a headache of a time trying to get Gnome Shell working under a Oneiric Beta VM. The problem was that when I installed gnome-shell, gnome-session-fallback was not being installed. Due to the fact is was a VM, a very rudimentary graphics card was installed on the guest; a card that Gnome Shell doesn't support. Once it did the support test it would fail. At that point it tries to load /usr/share/gnome-session/sessions/gnome-fallback.session which doesn't exist and the entire session loading would fail.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.1.92-0ubuntu1

---------------
gnome-shell (3.1.92-0ubuntu1) oneiric; urgency=low

  [ Jeremy Bicha ]
  * New upstream release.
    - Adds browser plugin for installing, enabling, disabling, and
      uninstalling shell extensions. (Note that extensions.gnome.org
      isn't yet in operation.)
    - Lots of bugfixes
  * debian/control.in:
    - Depend on caribou libraries
    - Recommend gnome-session-fallback, needed when graphics support
      test fails (LP: #852950)
    - Bump minimum gjs dependency to 1.29.18 and minimum mutter
      to 3.1.92
  * debian/patches/01_favorite_apps.patch: Updated
  * debian/patches/04_build-without-caribou.patch: Dropped

  [ Martin Pitt ]
  * debian/control.in: Add libjson-glib-dev build dependency as per
    configure.ac.
 -- Jeremy Bicha <email address hidden> Thu, 22 Sep 2011 08:50:45 +0200

Changed in gnome-shell (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers