Should depend on cups-pk-helper

Bug #844864 reported by Alexander Hunziker on 2011-09-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Low
Unassigned

Bug Description

In oneiric, I was not able to add or remove printers in gnome-control-center, because the respective buttons were greyed out. I then figured out that I had to install cups-pk-helper in order to make the unlock button in the top right appear. I guess gnome-control-center should depend on that package, or else the printing capplet really doesn't serve any purpose.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-control-center 1:3.1.91-0ubuntu4
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
Architecture: amd64
Date: Thu Sep 8 16:37:56 2011
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
SourcePackage: gnome-control-center
UpgradeStatus: Upgraded to oneiric on 2011-09-07 (0 days ago)

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, what desktop do you use? Under unity we make the icon load system-config-printer because the GNOME capplet is limited in features, maybe you use another session?

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: New → Confirmed

Indeed I am using the gnome-shell session. I don't quite see why that is related to the session type though -- gnome-control-center is the same, isn't it?

Sebastien Bacher (seb128) wrote :

no it's not, the icons showed depend of the session, as said the GNOME printing dialog is limited in features compared to system-config-printer so under unity the icon start the system-config-printer software rather than displaying the GNOME dialog

I understand. Then may I suggest having gnome-shell recommend cups-pk-helper?

Martin Pitt (pitti) wrote :

As discussed in #u-desktop, let's add the recommends to gnome-shell at least for oneiric, less intrusive at this point.

affects: gnome-control-center (Ubuntu) → gnome-shell (Ubuntu)
Changed in gnome-shell (Ubuntu):
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.1.90.1-0ubuntu3

---------------
gnome-shell (3.1.90.1-0ubuntu3) oneiric; urgency=low

  * debian/control.in: Add Recommends: cups-pk-helper. This isn't necessary
    under Unity, as we show/use system-config-printer there, but in the GNOME
    session control-center shows the upstream printer applet. This is a
    workaround for oneiric to avoid adding cups-pk-helper to main and the
    default install after FF. (LP: #844864)
 -- Martin Pitt <email address hidden> Fri, 09 Sep 2011 17:54:50 +0200

Changed in gnome-shell (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers