gnome-shell doesn't start

Bug #629828 reported by Daniel Fett on 2010-09-03
38
This bug affects 10 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
High
Micah Gersten

Bug Description

Binary package hint: gnome-shell

Fresh install of maverick, using home dir from lucid. After starting gnome-shell --replace from the terminal, nothing happens. Actually it behaves like starting metacity --replace and shows the following message:

daniel@c64:~$ gnome-shell --replace

(mutter:21736): mutter-WARNING **: Could not load library [/usr/lib/mutter/plugins/libgnome-shell.so (libmozjs.so: cannot open shared object file: No such file or directory)]

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gnome-shell 2.31.5-2ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Fri Sep 3 22:39:08 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha amd64 (20100803.1)
ProcEnviron:
 LANGUAGE=de_DE:de:en
 PATH=(custom, user)
 LANG=de_DE.utf8
 SHELL=/bin/bash
SourcePackage: gnome-shell

Daniel Fett (fett-ubuntu) wrote :
Micah Gersten (micahg) wrote :

Thank you for reporting this to Ubuntu. This is actually In Progress. This will we fixed when I upload the fix for bug 576991 which will happen over the weekend. Please report any other issues you may find.

Changed in gnome-shell (Ubuntu):
assignee: nobody → Micah Gersten (micahg)
importance: Undecided → High
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 2.31.5-2ubuntu2

---------------
gnome-shell (2.31.5-2ubuntu2) maverick; urgency=low

  * Fix gnome-shell to set LD_LIBRARY_PATH so that libmozjs can be found;
    Don't use pkg-config, use xulrunner-1.9.2 to figure out the path to
    libmozjs (LP: #576991) (LP: #629828)
    - update debian/patches/04_workaround_libmozjs_build.patch
  * Drop binary depends on pkg-config and replace with xulrunner-1.9.2;
    xulrunner-1.9.2 is already pulled in by the depends in any case, but
    now it's needed directly by gnome-shell
    - update debian/control.in
 -- Micah Gersten <email address hidden> Sat, 04 Sep 2010 21:00:09 -0500

Changed in gnome-shell (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers