depency conflict with libgjs0 and xulrunner

Bug #555155 reported by moguay
348
This bug affects 73 people
Affects Status Importance Assigned to Milestone
gjs (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by der_vegi
gnome-shell (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by der_vegi

Bug Description

UPDATE 2:
This bug has been fixed. If you notice it again, it means it has re-appeared, but you need to file a new bug since the situation is different.
Please see bugs:
https://bugs.launchpad.net/ubuntu/+source/gjs/+bug/597944
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/576991

UPDATE:
Blocked by this bug: https://bugs.launchpad.net/bugs/537903 (affects i386, armel, but not amd64)

Binary package hint: gnome-shell

sudo apt-get install gnome-shell
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  gnome-shell: Depends: libgjs0 but it is not going to be installed

sudo apt-get install libgjs0
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libgjs0: Depends: xulrunner-1.9.1 (<= 1.9.1.9~) but 1.9.1.9+nobinonly-0ubuntu1 is to be installed
E: Broken packages

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gnome-shell (not installed)
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sun Apr 4 15:32:18 2010
ProcEnviron:
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-shell

Julien Lavergne (gilir)
Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Revision history for this message
Savvas Radevic (medigeek) wrote :

I think it's the gjs package that has the problem:

$ sudo apt-get install libgjs0
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libgjs0: Depends: xulrunner-1.9.1 (<= 1.9.1.9~) but 1.9.1.9+nobinonly-0ubuntu1 is to be installed
E: Broken packages

Revision history for this message
Crashbit (crashbit-gmail) wrote :

I have the same problem:

-------------------------------
crashbit@m1330:~$ sudo aptitude install libgjs0
S'està llegint la llista de paquets... Fet
S'està construint l'arbre de dependències
S'està llegint la informació de l'estat... Fet
S'està llegint la informació d'estat estesa
S'estan inicialitzant els estats dels paquets... Fet
Els paquets següents contenen errors.
  libgjs0
Els paquets nous següents s'instal·laran:
  libgirepository1.0-0{a}
0 paquets a actualitzar, 2 a instal·lar, 0 a suprimir i 0 a no actualitzar.
Es necessita obtenir 211kB d'arxius. Després del desempaquetat s'utilitzaran 754kB.
No s'han trobat les dependències del paquets següents:
  libgjs0: Depèn: xulrunner-1.9.1 (<= 1.9.1.9~) però el 1.9.1.9+nobinonly-0ubuntu1 està instal·lat.
Les accions següents resoldran les dependències:

Mantín la versió actual dels següents paquets:
libgjs0 [No instal·lat]

La puntuació és -9879

Accepteu la solució? [Y/n/q/?] Y
No s'instal·larà, actualitzarà o suprimirà cap paquet.
0 paquets a actualitzar, 0 a instal·lar, 0 a suprimir i 0 a no actualitzar.
Es necessita obtenir 0B d'arxius. Després del desempaquetat s'utilitzaran 0B.
Esteu segur de voler continuar? [Y/n/?] n
Avorta.
crashbit@m1330:~$
------------------------------------

-------------------------------------
crashbit@m1330:~$ apt-cache policy libgjs0
libgjs0:
  Instal·lat: (cap)
  Candidat: 0.5-1ubuntu1
  Taula de versió:
     0.5-1ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ lucid/universe Packages
crashbit@m1330:~$
------------------------------------------

--------------------------------------------

crashbit@m1330:~$ apt-cache policy xulrunner-1.9.1
xulrunner-1.9.1:
  Instal·lat: 1.9.1.9+nobinonly-0ubuntu1
  Candidat: 1.9.1.9+nobinonly-0ubuntu1
  Taula de versió:
 *** 1.9.1.9+nobinonly-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ lucid/universe Packages
        100 /var/lib/dpkg/status
crashbit@m1330:~$
-----------------------------------------

Revision history for this message
JPedro (pedro-tumusok) wrote :

I see this problem in Lucid Lynx (10.4 LTS Beta 2) the install was a clean Beta 1 that got upgraded to Beta 2.
And when I tried to install gnome-shell, never installed on this machine before, it stops with libgjs0 dependencies and the xul-runner issue as listed above.

jpt@jpt-laptop:~$ sudo apt-get install gnome-shell
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  gnome-shell: Depends: libgjs0 but it is not going to be installed
E: Broken packages

jpt@jpt-laptop:~$ sudo apt-get install libgjs0
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libgjs0: Depends: xulrunner-1.9.1 (<= 1.9.1.9~) but 1.9.1.9+nobinonly-0ubuntu1 is to be installed
E: Broken packages

Revision history for this message
TuteC (tutecosta) wrote :

Downloading the package from https://launchpad.net/ubuntu/lucid/i386/libgjs0/0.4-3ubuntu4 made it work (although gnome shell isn't working as expected).
Regards.

Revision history for this message
Savvas Radevic (medigeek) wrote :

It's not the gnome-shell package -- gjs needs a rebuild and a bump of xulrunner-1.9.2 in debian/rules

Changed in gnome-shell (Ubuntu):
status: Confirmed → Invalid
Changed in gjs (Ubuntu):
status: New → Confirmed
Revision history for this message
Savvas Radevic (medigeek) wrote :

Adding patch to resolve the issue

Revision history for this message
Micah Gersten (micahg) wrote :

There's a problem with xulrunner-1.9.2 and gjs. See Bug #537903

Revision history for this message
Savvas Radevic (medigeek) wrote : Re: [Bug 555155] Re: depency conflict with libgjs0 and xulrunner

> There's a problem with xulrunner-1.9.2 and gjs.  See Bug #537903
Ouch... Thanks for the tip, I have amd64, that's why it worked here :)

Revision history for this message
Eric Carvalho (eric-carvalho) wrote :

Same problem:

carvalho@TIAD02:~$ sudo aptitude install gnome-shell
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages are BROKEN:
  libgjs0
The following NEW packages will be installed:
  gir1.0-atk-1.0{a} gir1.0-clutter-1.0{a} gir1.0-freedesktop{a} gir1.0-glib-2.0{a} gir1.0-gtk-2.0{a} gir1.0-mutter-2.28{a} gir1.0-pango-1.0{a} gnome-shell
  libgirepository1.0-0{a} libmutter-private0{a} mesa-utils{a} mutter{a} mutter-common{a} xbase-clients{a} xserver-xephyr{a} xulrunner-1.9.1{a}
0 packages upgraded, 17 newly installed, 0 to remove and 0 not upgraded.
Need to get 14.7MB of archives. After unpacking 45.0MB will be used.
The following packages have unmet dependencies:
  libgjs0: Depends: xulrunner-1.9.1 (<= 1.9.1.9~) but 1.9.1.9+nobinonly-0ubuntu1 is to be installed.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
gnome-shell [Not Installed]
libgjs0 [Not Installed]

description: updated
Revision history for this message
sam tygier (samtygier) wrote :

Bug #537903 is fixed, and i was able to install gnome shell on i386

Changed in gjs (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
vince (vince06fr) wrote :

not resolve for me!

"Les paquets suivants contiennent des dépendances non satisfaites :
  gnome-shell: Dépend: libgjs0 mais ne sera pas installé
E: Paquets défectueux"

Revision history for this message
Savvas Radevic (medigeek) wrote :

@vince: I guess you are using a french mirror.
Set it to the main mirror at menu: System -> administration ->
software sources -> Download from: "Main server". Then "Close" and
"Reload". I don't know the naming in French :)

Revision history for this message
rabid9797 (rabid9797) wrote :

@Savvas

I don't think this is a problem with what mirror is being used. I use a server from the US(and have tried using the main server as well) and I'm still seeing this bug. A fix may have been released but it has not been committed to the repositories. For those of us who don't know how to use debdiff to build a new verzion of libgjs0, we are still out of luck.

Revision history for this message
Savvas Radevic (medigeek) wrote :

I disagree, I use main mirror and it looks fine:

$ apt-cache policy libgjs0
libgjs0:
  Installed: (none)
  Candidate: 0.5-1ubuntu2
  Version table:
     0.5-1ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ lucid/universe Packages

$ sudo apt-get install gnome-shell
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  gir1.0-atk-1.0 gir1.0-clutter-1.0 gir1.0-freedesktop gir1.0-glib-2.0
gir1.0-gtk-2.0 gir1.0-mutter-2.28
  gir1.0-pango-1.0 libgjs0 mesa-utils xserver-xephyr
The following NEW packages will be installed:
  gir1.0-atk-1.0 gir1.0-clutter-1.0 gir1.0-freedesktop gir1.0-glib-2.0
gir1.0-gtk-2.0 gir1.0-mutter-2.28
  gir1.0-pango-1.0 gnome-shell libgjs0 mesa-utils xserver-xephyr
0 upgraded, 11 newly installed, 0 to remove and 0 not upgraded.
Need to get 3,293kB/3,508kB of archives.
After this operation, 8,159kB of additional disk space will be used.
Do you want to continue [Y/n]? y

Get:1 http://archive.ubuntu.com/ubuntu/ lucid/main gir1.0-glib-2.0
0.6.8-1 [116kB]
Get:2 http://archive.ubuntu.com/ubuntu/ lucid/main gir1.0-atk-1.0
1.30.0-0ubuntu2 [17.1kB]
Get:3 http://archive.ubuntu.com/ubuntu/ lucid/main gir1.0-freedesktop
0.6.8-1 [14.8kB]
Get:4 http://archive.ubuntu.com/ubuntu/ lucid/main gir1.0-pango-1.0
1.28.0-0ubuntu2 [87.7kB]
Get:5 http://archive.ubuntu.com/ubuntu/ lucid/main gir1.0-clutter-1.0
1.2.4-0ubuntu1 [84.2kB]
Get:6 http://archive.ubuntu.com/ubuntu/ lucid/main gir1.0-gtk-2.0
2.20.0-0ubuntu4 [549kB]
Get:7 http://archive.ubuntu.com/ubuntu/ lucid/universe
gir1.0-mutter-2.28 2.28.1~git20091208-1ubuntu7 [73.2kB]
Get:8 http://archive.ubuntu.com/ubuntu/ lucid/main xserver-xephyr
2:1.7.6-2ubuntu7 [1,878kB]
Get:9 http://archive.ubuntu.com/ubuntu/ lucid/universe gnome-shell
2.28.1~git20091125-1 [472kB]
Fetched 3,293kB in 38s (86.6kB/s)
Selecting previously deselected package gir1.0-glib-2.0.
(Reading database ... 272525 files and directories currently installed.)
Unpacking gir1.0-glib-2.0 (from .../gir1.0-glib-2.0_0.6.8-1_amd64.deb) ...
Selecting previously deselected package gir1.0-atk-1.0.
[...]
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place

Revision history for this message
Savvas Radevic (medigeek) wrote :

> For those of us who don't know how to use
> debdiff to build a new verzion of libgjs0, we are still out of luck.

I disagree on that too :)
32-bit package:
http://archive.ubuntu.com/ubuntu/pool/universe/g/gjs/libgjs0_0.5-1ubuntu2_i386.deb
64-bit package:
http://archive.ubuntu.com/ubuntu/pool/universe/g/gjs/libgjs0_0.5-1ubuntu2_amd64.deb

Reinstall if you already have it installed, and then try to install gnome-shell:
sudo apt-get install gnome-shell

Revision history for this message
Damien MAURAN (dmauran) wrote :

Today, a new update of xul-runner make this bug back :

****************************

dmauran@dmauran-netbook:~$ sudo apt-get install gnome-shell
[sudo] password for dmauran:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
  gnome-shell: Dépend: libgjs0 mais ne sera pas installé
E: Paquets défectueux
dmauran@dmauran-netbook:~$ sudo apt-get install libgjs
libgjs0 libgjs-dev
dmauran@dmauran-netbook:~$ sudo apt-get install libgjs0
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
  libgjs0: Dépend: xulrunner-1.9.2 (<= 1.9.2.4~) mais 1.9.2.6+nobinonly-0ubuntu0.10.04.1 devra être installé
E: Paquets défectueux
dmauran@dmauran-netbook:~$

*********************************

It's again the libgjs0 package dependencies bug ...

Revision history for this message
Micah Gersten (micahg) wrote :

We already have bug 597944 for that issue.

On 07/02/2010 04:16 AM, Damien MAURAN wrote:
> Today, a new update of xul-runner make this bug back :
>
> ****************************
>
> dmauran@dmauran-netbook:~$ sudo apt-get install gnome-shell
> [sudo] password for dmauran:
> Lecture des listes de paquets... Fait
> Construction de l'arbre des dépendances
> Lecture des informations d'état... Fait
> Certains paquets ne peuvent être installés. Ceci peut signifier
> que vous avez demandé l'impossible, ou bien, si vous utilisez
> la distribution unstable, que certains paquets n'ont pas encore
> été créés ou ne sont pas sortis d'Incoming.
> L'information suivante devrait vous aider à résoudre la situation :
>
> Les paquets suivants contiennent des dépendances non satisfaites :
> gnome-shell: Dépend: libgjs0 mais ne sera pas installé
> E: Paquets défectueux
> dmauran@dmauran-netbook:~$ sudo apt-get install libgjs
> libgjs0 libgjs-dev
> dmauran@dmauran-netbook:~$ sudo apt-get install libgjs0
> Lecture des listes de paquets... Fait
> Construction de l'arbre des dépendances
> Lecture des informations d'état... Fait
> Certains paquets ne peuvent être installés. Ceci peut signifier
> que vous avez demandé l'impossible, ou bien, si vous utilisez
> la distribution unstable, que certains paquets n'ont pas encore
> été créés ou ne sont pas sortis d'Incoming.
> L'information suivante devrait vous aider à résoudre la situation :
>
> Les paquets suivants contiennent des dépendances non satisfaites :
> libgjs0: Dépend: xulrunner-1.9.2 (<= 1.9.2.4~) mais
1.9.2.6+nobinonly-0ubuntu0.10.04.1 devra être installé
> E: Paquets défectueux
> dmauran@dmauran-netbook:~$
>
> *********************************
>
> It's again the libgjs0 package dependencies bug ...
>

Revision history for this message
frizzle21 (frederik-nnaji) wrote :

oh sh#t we so desperately need a "Related bugs" manually editable section up on the right hand side panel.

Revision history for this message
Sue Ori (orisue) wrote :

I also still have the issue. 64bit version 10.04.
Gnome-shell stopped working after standard daily update... :(
Trying to install gnome-shell gives back the dependency error for libgjs0.
Trying to install that libgjs0 package refers to the xulrunner error.
Die folgenden Pakete haben nicht-erfüllte Abhängigkeiten:
  libgjs0: Hängt ab: xulrunner-1.9.2 (<= 1.9.2.4~) aber 1.9.2.6+nobinonly-0ubuntu0.10.04.1 soll installiert werden

Still not solved...

description: updated
Revision history for this message
aaron.w.ball (aaron-w-ball) wrote :

Same issue here.

More specifically though:
I added the ricotz/testing ppa and installed. When running "gnome-shell --replace", gnome-shell crashed and reverted back to metacity. The reason for that is related to another bug (some dependency problem). Either way, I removed gnome-shell with purge. I then removed the repo and ran "apt-get update". After that I tried installing gnome-shell and received the error

The following packages have unmet dependencies:
  gnome-shell: Depends: libgjs0 but it is not going to be installed
E: Broken packages

Tried installing libgjs0 and received the error

The following packages have unmet dependencies:
  libgjs0: Depends: xulrunner-1.9.2 (<= 1.9.2.4~) but 1.9.2.6+nobinonly-0ubuntu0.10.04.1 is to be installed
E: Broken packages

Running 10.04 32 bit.

//
// Note: Before installing gnome-shell from the ricotz/testing ppa, gnome-shell installed and ran fine.
//

Revision history for this message
Micah Gersten (micahg) wrote :

See bug 597944. There's an update in lucid-proposed and will be copied
to lucid-updates next week.

On 07/14/2010 01:34 PM, aaron.w.ball wrote:
> Same issue here.
>
> More specifically though:
> I added the ricotz/testing ppa and installed. When running "gnome-shell --replace", gnome-shell crashed and reverted back to metacity. The reason for that is related to another bug (some dependency problem). Either way, I removed gnome-shell with purge. I then removed the repo and ran "apt-get update". After that I tried installing gnome-shell and received the error
>
> The following packages have unmet dependencies:
> gnome-shell: Depends: libgjs0 but it is not going to be installed
> E: Broken packages
>
> Tried installing libgjs0 and received the error
>
> The following packages have unmet dependencies:
> libgjs0: Depends: xulrunner-1.9.2 (<= 1.9.2.4~) but 1.9.2.6+nobinonly-0ubuntu0.10.04.1 is to be installed
> E: Broken packages
>
> Running 10.04 32 bit.
>
> //
> // Note: Before installing gnome-shell from the ricotz/testing ppa, gnome-shell installed and ran fine.
> //
>
>

Revision history for this message
Neal McBurnett (nealmcb) wrote :

And the next iteration is now in lucid-proposed, in need of testing for SRU: bug 608940

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions