Overview search causes the workarea to reshape, desktop-icons-ng to restart and the new window to lose focus

Bug #1922772 reported by Sai Vinoba on 2021-04-06
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
High
Daniel van Vugt

Bug Description

Release: Ubuntu 21.04 (20210406 iso image)

Software, version: gnome-shell, 3.38.4-1ubuntu1

How to reproduce:
1) Boot up Ubuntu 21.04 image (live session or installed)
2) Once inside shell, go to overview (either using Super key or clicking on Activities)
3) Search for any application (eg., terminal) and launch it.

Expected:
The application launches normally and usable.

Actual:
The application launches but the window looses focus. When the application is launching, the desktop icons disappear for few seconds and reappear. When they reappear the launched application window will not have focus.

If we launch the application from the app grid (without searching first) or from the dock, the window retains the focus.

Tested on VM (quickemu and virt-manager).

ProblemType: Bug
DistroRelease: Ubuntu 21.04
Package: gnome-shell 3.38.4-1ubuntu1
ProcVersionSignature: Ubuntu 5.11.0-13.14-generic 5.11.7
Uname: Linux 5.11.0-13-generic x86_64
ApportVersion: 2.20.11-0ubuntu61
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Tue Apr 6 22:14:04 2021
DisplayManager: gdm3
InstallationDate: Installed on 2021-04-06 (0 days ago)
InstallationMedia: Ubuntu 21.04 "Hirsute Hippo" - Beta amd64 (20210405)
ProcEnviron:
 LANGUAGE=en_IN:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_IN
 SHELL=/bin/bash
RelatedPackageVersions: mutter-common 3.38.4-1ubuntu1
SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Sai Vinoba (saivinob) wrote :
Revision history for this message
Sai Vinoba (saivinob) wrote :

Attaching screenshot of the issue.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Revision history for this message
Daniel van Vugt (vanvugt) wrote : Re: App search causes Ubuntu Dock to hide, desktop-icons-ng to restart and the new window to lose focus

Seems this is caused by the Ubuntu Dock extension.

summary: - Application window looses focus when launched from search but not when
- launched from app grid
+ App search causes Ubuntu Dock to hide, desktop-icons-ng to restart and
+ the new window to lose focus
Changed in gnome-shell (Ubuntu):
importance: Undecided → High
affects: gnome-shell (Ubuntu) → gnome-shell-extension-ubuntu-dock (Ubuntu)
tags: added: regression-release rls-hh-incoming
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

It's a complicated series of events but in the end it's really just Ubuntu Dock that's the problem...

1. Open the overview using Super.

2. Start typing in "Type to search". While you're typing the Ubuntu Dock disappears.

3. Because the Ubuntu Dock disappeared, the workspace shape has changed so the desktop icons disappear but you don't notice because you're still in the overview.

4. Hit Enter to complete the search and launch the app.

5. The Ubuntu Dock reappears.

6. desktop-icons-ng restarts, which takes the focus away (because it too is a window now) from the newly launched app.

Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
status: Confirmed → In Progress
no longer affects: dash-to-dock
summary: - App search causes Ubuntu Dock to hide, desktop-icons-ng to restart and
- the new window to lose focus
+ App search causes the workarea to reshape, desktop-icons-ng to restart
+ and the new window to lose focus
affects: gnome-shell-extension-ubuntu-dock (Ubuntu) → gnome-shell (Ubuntu)
Revision history for this message
Daniel van Vugt (vanvugt) wrote : Re: App search causes the workarea to reshape, desktop-icons-ng to restart and the new window to lose focus
summary: - App search causes the workarea to reshape, desktop-icons-ng to restart
- and the new window to lose focus
+ Overview search causes the workarea to reshape, desktop-icons-ng to
+ restart and the new window to lose focus
Changed in gnome-shell (Ubuntu):
status: In Progress → Fix Committed
tags: removed: rls-hh-incoming
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.38.4-1ubuntu2

---------------
gnome-shell (3.38.4-1ubuntu2) hirsute; urgency=medium

  [ Daniel van Vugt ]
  * Add layout-Try-to-allocate-before-getting-size-of-tracke.patch.
    To fix LP: #1919979 and also to re-fix LP: #1917939
    (LP: #1919979, #1917939)
  * Drop layout-Allow-updating-struts-in-Overview.patch.
    Because it caused a regression and doesn't seem to have been necessary
    anyway. (LP: #1922772)

  [ Marco Trevisan (Treviño) ]
  * debian/patches: Fix suggestions box actor population in non-latin languages
    (LP: #1914230)
  * debian/patches: Enable to use Escape to cancel auth requests (with limits)
    (LP: #1921929)
  * debian/patches: Refresh

 -- Marco Trevisan (Treviño) <email address hidden> Thu, 15 Apr 2021 06:20:27 +0200

Changed in gnome-shell (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.