Dock covers the top panel during the login animation

Bug #1919979 reported by Daniel van Vugt on 2021-03-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Low
Daniel van Vugt

Bug Description

Dock covers the top panel during the login animation (top left corner of the screen).

Changed in gnome-shell-extension-dashtodock (Ubuntu):
importance: Undecided → Low
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Looks like a regression that started in GNOME 3.38.2 but I don't yet know which project.

Changed in gnome-shell (Ubuntu):
status: New → Incomplete
Changed in gnome-shell-extension-dashtodock (Ubuntu):
status: New → Incomplete
tags: added: regression-update
Changed in mutter (Ubuntu):
status: New → Incomplete
Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: New → Incomplete
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

29351b3a60938e6ef9b22323831b05be36438cd5 is the first bad commit
commit 29351b3a60938e6ef9b22323831b05be36438cd5
Author: Jonas Dreßler <email address hidden>
Date: Fri Oct 16 21:29:02 2020 +0000

    clutter/actor: Only allocate when actor is mapped, not only visible

Changed in mutter (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Low
assignee: nobody → Daniel van Vugt (vanvugt)
no longer affects: gnome-shell (Ubuntu)
no longer affects: gnome-shell-extension-dashtodock (Ubuntu)
no longer affects: gnome-shell-extension-ubuntu-dock (Ubuntu)
Changed in gnome-shell-extension-dashtodock (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
importance: Undecided → Low
Changed in gnome-shell-extension-dashtodock (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: New → Triaged
Changed in gnome-shell-extension-dashtodock (Ubuntu):
status: Triaged → In Progress
Changed in mutter (Ubuntu):
status: Triaged → In Progress
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

It appears dash-to-dock is listening for 'workareas-changed' correctly. The problem is the first 'workareas-changed' happens before the panel exists, so it's the wrong work area. And then the second 'workareas-changed' happens around 900ms after the panel is allocated, which is also after the startup animation. So it seems the bug really is that 'workareas-changed' is not being emitted between the panel being allocated and the startup animation completing. This would affect a variety of extensions; not just docks but also desktop icons.

affects: mutter (Ubuntu) → gnome-shell (Ubuntu)
Changed in gnome-shell-extension-dashtodock (Ubuntu):
status: In Progress → Invalid
Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: Triaged → Invalid
Changed in gnome-shell-extension-dashtodock (Ubuntu):
assignee: Daniel van Vugt (vanvugt) → nobody
Revision history for this message
Daniel van Vugt (vanvugt) wrote :
no longer affects: gnome-shell-extension-dashtodock (Ubuntu)
no longer affects: gnome-shell-extension-ubuntu-dock (Ubuntu)
Revision history for this message
Daniel van Vugt (vanvugt) wrote :
Changed in gnome-shell (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.38.4-1ubuntu2

---------------
gnome-shell (3.38.4-1ubuntu2) hirsute; urgency=medium

  [ Daniel van Vugt ]
  * Add layout-Try-to-allocate-before-getting-size-of-tracke.patch.
    To fix LP: #1919979 and also to re-fix LP: #1917939
    (LP: #1919979, #1917939)
  * Drop layout-Allow-updating-struts-in-Overview.patch.
    Because it caused a regression and doesn't seem to have been necessary
    anyway. (LP: #1922772)

  [ Marco Trevisan (Treviño) ]
  * debian/patches: Fix suggestions box actor population in non-latin languages
    (LP: #1914230)
  * debian/patches: Enable to use Escape to cancel auth requests (with limits)
    (LP: #1921929)
  * debian/patches: Refresh

 -- Marco Trevisan (Treviño) <email address hidden> Thu, 15 Apr 2021 06:20:27 +0200

Changed in gnome-shell (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers