On-screen keyboard for Japanese doesn't display Japanese characters, only English

Bug #1914230 reported by Hatsune on 2021-02-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME Shell
Unknown
Unknown
gnome-shell (Ubuntu)
Medium
Unassigned

Bug Description

This is about touch keyboard.
Screen keyboard doesn't display other languages characters, only english characters. I noticed many users concern about that on forums

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Please choose a specific language for this bug to be about.

tags: added: osk
Changed in gnome-shell (Ubuntu):
status: New → Incomplete
importance: Undecided → Wishlist
Revision history for this message
Hatsune (hatsune) wrote :

@vanvugt "Please choose a specific language for this bug to be about."
Tamil, Thai, Sinhala(Sinhalese), Korean, Chinese, Japanese etc.

Steps to reproduce
1. Add these languages (may not need to apply system wide)
2. Switch to eg: Japanese
3. Tap(touch) on text field then screen keyboard will be appear automatically
   (Or force open screen keyboard manually)
4. You will see that, it still appear in english

(This also applicable to english characters based languages similar Spanish. just doesn't appear its unique screen keyboard)

Changed in gnome-shell (Ubuntu):
status: Incomplete → New
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

OK, let's make this bug about Japanese which is already being tracked in https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/3422

Thai it seems already exists in GNOME 3.36 according to https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/3106

The other keyboard layouts I'm not sure about. Please log upstream bugs for each at: https://gitlab.gnome.org/GNOME/gnome-shell/-/issues

summary: - [High priority] Screen keyboard doesn't display other languages
- characters, only english
+ On-screen keyboard for Japanese doesn't display Japanese characters,
+ only English
Changed in gnome-shell (Ubuntu):
importance: Wishlist → Medium
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Indeed it seems of that list only Thai alreay exists:
https://gitlab.gnome.org/GNOME/gnome-shell/-/tree/master/data/osk-layouts

For the other missing layouts please open a new bug for each one at:
https://gitlab.gnome.org/GNOME/gnome-shell/-/issues

Changed in gnome-shell (Ubuntu):
status: New → Triaged
tags: added: i18n
Revision history for this message
Hatsune (hatsune) wrote :

@vanvugt i'll fix that myself ^_^

Changed in gnome-shell (Ubuntu):
status: Triaged → Fix Committed
tags: added: fixed-in-3.38.5 fixed-in-40.1 fixed-upstream
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.38.4-1ubuntu2

---------------
gnome-shell (3.38.4-1ubuntu2) hirsute; urgency=medium

  [ Daniel van Vugt ]
  * Add layout-Try-to-allocate-before-getting-size-of-tracke.patch.
    To fix LP: #1919979 and also to re-fix LP: #1917939
    (LP: #1919979, #1917939)
  * Drop layout-Allow-updating-struts-in-Overview.patch.
    Because it caused a regression and doesn't seem to have been necessary
    anyway. (LP: #1922772)

  [ Marco Trevisan (Treviño) ]
  * debian/patches: Fix suggestions box actor population in non-latin languages
    (LP: #1914230)
  * debian/patches: Enable to use Escape to cancel auth requests (with limits)
    (LP: #1921929)
  * debian/patches: Refresh

 -- Marco Trevisan (Treviño) <email address hidden> Thu, 15 Apr 2021 06:20:27 +0200

Changed in gnome-shell (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.