Mouse stop moving after few seconds. restart at click

Bug #1905946 reported by corrado venturini
36
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

Mouse stop moving after few seconds if i don't continue moving it, restart moving if i click but after few seconds sstops again.
Problem occurs with both X11 and Wayland session.
corrado@corrado-x2-hh-1104:~$ inxi -Fx
System: Host: corrado-x2-hh-1104 Kernel: 5.8.0-25-generic x86_64 bits: 64 compiler: gcc v: 10.2.0
           Desktop: GNOME 3.38.1 Distro: Ubuntu 21.04 (Hirsute Hippo)
Machine: Type: Desktop Mobo: ASRock model: H110M-G/M.2 serial: <superuser/root required>
           UEFI: American Megatrends v: P1.10 date: 05/11/2017
CPU: Info: Dual Core model: Intel Core i3-7100 bits: 64 type: MT MCP arch: Kaby Lake rev: 9
           L2 cache: 3072 KiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31199
           Speed: 800 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800
Graphics: Device-1: Intel HD Graphics 630 vendor: ASRock driver: i915 v: kernel bus ID: 00:02.0
           Device-2: ARC USB 2.0 Camera type: USB driver: uvcvideo bus ID: 1-1:2
           Display: x11 server: X.Org 1.20.9 driver: modesetting unloaded: fbdev,vesa
           resolution: 1920x1080~60Hz
           OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 20.2.2
           direct render: Yes
Audio: Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASRock
           driver: snd_hda_intel v: kernel bus ID: 00:1f.3
           Device-2: Logitech QuickCam Pro 9000 type: USB driver: snd-usb-audio,uvcvideo
           bus ID: 1-8:5
           Sound Server: ALSA v: k5.8.0-25-generic
Network: Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e v: 3.2.6-k port: f040
           bus ID: 00:1f.6
           IF: enp0s31f6 state: up speed: 100 Mbps duplex: full mac: 70:85:c2:44:7b:86
Drives: Local Storage: total: 2.05 TiB used: 15.92 GiB (0.8%)
           ID-1: /dev/nvme0n1 vendor: Kingston model: SKC2000M8250G size: 232.89 GiB
           ID-2: /dev/sda vendor: Toshiba model: DT01ACA100 size: 931.51 GiB
           ID-3: /dev/sdb vendor: Hitachi model: HDS721010CLA332 size: 931.51 GiB
Partition: ID-1: / size: 31.25 GiB used: 15.91 GiB (50.9%) fs: ext4 dev: /dev/nvme0n1p2
Swap: ID-1: swap-1 type: partition size: 8.00 GiB used: 0 KiB (0.0%) dev: /dev/sda2
Sensors: System Temperatures: cpu: 45.5 C mobo: N/A
           Fan Speeds (RPM): N/A
Info: Processes: 213 Uptime: 1h 31m Memory: 7.48 GiB used: 1.75 GiB (23.4%) Init: systemd
           runlevel: 5 Compilers: gcc: N/A Packages: 1937 Shell: Bash v: 5.1.0-rc2 inxi: 3.1.09
corrado@corrado-x2-hh-1104:~$

ProblemType: Bug
DistroRelease: Ubuntu 21.04
Package: gnome-shell 3.38.1-1ubuntu2
ProcVersionSignature: Ubuntu 5.8.0-25.26-generic 5.8.14
Uname: Linux 5.8.0-25-generic x86_64
ApportVersion: 2.20.11-0ubuntu53
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Fri Nov 27 11:12:40 2020
DisplayManager: gdm3
InstallationDate: Installed on 2020-11-04 (22 days ago)
InstallationMedia: Ubuntu 21.04 "Hirsute Hippo" - Alpha amd64 (20201104)
RelatedPackageVersions: mutter-common 3.38.1-2ubuntu1
SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
corrado venturini (corradoventu) wrote :
Revision history for this message
corrado venturini (corradoventu) wrote :

Same problem on a different hardware:
System: Host: corrado-n7-hh-1104 Kernel: 5.8.0-25-generic x86_64 bits: 64 compiler: gcc
           v: 10.2.0 Desktop: GNOME 3.38.1 Distro: Ubuntu 21.04 (Hirsute Hippo)
Machine: Type: Laptop System: Dell product: Inspiron 3793 v: N/A
           serial: <superuser/root required>
           Mobo: Dell model: 0C1PF2 v: A00 serial: <superuser/root required> UEFI: Dell v: 1.5.0
           date: 12/17/2019
CPU: Info: Quad Core model: Intel Core i5-1035G1 bits: 64 type: MT MCP arch: Ice Lake
           rev: 5 L2 cache: 6144 KiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19046
           Speed: 704 MHz min/max: 400/3600 MHz Core speeds (MHz): 1: 1194 2: 1258 3: 1101
           4: 1284 5: 1039 6: 1138 7: 807 8: 1293
Graphics: Device-1: Intel Iris Plus Graphics G1 vendor: Dell driver: i915 v: kernel
           bus ID: 00:02.0
           Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus ID: 1-6:3
           Display: x11 server: X.Org 1.20.9 driver: modesetting unloaded: fbdev,vesa
           resolution: 1920x1080
           OpenGL: renderer: Mesa Intel UHD Graphics (ICL GT1) v: 4.6 Mesa 20.2.2
           direct render: Yes
corrado@corrado-n7-hh-1104:~$

Revision history for this message
corrado venturini (corradoventu) wrote :

Problem does not happen with live Ubuntu 21.04 "Hirsute Hippo" - Alpha amd64 (20201125) or ubuntu installed from this ISO but reappear after following updates:
24 packages can be upgraded. Run 'apt list --upgradable' to see them.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  libdebuginfod1
The following packages will be upgraded:
  apport apport-gtk gdb gdbserver gir1.2-rsvg-2.0 libasound2 libasound2-data libatopology2 libdjvulibre-text libdjvulibre21 libegl-mesa0 libfprint-2-2
  libgbm1 libgl1-mesa-dri libglapi-mesa libglx-mesa0 libqpdf28 librsvg2-2 librsvg2-common libxatracker2 linux-firmware mesa-vulkan-drivers python3-apport
  python3-problem-report
24 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 157 MB of archives.
After this operation, 2.348 kB of additional disk space will be used.
Do you want to continue? [Y/n]

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Revision history for this message
AO (aofrl10n) wrote :

Same problem on Hirsute, Logitech touch pad (not a laptop) and keyboard are mostly unusable because they lag/stop working.

Revision history for this message
Per-Inge (per-inge-hallin) wrote :

Same problem mouse is Steeleries Rival 110
My configuration is
p-i@pi-TUF-Gaming-B550M:~$ inxi -Fz
System: Kernel: 5.8.0-25-generic x86_64 bits: 64 Desktop: GNOME 3.38.1 Distro: Ubuntu 21.04 (Hirsute Hippo)
Machine: Type: Desktop System: ASUS product: N/A v: N/A serial: <filter>
           Mobo: ASUSTeK model: TUF GAMING B550M-PLUS (WI-FI) v: Rev X.0x serial: <filter> UEFI: American Megatrends v: 1212
           date: 11/04/2020
CPU: Info: 6-Core model: AMD Ryzen 5 5600X bits: 64 type: MT MCP L2 cache: 3072 KiB
           Speed: 2196 MHz min/max: 2200/3700 MHz Core speeds (MHz): 1: 2198 2: 2198 3: 2199 4: 2200 5: 2199 6: 2194 7: 2198
           8: 2201 9: 2193 10: 2195 11: 2194 12: 2192
Graphics: Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] driver: amdgpu
           v: kernel
           Display: x11 server: X.Org 1.20.9 driver: amdgpu,ati unloaded: fbdev,modesetting,radeon,vesa
           resolution: 2560x1440~60Hz
           OpenGL: renderer: AMD Radeon RX 5700 (NAVI10 DRM 3.38.0 5.8.0-25-generic LLVM 11.0.0) v: 4.6 Mesa 20.2.2
Audio: Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 HDMI Audio driver: snd_hda_intel
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio driver: snd_hda_intel
           Sound Server: ALSA v: k5.8.0-25-generic
Network: Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi
           IF: wlp6s0 state: up mac: <filter>
           Device-2: Realtek RTL8125 2.5GbE driver: N/A
Drives: Local Storage: total: 1.36 TiB used: 24.03 GiB (1.7%)
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 500GB size: 465.76 GiB
           ID-2: /dev/nvme1n1 vendor: Kingston model: SA2000M8500G size: 465.76 GiB
           ID-3: /dev/sda vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB
Partition: ID-1: / size: 456.96 GiB used: 24.00 GiB (5.3%) fs: ext4 dev: /dev/sda2
Swap: ID-1: swap-1 type: file size: 2.00 GiB used: 0 KiB (0.0%) file: /swapfile
Sensors: System Temperatures: cpu: 0.0 C mobo: N/A gpu: amdgpu temp: 46.0 C
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info: Processes: 362 Uptime: 2m Memory: 15.54 GiB used: 2.20 GiB (14.2%) Shell: Bash inxi: 3.1.09
p-i@pi-TUF-Gaming-B550M:~$

Revision history for this message
tj (mm02b-tky) wrote :

Similar issues with Logitech wireless keyboard and mouse after updating Hirsute. Mouse freezes intermittently but is mostly usable. Keyboard is essentially unusable (this is posted via onscreen keyboard). All hardware fully functional on Hirsute with 5.8.0-25 and 5.8.0-26 before updates on 11/27 and/or 11/28. Overlapping updated packages with corradoventu appear to be linux-firmware and apport related ones.

Booting in recovery mode on both kernels keyboard is also unusable. No issues in updated Groovy or elementary OS.

Intel i9, Asus MB

Revision history for this message
corrado venturini (corradoventu) wrote :

Reinstalled from Ubuntu 21.04 "Hirsute Hippo" - Alpha amd64 (20201125) with NO download updates.
mouse works fine
held linux-firmware package: sudo apt-mark hold linux-firmware
done update+upgrade
problem reappear
... so linux-firmware is not guilty

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Since this original reporter now says the issue is fixed in 21.04, the correct status here is Fix Released.

But it would be nice to know what fixed it. I suspect it's related to:
https://gitlab.gnome.org/GNOME/mutter/-/issues/1409
https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/1858

Changed in gnome-shell (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
corrado venturini (corradoventu) wrote :

Problem is NOT fixed: I don't see the problem after install WITHOUT updates but problem reappear after updates listed in #3 and explained in #9 so please reopen the problem.
Also after today updates the problem remain:
Start-Date: 2020-11-30 08:31:38
Commandline: apt upgrade
Requested-By: corrado (1000)
Upgrade: fdisk:amd64 (2.36-3ubuntu1, 2.36.1-1ubuntu2), bsdextrautils:amd64 (2.36-3ubuntu1, 2.36.1-1ubuntu2), libnghttp2-14:amd64 (1.41.0-3, 1.42.0-1), uuid-runtime:amd64 (2.36-3ubuntu1, 2.36.1-1ubuntu2), libfdisk1:amd64 (2.36-3ubuntu1, 2.36.1-1ubuntu2), libmount1:amd64 (2.36-3ubuntu1, 2.36.1-1ubuntu2), util-linux:amd64 (2.36-3ubuntu1, 2.36.1-1ubuntu2), lz4:amd64 (1.9.2-2, 1.9.3-0ubuntu1), mount:amd64 (2.36-3ubuntu1, 2.36.1-1ubuntu2), libblkid1:amd64 (2.36-3ubuntu1, 2.36.1-1ubuntu2), libllvm11:amd64 (1:11.0.0-5, 1:11.0.0-5build1), libuuid1:amd64 (2.36-3ubuntu1, 2.36.1-1ubuntu2), ufw:amd64 (0.36-7, 0.36-7.1), liblz4-1:amd64 (1.9.2-2, 1.9.3-0ubuntu1), python3-pkg-resources:amd64 (49.3.1-2, 50.3.0-1), libsmartcols1:amd64 (2.36-3ubuntu1, 2.36.1-1ubuntu2), rfkill:amd64 (2.36-3ubuntu1, 2.36.1-1ubuntu2), eject:amd64 (2.36-3ubuntu1, 2.36.1-1ubuntu2), bsdutils:amd64 (1:2.36-3ubuntu1, 1:2.36.1-1ubuntu2), bash:amd64 (5.1~rc2-1ubuntu1, 5.1~rc3-1ubuntu1), libnss3:amd64 (2:3.55-1ubuntu3, 2:3.55-1ubuntu4), python3-secretstorage:amd64 (3.2.0-1, 3.3.0-1)
End-Date: 2020-11-30 08:31:49

Changed in gnome-shell (Ubuntu):
status: Fix Released → Confirmed
Revision history for this message
corrado venturini (corradoventu) wrote :

Also installing proposed problem remain and also with last kernel from ppa mainline

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

OK. What model of mouse are you using? And is it wired or wireless?

Revision history for this message
corrado venturini (corradoventu) wrote :

now: Bus 001 Device 002: ID 1bcf:0007 Sunplus Innovation Technology Inc. Optical Mouse
but I have the problem also with different models all wired optical, connevted to USB2 or USB3 ports.

Revision history for this message
corrado venturini (corradoventu) wrote :

now i have 2 different mouse connected and both are 'stopped'
if I click on one mouse the mouse 'unlocks' for few seconds buth the other ore remain locked.
om my laptop (see #2) I have the same problem wit mouse but the touchpad works fine.

Bus 001 Device 003: ID 046d:c016 Logitech, Inc. Optical Wheel Mouse
Bus 001 Device 002: ID 1bcf:0007 Sunplus Innovation Technology Inc. Optical Mouse

Revision history for this message
corrado venturini (corradoventu) wrote :

also with a 3rd mouse: Bus 003 Device 003: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse

Revision history for this message
AO (aofrl10n) wrote :

@vanvugt, I use a Logitech Wireless Touchpad and a K800 keyboard.

Revision history for this message
Sebastien Bacher (seb128) wrote :

the issue on the hirsute serie could be bug #1906296 , could you try of the libfprint update fixes the problem for you?

Revision history for this message
corrado venturini (corradoventu) wrote :

This is my libfprint before and also after update and problem does not disappear.
Will try on the partition where i have proposed enabled.
corrado@corrado-x2-hh-1104:~$ apt policy libfprint-2-2
libfprint-2-2:
  Installed: 1:1.90.3+tod1-0ubuntu2
  Candidate: 1:1.90.3+tod1-0ubuntu2
  Version table:
 *** 1:1.90.3+tod1-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu hirsute/main amd64 Packages
        100 /var/lib/dpkg/status
corrado@corrado-x2-hh-1104:~$

Revision history for this message
corrado venturini (corradoventu) wrote :

Same on partition with proposed enabled. problem still here.
corrado@corrado-p6-hh-1125:~$ apt policy libfprint-2-2
libfprint-2-2:
  Installed: 1:1.90.3+tod1-0ubuntu2
  Candidate: 1:1.90.3+tod1-0ubuntu2
  Version table:
 *** 1:1.90.3+tod1-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu hirsute/main amd64 Packages
        100 /var/lib/dpkg/status
corrado@corrado-p6-hh-1125:~$

Revision history for this message
Per-Inge (per-inge-hallin) wrote :

I installed all the updates in proposed (main repository) and now have
libfprint-2-2 1:1.90.3tod1-0ubuntu3 installed
This fixed the problem on my computer

Revision history for this message
corrado venturini (corradoventu) wrote :

Installed updates in proposed. New libfprint fixed the problem.
Thanks a lot

corrado@corrado-p6-hh-1125:~$ apt policy libfprint-2-2
libfprint-2-2:
  Installed: 1:1.90.3+tod1-0ubuntu3
  Candidate: 1:1.90.3+tod1-0ubuntu3
  Version table:
 *** 1:1.90.3+tod1-0ubuntu3 500
        500 http://archive.ubuntu.com/ubuntu hirsute-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     1:1.90.3+tod1-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu hirsute/main amd64 Packages
corrado@corrado-p6-hh-1125:~$

Revision history for this message
Sebastien Bacher (seb128) wrote :

closing for the shell component, thanks for confirming it's fixed with the libfprint update

Changed in gnome-shell (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
AO (aofrl10n) wrote :

Issue has been fixed after the latest updates.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.