x11 session all mouse or keyboard action ignored

Bug #1850969 reported by corrado venturini on 2019-11-01
52
This bug affects 7 people
Affects Status Importance Assigned to Milestone
GNOME Shell
Fix Released
Unknown
gnome-shell (Ubuntu)
High
Marco Trevisan (Treviño)

Bug Description

Starting with x1 session all mouse or keyboard action are ignored. Only mouse arrow moves on the desktop.
was able to exit only with cntrl+alt+f3
wayland session works fine.
Also booting from USB live and selecting 'try ubuntu' has the same problem.
selecting install the install run smoothly but the just installed system has the problem.

same problem with ISO dated 20191030 20191031 20191101 and 20191021 after update+upgrade

corrado@corrado-p13-ff-1101:~/Desktop$ inxi -Fx
System: Host: corrado-p13-ff-1101 Kernel: 5.3.0-18-generic x86_64 bits: 64 compiler: gcc v: 9.2.1 Desktop: Gnome 3.34.1
           Distro: Ubuntu 20.04 LTS (Focal Fossa)
Machine: Type: Desktop Mobo: ASRock model: H110M-G/M.2 serial: <root required> UEFI: American Megatrends v: P1.10
           date: 05/11/2017
CPU: Topology: Dual Core model: Intel Core i3-7100 bits: 64 type: MT MCP arch: Kaby Lake rev: 9 L2 cache: 3072 KiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31199
           Speed: 801 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800
Graphics: Device-1: Intel HD Graphics 630 vendor: ASRock driver: i915 v: kernel bus ID: 00:02.0
           Display: wayland server: X.Org 1.20.5 driver: i915 resolution: 1920x1080~60Hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2) v: 4.5 Mesa 19.2.1 direct render: Yes
Audio: Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASRock driver: snd_hda_intel v: kernel
           bus ID: 00:1f.3
           Sound Server: ALSA v: k5.3.0-18-generic
Network: Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e v: 3.2.6-k port: f040 bus ID: 00:1f.6
           IF: enp0s31f6 state: up speed: 100 Mbps duplex: full mac: 70:85:c2:44:7b:86
Drives: Local Storage: total: 931.51 GiB used: 4.87 GiB (0.5%)
           ID-1: /dev/sda vendor: Toshiba model: DT01ACA100 size: 931.51 GiB temp: 34 C
Partition: ID-1: / size: 15.62 GiB used: 4.87 GiB (31.2%) fs: ext4 dev: /dev/sda13
           ID-2: swap-1 size: 8.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2
Sensors: System Temperatures: cpu: 38.5 C mobo: N/A
           Fan Speeds (RPM): N/A
Info: Processes: 205 Uptime: 16m Memory: 7.49 GiB used: 1.11 GiB (14.8%) Init: systemd runlevel: 5 Compilers:
           gcc: 9.2.1 Shell: bash v: 5.0.3 inxi: 3.0.36
corrado@corrado-p13-ff-1101:~/Desktop$

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: xorg 1:7.7+19ubuntu12
ProcVersionSignature: Ubuntu 5.3.0-18.19-generic 5.3.1
Uname: Linux 5.3.0-18-generic x86_64
ApportVersion: 2.20.11-0ubuntu9
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Fri Nov 1 18:13:53 2019
DistUpgraded: Fresh install
DistroCodename: focal
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Intel Corporation HD Graphics 630 [8086:5912] (rev 04) (prog-if 00 [VGA controller])
   Subsystem: ASRock Incorporation HD Graphics 630 [1849:5912]
InstallationDate: Installed on 2019-11-01 (0 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20191101)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 046d:c016 Logitech, Inc. Optical Wheel Mouse
 Bus 001 Device 002: ID 058f:6377 Alcor Micro Corp. AU6375 4-LUN card reader
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-18-generic root=UUID=062c7ec4-2948-49df-934f-d054f397e4c4 ro quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/11/2017
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.10
dmi.board.name: H110M-G/M.2
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.10:bd05/11/2017:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnH110M-G/M.2:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.family: To Be Filled By O.E.M.
dmi.product.name: To Be Filled By O.E.M.
dmi.product.sku: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.99-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 19.2.1-1ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.5+git20191008-0ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20190815-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

same problem on a different hardware with an install from
Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20191019)
after updates

corrado@corrado-HP-p6-ff-1019:~$ inxi -Fx
System:
  Host: corrado-HP-p6-ff-1019 Kernel: 5.3.0-18-generic x86_64 bits: 64 compiler: gcc
  v: 9.2.1 Desktop: Gnome 3.34.1 Distro: Ubuntu 20.04 LTS (Focal Fossa)
Machine:
  Type: Laptop System: Hewlett-Packard product: HP 250 G3 Notebook PC
  v: 0991100000000000000600087 serial: <root required>
  Mobo: Hewlett-Packard model: 2211 v: 86.49 serial: <root required> UEFI: Insyde
  v: F.36 date: 12/18/2014
Battery:
  ID-1: BAT1 charge: 12.7 Wh condition: 18.9/18.9 Wh (100%) model: 13-42 OA03031
  status: Charging
CPU:
  Topology: Dual Core model: Intel Core i5-4210U bits: 64 type: MT MCP arch: Haswell
  rev: 1 L2 cache: 3072 KiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19156
  Speed: 798 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 799 2: 799 3: 798 4: 798
Graphics:
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Hewlett-Packard driver: i915
  v: kernel bus ID: 00:02.0
  Display: wayland server: X.Org 1.20.5 driver: i915 resolution: 1366x768~60Hz
  OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 19.2.1
  direct render: Yes
Audio:
  Device-1: Intel Haswell-ULT HD Audio vendor: Hewlett-Packard driver: snd_hda_intel
  v: kernel bus ID: 00:03.0
  Device-2: Intel 8 Series HD Audio vendor: Hewlett-Packard driver: snd_hda_intel
  v: kernel bus ID: 00:1b.0
  Sound Server: ALSA v: k5.3.0-18-generic
Network:
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard
  driver: r8169 v: kernel port: 3000 bus ID: 08:00.0
  IF: enp8s0 state: up speed: 100 Mbps duplex: full mac: 5c:b9:01:06:ba:ce
  Device-2: Ralink RT3290 Wireless 802.11n 1T/1R PCIe vendor: Hewlett-Packard
  driver: rt2800pci v: 2.3.0 port: 3000 bus ID: 09:00.0
  IF: wlp9s0f0 state: down mac: ac:d1:b8:82:03:5d
Drives:
  Local Storage: total: 465.76 GiB used: 6.31 GiB (1.4%)
  ID-1: /dev/sda vendor: Seagate model: ST500LT012-1DG142 size: 465.76 GiB
Partition:
  ID-1: / size: 31.25 GiB used: 6.30 GiB (20.1%) fs: ext4 dev: /dev/sda6
  ID-2: swap-1 size: 4.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2
Sensors:
  System Temperatures: cpu: 47.0 C mobo: 47.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 207 Uptime: 4m Memory: 3.78 GiB used: 1.18 GiB (31.3%) Init: systemd
  runlevel: 5 Compilers: gcc: 9.2.1 Shell: bash v: 5.0.3 inxi: 3.0.36
corrado@corrado-HP-p6-ff-1019:~$

summary: - x1 session all mouse or keyboard action ignored
+ x11 session all mouse or keyboard action ignored
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :
affects: xorg (Ubuntu) → gnome-shell (Ubuntu)
Changed in gnome-shell (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → High
status: Confirmed → In Progress
Changed in gnome-shell:
status: Unknown → New

The same problem with live session from a recent ISO: https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1851058

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1850969

tags: added: iso-testing
Changed in gnome-shell:
status: New → Fix Released

Problem disappeared after last upgrade:
Start-Date: 2019-11-07 17:28:08
Commandline: apt upgrade
Requested-By: corrado (1000)
Upgrade: gir1.2-mutter-5:amd64 (3.34.1+git20191022-2ubuntu1, 3.34.1+git20191107-1ubuntu1), libmutter-5-0:amd64 (3.34.1+git20191022-2ubuntu1, 3.34.1+git20191107-1ubuntu1), mutter-common:amd64 (3.34.1+git20191022-2ubuntu1, 3.34.1+git20191107-1ubuntu1), mutter:amd64 (3.34.1+git20191022-2ubuntu1, 3.34.1+git20191107-1ubuntu1)
End-Date: 2019-11-07 17:28:15

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.