gnome-shell freezes with 100% CPU when closing popup window

Bug #1834984 reported by Rocko on 2019-07-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Undecided
Unassigned

Bug Description

Whenever I run Netbeans 11 (using either openjdk11) and (eg):

1. Open Tools / Plugins.
2. Go to Settings.
3. Click on 'Add'.
4. Click 'Cancel'.

then gnome-shell freezes (except for the mouse), apparently indefinitely (I have left it for 30+ minutes.)

I can login as another user via CTRL-ALT-F1 and kill the frozen session using loginctl. Sometimes this kills gnome-shell completely and I have to power cycle; other times I can switch back to the login with CTRL-ALT-F1 and continue.

This also usually happens when I close any other popup windows in Netbeans.

I have tried making the popup windows modal and non-modal, but it makes no difference.

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: gnome-shell 3.32.2-2ubuntu1
Uname: Linux 5.2.0-050200rc7-generic x86_64
ApportVersion: 2.20.11-0ubuntu3
Architecture: amd64
Date: Tue Jul 2 11:34:29 2019
DisplayManager: gdm3
GsettingsChanges:

InstallationDate: Installed on 2019-07-01 (0 days ago)
InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Alpha amd64 (20190606)
ProcEnviron:
 LANGUAGE=en_AU:en
 TERM=xterm-256color
 PATH=(custom, no user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
RelatedPackageVersions: mutter-common 3.32.2+git20190626-1ubuntu1
SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

Rocko (rockorequin) wrote :
Daniel van Vugt (vanvugt) wrote :

Thanks for the bug report. I am fairly confident this will be a duplicate of bug 1834583, but just to verify please run:

  apport-cli --hanging -u 1834984 -P PID

where PID is the process ID of the busy gnome-shell.

Changed in gnome-shell (Ubuntu):
status: New → Incomplete
Rocko (rockorequin) wrote :

That command gives me "apport-cli: error: -u/--update-bug option cannot be used together with options for a new report".

Should I omit the -u option and create a new bug?

Daniel van Vugt (vanvugt) wrote :

Yes please...

  apport-cli --hanging -P PID

Rocko (rockorequin) wrote :

Hmm. I did that, and eventually it asked if I wanted to send a report, so I said yes ('S' for send), and then nothing happened except it created a zero-length file /var/crash/_usr_bin_gnome-shell.0.7619.hanging. A bit later I got a window saying that a report was ready to send, so I told it to continue, but it has vanished. Is it likely that apport crashed silently?

Daniel van Vugt (vanvugt) wrote :

It is possible that apport crashes.

Maybe next time force a core dump with:

  kill -ABRT PID

so you don't lose it. Then you can use apport-cli etc to create a new bug like:

  apport-cli /var/crash/...

Rocko (rockorequin) wrote :

I did that and it is reported as bug #1835033.

When I killed the frozen gnome-shell process, it had recovered by the time I switched back to it and I was then able to close the offending window.

Rocko (rockorequin) wrote :

Also in case it's of any help, I only have Ubuntu's default gnome-shell extensions running.

Daniel van Vugt (vanvugt) wrote :

Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers