gnome-shell crashes in meta_monitor_mode_get_resolution -> calculate_scale -> meta_monitor_calculate_mode_scale derive_calculated_global_scale -> meta_monitor_manager_rebuild_logical_monitors_derived

Bug #1826933 reported by errors.ubuntu.com bug bridge on 2019-04-29
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Status tracked in Eoan
Disco
Medium
Marco Trevisan (Treviño)
Eoan
Medium
Marco Trevisan (Treviño)
mutter (Ubuntu)
Status tracked in Eoan
Disco
Medium
Marco Trevisan (Treviño)
Eoan
Medium
Marco Trevisan (Treviño)

Bug Description

[ Impact ]

Gnome shell crashes in meta_monitor_mode_get_resolution

This seems to happen when starting gnome-shell with no display on (headless).

[ Test case ]

- Start gnome-shell in a desktop (i.e. one with no embedded display) setup
  with all the monitors off
- Gnome shell should start properly, without crashing

- Anyway monitor results in
  https://errors.ubuntu.com/problem/f66514c0f5ecdc8dceb19c76baf20adf29746f12
  to check if errors goes down

[ Regression potential ]

Scale isn't properly computed for monitors with higher DPI

---

The Ubuntu Error Tracker has been receiving reports about a problem regarding gnome-shell. This problem was most recently seen with package version 3.32.0+git20190410-1ubuntu1, the problem page at https://errors.ubuntu.com/problem/f66514c0f5ecdc8dceb19c76baf20adf29746f12 contains more details, including versions of packages affected, stacktrace or traceback, and individual crash reports.
If you do not have access to the Ubuntu Error Tracker and are a software developer, you can request it at http://forms.canonical.com/reports/.

Related branches

tags: added: rls-dd-incoming rls-ee-incoming
Changed in gnome-shell (Ubuntu):
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → Medium
summary: - /usr/bin/gnome-
- shell:11:meta_monitor_mode_get_resolution:calculate_scale:meta_monitor_calculate_mode_scale:derive_calculated_global_scale:meta_monitor_manager_rebuild_logical_monitors_derived
+ gnome-shell crashes in meta_monitor_mode_get_resolution ->
+ calculate_scale -> meta_monitor_calculate_mode_scale
+ derive_calculated_global_scale ->
+ meta_monitor_manager_rebuild_logical_monitors_derived
Will Cooke (willcooke) on 2019-04-30
tags: removed: rls-dd-incoming rls-ee-incoming
Iain Lane (laney) wrote :

this bug needs SRUifying too please

Changed in gnome-shell (Ubuntu Disco):
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)

Hello errors.ubuntu.com, or anyone else affected,

Accepted mutter into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mutter/3.32.1-2ubuntu1~19.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-disco
Changed in mutter (Ubuntu Disco):
status: New → In Progress
Changed in mutter (Ubuntu Eoan):
status: New → In Progress
Łukasz Zemczak (sil2100) wrote :

That's ok. For error-tracker crash fixes we're not always super strict on SRU templates, so I'm accepting it early. Would be of course nice if there is a easily reproducible test case that could be included in the description. But if not, the usual 'check for error tracker' might be enough for verification here.

This bug was fixed in the package mutter - 3.32.1-2ubuntu1

---------------
mutter (3.32.1-2ubuntu1) eoan; urgency=medium

  * Merge with debian
    - Update to 3.32.1 upstream version (LP: #1826936)
    - Fix applications aren't focused in Wayland session (LP: #1826176)
    - Fix crash on hotplugging a dock with a monitor (LP: #1826182)
    Remaining changes:
    + debian/control:
      - Update VCS flags to point to launchpad
      - Update maintainer to ubuntu
    + debian/gbp.conf: update branch to point to ubuntu/master
    + debian/patches/x11-Add-support-for-fractional-scaling-using-Randr.patch:
      - X11: Add support for fractional scaling using Randr
  * d/p/x11-Add-support-for-fractional-scaling-using-Randr.patch:
    - Fixed crash on calculation of global scale (LP: #1826933)

mutter (3.32.1-2) experimental; urgency=medium

  * Cherry-pick patches from upstream gnome-3-32 branch:
    - compositor-Destroy-window-actors-list-on-destruction.patch,
      compositor-Disconnect-from-stage-signals-on-destruction.patch: Fix crash
      when exiting. (LP: #1813716)
    - 0-initialize a struct we'll be memcmp()ing.
  * Reorder patch series so upstream patches come first (no conflicts, no
    refreshing required).

mutter (3.32.1-1) experimental; urgency=medium

  * New upstream release
  * debian/patches: disable mousekeys with Numlock ON to match the
    documentation (cherry picked from the 3.32 branch)

mutter (3.32.0+git20190410-2) experimental; urgency=medium

  [ Gunnar Hjalmarsson ]
  * Add gnome-control-center-data to Build-Depends. This package provides
    gnome-keybindings.{its,loc}. These are needed if the translation template
    is regenerated at build-time to translate the key bindings defined in
    data/50-*.xml. (LP: #1823722)

 -- Marco Trevisan (Treviño) <email address hidden> Wed, 01 May 2019 11:08:08 +0100

Changed in gnome-shell (Ubuntu Eoan):
status: In Progress → Fix Released
Changed in mutter (Ubuntu Eoan):
status: In Progress → Fix Released
Changed in gnome-shell (Ubuntu Disco):
status: In Progress → Fix Committed
Changed in mutter (Ubuntu Disco):
status: In Progress → Fix Committed
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in mutter (Ubuntu Eoan):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in gnome-shell (Ubuntu Disco):
importance: Undecided → Medium
Changed in mutter (Ubuntu Disco):
importance: Undecided → Medium
Changed in mutter (Ubuntu Eoan):
importance: Undecided → Medium
description: updated

I was pretty sure to have marked this as a duplicate of another bug and SRU'ed that description, but I can't find it anymore :o

Anyways, i've updated the description accordingly.

No crash has been recorded by e.u.c in versions mayor than 3.32.1-2ubuntu1, so marking as verified.

tags: added: verification-done verification-done-disco
removed: verification-needed verification-needed-disco
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.32.1-2ubuntu1~19.04.1

---------------
mutter (3.32.1-2ubuntu1~19.04.1) disco; urgency=medium

  * Backport from eoan to disco
  * Update VCS metadata

mutter (3.32.1-2ubuntu1) eoan; urgency=medium

  * Merge with debian
    - Update to 3.32.1 upstream version (LP: #1826936)
    - Fix applications aren't focused in Wayland session (LP: #1826176)
    - Fix crash on hotplugging a dock with a monitor (LP: #1826182)
    Remaining changes:
    + debian/control:
      - Update VCS flags to point to launchpad
      - Update maintainer to ubuntu
    + debian/gbp.conf: update branch to point to ubuntu/master
    + debian/patches/x11-Add-support-for-fractional-scaling-using-Randr.patch:
      - X11: Add support for fractional scaling using Randr
  * d/p/x11-Add-support-for-fractional-scaling-using-Randr.patch:
    - Fixed crash on calculation of global scale (LP: #1826933)

mutter (3.32.1-2) experimental; urgency=medium

  * Cherry-pick patches from upstream gnome-3-32 branch:
    - compositor-Destroy-window-actors-list-on-destruction.patch,
      compositor-Disconnect-from-stage-signals-on-destruction.patch: Fix crash
      when exiting. (LP: #1813716)
    - 0-initialize a struct we'll be memcmp()ing.
  * Reorder patch series so upstream patches come first (no conflicts, no
    refreshing required).

mutter (3.32.1-1) experimental; urgency=medium

  * New upstream release
  * debian/patches: disable mousekeys with Numlock ON to match the
    documentation (cherry picked from the 3.32 branch)

mutter (3.32.0+git20190410-2) experimental; urgency=medium

  [ Gunnar Hjalmarsson ]
  * Add gnome-control-center-data to Build-Depends. This package provides
    gnome-keybindings.{its,loc}. These are needed if the translation template
    is regenerated at build-time to translate the key bindings defined in
    data/50-*.xml. (LP: #1823722)

 -- Iain Lane <email address hidden> Wed, 01 May 2019 11:32:50 +0100

Changed in mutter (Ubuntu Disco):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for mutter has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers