gnome-shell crashed with SIGSEGV in meta_x11_display_get_xdisplay → detach_pixmap → meta_surface_actor_x11_dispose → g_object_unref → ObjectInstance → → release_native_object

Bug #1813716 reported by errors.ubuntu.com bug bridge on 2019-01-29
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mutter
Fix Released
Unknown
gnome-shell (Ubuntu)
Status tracked in Eoan
Disco
Medium
Marco Trevisan (Treviño)
Eoan
Medium
Marco Trevisan (Treviño)
mutter (Ubuntu)
Status tracked in Eoan
Disco
Medium
Marco Trevisan (Treviño)
Eoan
Medium
Marco Trevisan (Treviño)

Bug Description

[ Impact ]

GNOME Shell crashes on restart or when ending the session

[ Test Case ]

Under X11, try to reload the shell multiple times using
 - Alt+F2: write 'r', press 'enter'.
 - Or quit it writing in the run dialog 'debugexit'.

Repeat multiple times, no crash caused by x11 calls should happen.

[ Regression potential ]

Nothing known, window actors might not be painted on reload.

---

Tracked upstream in https://gitlab.gnome.org/GNOME/mutter/issues/576

Proposed fix: https://gitlab.gnome.org/GNOME/mutter/merge_requests/557

The Ubuntu Error Tracker has been receiving reports about a problem regarding gnome-shell. This problem was most recently seen with package version 3.30.2-2ubuntu1, the problem page at https://errors.ubuntu.com/problem/a27089759201dfe884a9070c2d62c50680fb2de4 contains more details, including versions of packages affected, stacktrace or traceback, and individual crash reports.
If you do not have access to the Ubuntu Error Tracker and are a software developer, you can request it at http://forms.canonical.com/reports/.

Related branches

summary: - /usr/bin/gnome-
- shell:11:meta_x11_display_get_xdisplay:detach_pixmap:meta_surface_actor_x11_dispose:g_object_unref:ObjectInstance::release_native_object
+ meta_x11_display_get_xdisplay → detach_pixmap →
+ meta_surface_actor_x11_dispose → g_object_unref → ObjectInstance → →
+ release_native_object
summary: - meta_x11_display_get_xdisplay → detach_pixmap →
- meta_surface_actor_x11_dispose → g_object_unref → ObjectInstance → →
- release_native_object
+ gnome-shell crashed with SIGSEGV in meta_x11_display_get_xdisplay →
+ detach_pixmap → meta_surface_actor_x11_dispose → g_object_unref →
+ ObjectInstance → → release_native_object
Changed in gnome-shell (Ubuntu):
importance: Undecided → High
status: New → Confirmed
tags: added: rls-ee-incoming
tags: added: rls-dd-incoming
description: updated
Changed in gnome-shell (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Confirmed → In Progress
Changed in mutter (Ubuntu):
status: New → Triaged
status: Triaged → In Progress
importance: Undecided → Medium
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in mutter:
status: Unknown → New
Will Cooke (willcooke) on 2019-04-30
tags: removed: rls-dd-incoming rls-ee-incoming
Changed in gnome-shell (Ubuntu Disco):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in mutter (Ubuntu Disco):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in mutter:
status: New → Fix Released
Changed in gnome-shell (Ubuntu Disco):
status: New → In Progress
Changed in mutter (Ubuntu Disco):
status: New → In Progress
description: updated
Changed in mutter (Ubuntu Disco):
importance: Undecided → High
Changed in gnome-shell (Ubuntu Disco):
importance: Undecided → High
importance: High → Medium
Changed in gnome-shell (Ubuntu Eoan):
importance: High → Medium
Changed in mutter (Ubuntu Disco):
importance: High → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.32.1-2ubuntu1

---------------
mutter (3.32.1-2ubuntu1) eoan; urgency=medium

  * Merge with debian
    - Update to 3.32.1 upstream version (LP: #1826936)
    - Fix applications aren't focused in Wayland session (LP: #1826176)
    - Fix crash on hotplugging a dock with a monitor (LP: #1826182)
    Remaining changes:
    + debian/control:
      - Update VCS flags to point to launchpad
      - Update maintainer to ubuntu
    + debian/gbp.conf: update branch to point to ubuntu/master
    + debian/patches/x11-Add-support-for-fractional-scaling-using-Randr.patch:
      - X11: Add support for fractional scaling using Randr
  * d/p/x11-Add-support-for-fractional-scaling-using-Randr.patch:
    - Fixed crash on calculation of global scale (LP: #1826933)

mutter (3.32.1-2) experimental; urgency=medium

  * Cherry-pick patches from upstream gnome-3-32 branch:
    - compositor-Destroy-window-actors-list-on-destruction.patch,
      compositor-Disconnect-from-stage-signals-on-destruction.patch: Fix crash
      when exiting. (LP: #1813716)
    - 0-initialize a struct we'll be memcmp()ing.
  * Reorder patch series so upstream patches come first (no conflicts, no
    refreshing required).

mutter (3.32.1-1) experimental; urgency=medium

  * New upstream release
  * debian/patches: disable mousekeys with Numlock ON to match the
    documentation (cherry picked from the 3.32 branch)

mutter (3.32.0+git20190410-2) experimental; urgency=medium

  [ Gunnar Hjalmarsson ]
  * Add gnome-control-center-data to Build-Depends. This package provides
    gnome-keybindings.{its,loc}. These are needed if the translation template
    is regenerated at build-time to translate the key bindings defined in
    data/50-*.xml. (LP: #1823722)

 -- Marco Trevisan (Treviño) <email address hidden> Wed, 01 May 2019 11:08:08 +0100

Changed in mutter (Ubuntu Eoan):
status: In Progress → Fix Released

Hello errors.ubuntu.com, or anyone else affected,

Accepted mutter into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mutter/3.32.1-2ubuntu1~19.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in mutter (Ubuntu Disco):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-disco
Changed in gnome-shell (Ubuntu Eoan):
status: In Progress → Fix Released
Changed in gnome-shell (Ubuntu Disco):
status: In Progress → Fix Committed

No crash has been recorded for 3.32.1-2ubuntu1 and SRU'ed version for this, so marking as verified

tags: added: verification-done verification-done-disco
removed: verification-needed verification-needed-disco
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.32.1-2ubuntu1~19.04.1

---------------
mutter (3.32.1-2ubuntu1~19.04.1) disco; urgency=medium

  * Backport from eoan to disco
  * Update VCS metadata

mutter (3.32.1-2ubuntu1) eoan; urgency=medium

  * Merge with debian
    - Update to 3.32.1 upstream version (LP: #1826936)
    - Fix applications aren't focused in Wayland session (LP: #1826176)
    - Fix crash on hotplugging a dock with a monitor (LP: #1826182)
    Remaining changes:
    + debian/control:
      - Update VCS flags to point to launchpad
      - Update maintainer to ubuntu
    + debian/gbp.conf: update branch to point to ubuntu/master
    + debian/patches/x11-Add-support-for-fractional-scaling-using-Randr.patch:
      - X11: Add support for fractional scaling using Randr
  * d/p/x11-Add-support-for-fractional-scaling-using-Randr.patch:
    - Fixed crash on calculation of global scale (LP: #1826933)

mutter (3.32.1-2) experimental; urgency=medium

  * Cherry-pick patches from upstream gnome-3-32 branch:
    - compositor-Destroy-window-actors-list-on-destruction.patch,
      compositor-Disconnect-from-stage-signals-on-destruction.patch: Fix crash
      when exiting. (LP: #1813716)
    - 0-initialize a struct we'll be memcmp()ing.
  * Reorder patch series so upstream patches come first (no conflicts, no
    refreshing required).

mutter (3.32.1-1) experimental; urgency=medium

  * New upstream release
  * debian/patches: disable mousekeys with Numlock ON to match the
    documentation (cherry picked from the 3.32 branch)

mutter (3.32.0+git20190410-2) experimental; urgency=medium

  [ Gunnar Hjalmarsson ]
  * Add gnome-control-center-data to Build-Depends. This package provides
    gnome-keybindings.{its,loc}. These are needed if the translation template
    is regenerated at build-time to translate the key bindings defined in
    data/50-*.xml. (LP: #1823722)

 -- Iain Lane <email address hidden> Wed, 01 May 2019 11:32:50 +0100

Changed in mutter (Ubuntu Disco):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for mutter has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Daniel van Vugt (vanvugt) wrote :

Weird I can still reproduce this crash using mutter master from git (https://gitlab.gnome.org/GNOME/mutter/issues/629), but there is no evidence of Ubuntu crashing since the above fix.

Daniel van Vugt (vanvugt) wrote :

Ooh...

It seems the explanation is that the above versions were short lived. The subsequent version 3.32.2-1ubuntu1 is experiencing the crash still in eoan:

https://errors.ubuntu.com/problem/1a5d1f99fd9215f7a79b718d2e915c675ebcd69f

Daniel van Vugt (vanvugt) wrote :

OK. I will not reopen this bug.

Instead I have separated bug 1826918. Please look there.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.