[bionic][regression] gnome-shell crashes with SIGSEGV in meta_window_actor_is_destroyed(self=NULL) called from _switchWorkspaceDone() [windowManager.js:1787]

Bug #1812527 reported by Jean-Francois Turcot on 2019-01-20
198
This bug affects 31 people
Affects Status Importance Assigned to Milestone
GNOME Shell
Fix Released
Unknown
gnome-shell (Ubuntu)
Status tracked in Eoan
Bionic
High
Marco Trevisan (Treviño)
Cosmic
Undecided
Unassigned
Eoan
Undecided
Unassigned

Bug Description

https://errors.ubuntu.com/problem/cb400a6f83ed57af8bb117cf84d5ed6d7e2ffcee
https://gitlab.gnome.org/GNOME/gnome-shell/issues/927

[ Impact ]

Switching workspace with the Android Emulator running will blink the screen as if gnome restarted, if I switch workspace one more time, it will completely crash and I will need to log in again.

[ Test case ]

Open Android Emulator and switch workspace
or
Open Skype, start a test call and switch workspace

GNOME-Shell should not crash

[ Regression potential ]

Very low, we remove windows from Javascript array when they're destroyed.
A possible regression could be not switching to workspace when selecting a window that is in another one.

ProblemType: BugDistroRelease: Ubuntu 18.04
Package: gnome-shell 3.28.3-0ubuntu0.18.04.4
Uname: Linux 4.20.3-acso x86_64
ApportVersion: 2.20.9-0ubuntu7.5
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Sat Jan 19 20:05:34 2019
DisplayManager: gdm3
GsettingsChanges:
 b'org.gnome.shell' b'favorite-apps' redacted by apport
 b'org.gnome.desktop.interface' b'gtk-im-module' b"'gtk-im-context-simple'"
InstallationDate: Installed on 2019-01-15 (4 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jean-Francois Turcot (jfturcot) wrote :
Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It sounds like some part of the system has crashed. To help us find the cause of the crash please follow these steps:

1. Look in /var/crash for crash files and if found run:
    ubuntu-bug YOURFILE.crash
Then tell us the ID of the newly-created bug.

2. If step 1 failed then look at https://errors.ubuntu.com/user/ID where ID is the content of file /var/lib/whoopsie/whoopsie-id on the machine. Do you find any links to recent problems on that page? If so then please send the links to us.

3. If step 2 also failed then apply the workaround from bug 994921, reboot, reproduce the crash, and retry step 1.

Please take care to avoid attaching .crash files to bugs as we are unable to process them as file attachments. It would also be a security risk for yourself.

Changed in gnome-shell (Ubuntu):
status: New → Incomplete
FixMaker (fixmaker) wrote :

I am also seeing this problem, which seemed to manifest itself after a recent update. By experimenting, I've determined that there seems to be a segfault in libmutter-2.so.0.0.0 each time the workspace changes (when the Android emulator is running).

Please see the attached excerpt from my syslog. I see this each time I try to switch to a different workspace, if the *current* workspace contains an open emulator window. The problem doesn't seem to happen if the emulator window is minimized.

Please let me know if you need any more info.

Khalil Laleh (khalilst) wrote :

Same issue here [https://answers.launchpad.net/ubuntu/+question/677918]. Please see my answer, hope it helps.

Daniel van Vugt (vanvugt) wrote :

Everyone please follow the steps in comment #2.

Daniel van Vugt (vanvugt) wrote :

Bug 1812780 suggests the regression started with gjs 1.52.5-0ubuntu18.04.1

Generalized the bug title to cover the common aspects between this and bug 1812780.

summary: - gnome-shell crashes when switching from workspace that is running
- Android emulator (QEMU)
+ gnome-shell crashes at windowManager.js:1787 when switching from
+ workspace that is running Android emulator (QEMU)
summary: - gnome-shell crashes at windowManager.js:1787 when switching from
- workspace that is running Android emulator (QEMU)
+ gnome-shell crashes with SIGSEGV at windowManager.js:1787 when running
+ Android emulator (QEMU)
Changed in gnome-shell (Ubuntu):
importance: Undecided → High
tags: added: regression-update
Daniel van Vugt (vanvugt) wrote :

The offending line of JavaScript is the one that says "Window gone". I guess maybe a NULL pointer?

    _switchWorkspaceDone(shellwm) {
        let switchData = this._switchData;
        if (!switchData)
            return;
        this._switchData = null;

        for (let i = 0; i < switchData.windows.length; i++) {
                let w = switchData.windows[i];
                if (w.window.is_destroyed()) // Window gone
                    continue;
                if (w.window.get_parent() == switchData.outGroup) {
                    w.window.reparent(w.parent);
                    w.window.hide();
                } else
                    w.window.reparent(w.parent);
        }

summary: - gnome-shell crashes with SIGSEGV at windowManager.js:1787 when running
- Android emulator (QEMU)
+ gnome-shell crashes with SIGSEGV in meta_window_actor_is_destroyed()
+ called from windowManager.js:1787 when running Android emulator (QEMU)
Changed in gnome-shell (Ubuntu):
status: Incomplete → Confirmed
summary: - gnome-shell crashes with SIGSEGV in meta_window_actor_is_destroyed()
- called from windowManager.js:1787 when running Android emulator (QEMU)
+ gnome-shell crashes with SIGSEGV in
+ meta_window_actor_is_destroyed(self=NULL) called from
+ windowManager.js:1787 when running Android emulator (QEMU)
Daniel van Vugt (vanvugt) wrote :

I can't find any relevant change to mutter or gnome-shell. If the bug is caused by a change in gjs then I guess the problem would be that gjs previously would not try calling functions on NULL objects, and now it does...?

Changed in gjs (Ubuntu):
status: New → Triaged
importance: Undecided → High
summary: gnome-shell crashes with SIGSEGV in
meta_window_actor_is_destroyed(self=NULL) called from
- windowManager.js:1787 when running Android emulator (QEMU)
+ _switchWorkspaceDone() [windowManager.js:1787] when running Android
+ emulator (QEMU)
description: updated
ekimai (home-ekimai) wrote :

I can confirm the problem here too. I'm currently completely unable to use the emulator, and developing on hardware devices for testing.

Crashing here as well, and I don't have the Android emulator running. It's happening seemingly randomly when switching between workspaces.

I tried to follow the steps from #2, but steps 1 and 2 didn't work, and I'm not clear what workaround from bug 994921 is meant exactly.

syslog also shows a crash in libmutter-2.so.0.0.0.

Jeremy LaCroix (j-jlacroix) wrote :

I'm seeing this same problem, and on my end I am not using the Android emulator. The only apps I use on a regular basis that are always open are the following:

firefox
gnome-terminal
thunderbird

Pavel Hykš (pavel-o) wrote :

I can confirm the same bug on 18.04 and Android Studio + running AVD. Disabling system animation by Tweaks / Appearance / Animations works!! It does not crash anymore...

ekimai (home-ekimai) wrote :

@Pavel - That's awesome!
Thanks for the workaround.

Michael Grivas (mgrivas) wrote :

I had the same, without using any Android emulation. When changing workspace, the gnome-shell was actually freezing and then restarting. Sometimes it could kill the session.

Disabling the animation did the trick ! No issue anymore (although no fancy scrolling) .

Jeremy LaCroix (j-jlacroix) wrote :

Disabling animations seemed to resolve it for me too. But now switching workspaces just feels very odd without it.

Since this is a regression (the bug was definitely not present at the time of initial release) I really hope this gets fixed. I have two systems with this problem.

summary: gnome-shell crashes with SIGSEGV in
meta_window_actor_is_destroyed(self=NULL) called from
- _switchWorkspaceDone() [windowManager.js:1787] when running Android
- emulator (QEMU)
+ _switchWorkspaceDone() [windowManager.js:1787], often when running
+ Android emulator (QEMU)

@Pavel++
This also helps me out too. Thanks!

My issue is reproducible as per the bug report
4
.18.0-15-generic #16~18.04.1-Ubuntu SMP Thu Feb 7 14:06:04 UTC 2019 x86_64

ekimai (home-ekimai) wrote :

Just an update - I do still get the occasional crash without animations, but it's much less likely.

Jeremy LaCroix (j-jlacroix) wrote :

I think we need to completely remove Android Emulation from the title and description. I never use that, nor have I ever, and I see this crash constantly. It's EXTREMELY frustrating.

What do you guys need from us in order to help us track this issue? I want to do what I can to help get this fixed.

Done. I think this bug should now be discussed upstream where a fix would occur and there are people who know the code:

https://gitlab.gnome.org/GNOME/gnome-shell/issues/927

summary: gnome-shell crashes with SIGSEGV in
meta_window_actor_is_destroyed(self=NULL) called from
- _switchWorkspaceDone() [windowManager.js:1787], often when running
- Android emulator (QEMU)
+ _switchWorkspaceDone() [windowManager.js:1787]
summary: - gnome-shell crashes with SIGSEGV in
+ [bionic][regression] gnome-shell crashes with SIGSEGV in
meta_window_actor_is_destroyed(self=NULL) called from
_switchWorkspaceDone() [windowManager.js:1787]
tags: added: rls-bb-incoming
Michael Grivas (mgrivas) wrote :

Indeed this is not related to Android and it should be better upstream. Thanks Daniel.

Although removing the Animation alleviates a lot the problem, it does not solve it.
Furthermore, it is not only Ubuntu problem. It appears to my Fedora, pretty similar to what I see in Ubuntu. And it appears (in both) very few times after disabling the animation.

Michael Grivas (mgrivas) wrote :

By the way, in my case, the track does not show "self=NULL". It's just empty:
gnome-shell crashes with SIGSEGV in meta_window_actor_is_destroyed()

Issue was solved for me by disabling animation between workspaces https://extensions.gnome.org/extension/1328/disable-workspace-switch-animation/

Can anyone affected post a the result of

 journalctl /usr/bin/gnome-shell -b

Or otherwise follow what explaind here to have a full javascript dump too.

https://wiki.gnome.org/Community/GettingInTouch/Bugzilla/GettingTraces/Details#Obtaining_a_stack_and_JS_trace_using_GDB_for_an_already_running_gnome-shell

Jeremy LaCroix (j-jlacroix) wrote :

Attached.

Michael Grivas (mgrivas) wrote :

Anonymized, gzipped and attached.

Will Cooke (willcooke) on 2019-03-05
Changed in gnome-shell (Ubuntu Bionic):
assignee: nobody → Daniel van Vugt (vanvugt)
tags: added: rls-bb-tracking
removed: rls-bb-incoming
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gjs (Ubuntu Bionic):
status: New → Confirmed
Changed in gnome-shell (Ubuntu Bionic):
status: New → Confirmed
Changed in gjs (Ubuntu Bionic):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in gjs (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Daniel van Vugt (vanvugt) wrote :

Curious how this crash only exists on 18.04 (Gnome 3.28). Not on later releases.

Daniel van Vugt (vanvugt) wrote :

Although there was 1 (out of 7139) instance of the crash reported in version 3.30.1-2ubuntu1.18.10.2. I guess that suggests it was fixed around Gnome 3.30.1-ish.

Daniel van Vugt (vanvugt) wrote :

Which "Android Emulator" are people using to see this bug?

Is there an Ubuntu package which provides it, or are you manually installing the Android SDK from Google?

Changed in gnome-shell (Ubuntu Bionic):
importance: Undecided → High
Jeremy LaCroix (j-jlacroix) wrote :

@Daniel, this bug has absolutely nothing to do with using an Android Emulator. I literally get this crash every five minutes, and I've never used emulation or virtualization of any kind on either of my machines. I think the Android Emulator was just a red herring.

Horváth Csongor (csongi77) wrote :

@Daniel,
Android Emulator version:
28.1.9-5346014
It was packaged with IntelliJ IDEA (Android Studio)

gnome-shell:
  Installed: 3.28.3-0ubuntu0.18.04.4

  Version table:
 *** 3.28.3-0ubuntu0.18.04.4 500
        500 http://hu.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     3.28.1-0ubuntu2 500
        500 http://hu.archive.ubuntu.com/ubuntu bionic/main amd64 Packages

Daniel van Vugt (vanvugt) wrote :

Jeremy,

Yes I am aware that Android Emulator is not required to encounter this crash. But I need something that will encounter it reliably, for testing.

Daniel van Vugt (vanvugt) wrote :

I use 18.04 all day every day with multiple workspaces and do not encounter this crash. However if I am to fix it then I need to know how to reproduce it.

Jeremy LaCroix (j-jlacroix) wrote :

@Daniel, I understand that you want to reproduce it. However, if you aren't experiencing this bug, then that tells me you don't have a hardware configuration that is affected by it. If you're affected, reproducing it is very easy - simply use the keyboard shortcut designated for switching up or down to another workspace. Every time I do this, I have a one in five chance of GNOME crashing. It's so common that I have no chance of NOT reproducing it.

As for apps, if it matters, I only have Firefox, Thunderbird, and gnome-terminal open at any one time.

ekimai (home-ekimai) wrote :

I'm using a Dell Precision 7530, with Quadro P1000 running NVidia drivers Version 396.54.

Hope this helps @Daniel.

I have a Dell Precision 3510 with Radeon HD 8830M/R7 M465X and Intel HD Graphics 530 (radeon and i915 drivers) running Ubuntu 18.04.2.

Installed and active gnome extensions:
- Auto Move Windows
- Google Earth Wallpaper
- Hide veth interface
- NoAnnoyance
- Shortcuts
- Suspend Button
- system-monitor

Daniel van Vugt (vanvugt) wrote :

Thanks for the reminder...

1. Everyone please try uninstalling all your extensions (except the default Ubuntu ones), reboot, and then tell us if the crash still occurs.

2. More answers to comment #33 would also be appreciated.

Changed in gjs (Ubuntu):
status: Triaged → Incomplete
Changed in gjs (Ubuntu Bionic):
status: Confirmed → Incomplete
Changed in gnome-shell (Ubuntu):
status: Triaged → Incomplete
Changed in gnome-shell (Ubuntu Bionic):
status: Confirmed → Incomplete
Changed in gnome-shell (Ubuntu):
status: Incomplete → Confirmed
Changed in gnome-shell (Ubuntu Bionic):
status: Incomplete → Confirmed
Changed in gjs (Ubuntu):
status: Incomplete → New
Changed in gjs (Ubuntu Bionic):
status: Incomplete → New
Changed in gjs (Ubuntu):
status: New → Confirmed
Changed in gjs (Ubuntu Bionic):
status: New → Confirmed
importance: Undecided → High
Changed in gnome-shell (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
Fagner Araujo (ifgr) wrote :

I faced this problem first when I was using skype and zoom. Both in shared screen mode.
Using Android Emulator, my Ubuntu are crashing too.

Just only when I change the Workspace.

Rocky (brightstone8x) on 2019-03-11
information type: Public → Public Security
information type: Public Security → Private Security
Alex Murray (alexmurray) on 2019-03-12
information type: Private Security → Public
ekimai (home-ekimai) wrote :

I can confirm that the crash is 100% reproducible with no Gnome extensions installed.

ekimai (home-ekimai) wrote :

Also, my Android Emulator version info:

Android emulator version 28.0.23.0 (build_id 5264690) (CL:be2be19ca0131957449e8c0ded5e55070f9537b0)

Rodrigo García (rodrirokr) wrote :

I'm also having the same problem with the same configuration: Ubuntu 18.04.2 and GNOME 3.28, but the solution of Fabrizio Bertoglio (fabriziobertoglio) #28 aliviated the problem.

ekimai (home-ekimai) wrote :

I have a theory, and it isust a theory...

The hotkey to change desktops is Ctrl+Alt+UP/DOWN
The hotkey on the Android emulator to pinch zoom is Ctrl+Alt with mouse drag.

When the emulator is the active window, and you press Ctrl+Alt, then a graphic appears on the emulator showing the pinch zoom function. This graphic is often left on the display as an artefact overlayed on the new desktop, when the crash occurs.

As I said, just a theory, and I don't want to point anyone in the wrong direction :)

Jeremy LaCroix (j-jlacroix) wrote :

On my end, I haven't been able to reproduce this so far with Ubuntu Appindicators disabled. It's very stable for me now. I am not 100% sure this is the fix for me, time will tell. But it's definitely more stable and possibly even fixed now.

I have tested without gnome extensions and the same happens to me.
I've also tried the theory of ekimai by switching workspaces with mouse scroll on right bottom corner, unfortunately with the same crash.

ekimai (home-ekimai) wrote :

Agreed - I've experimented using different desktop switching methods, and the only thing that seems to work is to have another window on the same desktop as the emulator, and ensure this is active prior to changing desktops. The trouble is I rarely remember to do this, so I've no way of knowing if it works 100%.

It's been so long, and so disruptive I've elected to change window managers. I'll keep an eye on this ticket though.

Sjef Bosman (sjef.bosman) wrote :

Same problem here, and I have absolutely nothing related to Android installed. When I switch workspaces, occasionally the system flashes and all screens disappear, but all workspaces are correctly displayed after 2-3 seconds. Rarely a lot more crashes and the login screen reappears.

System: Ubuntu 18.04.2 LTS with GNOME 3.28.2. I changed my workspace switching key-combination to Windows-PgUp and PgDown.

Workspace screens: 4 down, 2 wide
Active applications: Firefox, Whatsdesk, Skype, VirtualBox, Yate Client, Owncloud, Dropbox, Devilspie, Psensor and VirtualBox running Windows10.

I saved the syslog file, and if you're interested I can send it to you. No other bug info found, neither in the folders you mentioned nor on the errors.ubuntu.com website. It's funny though that the error reports on that site stop on 2019-02-03, nothing newer.

I disabled Animation, let's see if it helps.

Alec Larsen (aleclarsen42) wrote :

This problem also affects me with Zoom. I am also using a Dell Precision 5520 with Intel HD Graphics, and disabling animations in Tweaks / Appearance / Animations fixes the problem for me.

I arrived at this thread by Googling the last few frames in my coredump:

```
$ gdb /usr/bin/gnome-shell -c CoreDump
GNU gdb (Ubuntu 8.1-0ubuntu3) 8.1.0.20180409-git
Copyright (C) 2018 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/bin/gnome-shell...(no debugging symbols found)...done.
[New LWP 16771]
[New LWP 16775]
[New LWP 16782]
[New LWP 16777]
[New LWP 16785]
[New LWP 16792]
[New LWP 16784]
[New LWP 16788]
[New LWP 16776]
[New LWP 16786]
[New LWP 16793]
[New LWP 16787]
[New LWP 16790]
[New LWP 16783]
[New LWP 16791]
[New LWP 16779]
[New LWP 16789]
[New LWP 16794]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Core was generated by `/usr/bin/gnome-shell'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0 0x00007f8326767fe0 in meta_window_actor_is_destroyed () from /usr/lib/x86_64-linux-gnu/libmutter-2.so.0
[Current thread is 1 (Thread 0x7f8329125ac0 (LWP 16771))]
(gdb) backtrace
#0 0x00007f8326767fe0 in meta_window_actor_is_destroyed () at /usr/lib/x86_64-linux-gnu/libmutter-2.so.0
#1 0x00007f8322546dae in ffi_call_unix64 () at /usr/lib/x86_64-linux-gnu/libffi.so.6
#2 0x00007f832254671f in ffi_call () at /usr/lib/x86_64-linux-gnu/libffi.so.6
#3 0x00007f8327221648 in () at /usr/lib/libgjs.so.0
#4 0x00007f8327222f94 in () at /usr/lib/libgjs.so.0
#5 0x00007f831f028f6c in () at /usr/lib/x86_64-linux-gnu/libmozjs-52.so.0
#6 0x00007f831f01bed7 in () at /usr/lib/x86_64-linux-gnu/libmozjs-52.so.0
#7 0x00007f831f0287d6 in () at /usr/lib/x86_64-linux-gnu/libmozjs-52.so.0
#8 0x00007f831f028daf in () at /usr/lib/x86_64-linux-gnu/libmozjs-52.so.0
#9 0x00007f831f029089 in () at /usr/lib/x86_64-linux-gnu/libmozjs-52.so.0
#10 0x00007f831ee190c9 in () at /usr/lib/x86_64-linux-gnu/libmozjs-52.so.0
#11 0x000014a67c2ca3c6 in ()
#12 0x0000561eaa870a40 in ()
#13 0x00007ffea8948460 in ()
#14 0xfff9000000000000 in ()
#15 0x00007f83203bf8c0 in () at /usr/lib/x86_64-linux-gnu/libmozjs-52.so.0
#16 0x00007f82fc0739a0 in ()
#17 0x000014a67c49b66b in ()
#18 0x0000000000006820 in ()
#19 0x00007f82dac1bba0 in ()
#20 0x0000000000000000 in ()
(gdb)
```

I'm happy to help debugging if any other information is needed.

Dave Chiluk (chiluk) on 2019-04-12
tags: added: indeed
Sjef Bosman (sjef.bosman) wrote :

Yep, no crashes so far with Animation disabled.

Muhammad Asif (masifofficial0) wrote :

I experienced this issue as well. The scenario is same all the time.
When I'm on a Skype CALL and try to switch my workspace to the Skype workspace, it either hangs or logs me out of the system.
Please let me know if I can provide anything to help fix this bug, this is very crucial to me.

Daniel van Vugt (vanvugt) wrote :

It appears we still get crash reports for this from the latest gnome-shell version 3.28.3+git20190124-0ubuntu18.04.1

So it's interesting the bug still doesn't exist in 3.30 and later.

It's also interesting there is one crash report from version:

  https://launchpad.net/ubuntu/+source/gnome-shell/3.30.1-2ubuntu1.18.10.2

from bionic. Not from cosmic where that version was targeted. That suggests to me the problem might actually be in some other package more related to bionic than to the gnome-shell version.

Changed in gnome-shell (Ubuntu Eoan):
importance: High → Undecided
status: Confirmed → Invalid
no longer affects: gnome-shell (Ubuntu Disco)
no longer affects: gnome-shell (Ubuntu Cosmic)
no longer affects: gjs (Ubuntu Cosmic)
Changed in gjs (Ubuntu Eoan):
status: Confirmed → Invalid
importance: High → Undecided
assignee: Marco Trevisan (Treviño) (3v1n0) → nobody
no longer affects: gjs (Ubuntu Disco)
Changed in gnome-shell (Ubuntu Eoan):
assignee: Daniel van Vugt (vanvugt) → nobody
Changed in gnome-shell (Ubuntu Bionic):
status: Confirmed → In Progress
Daniel van Vugt (vanvugt) wrote :

Good news:

(1) I can finally reproduce the crash today.

(2) My original analysis failed to notice that the offending JavaScript code simply doesn't exist in Gnome Shell 3.30 and later. So that's why this bug only exists in 3.28 (Ubuntu 18.04).

Changed in gjs (Ubuntu Bionic):
status: Confirmed → Invalid
no longer affects: gjs (Ubuntu)
no longer affects: gjs (Ubuntu Bionic)
no longer affects: gjs (Ubuntu Eoan)
Daniel van Vugt (vanvugt) wrote :

Oh, actually there was a formal fix done for this exact bug upstream in the 3.30 series. We should use that:

 https://gitlab.gnome.org/GNOME/gnome-shell/issues/539

Changed in gnome-shell:
status: Unknown → Fix Released
Changed in gnome-shell (Ubuntu Eoan):
status: Invalid → Fix Released
Changed in gnome-shell (Ubuntu Cosmic):
status: New → Triaged
Changed in gnome-shell (Ubuntu Bionic):
assignee: Daniel van Vugt (vanvugt) → Marco Trevisan (Treviño) (3v1n0)

Daniel, thanks for the finding...

I've prepared a backport of this for gnome-3-28 and adding to the next bionic SRU.

Was fixed as part of 3.30.1 and so released already to cosmic as per 3.30.1-2ubuntu1.18.10.2

Changed in gnome-shell (Ubuntu Cosmic):
status: Triaged → Fix Released
description: updated
Daniel van Vugt (vanvugt) wrote :

Thanks. I was going to backport and patch it today, but having it done while I sleep is good too.

Rafael Nicolay (rrnicolay) wrote :

Hi, guys! I saw that this problem has been fixed. My system was updated today(apt-get update/upgrade), but I'm still facing the crashes. I'm not familiar with this, but how do I force an update to benefit of this fix? Sorry for this question.

Daniel van Vugt (vanvugt) wrote :

The fix is not released yet. At the top of the bug you will find "Bionic In Progress".

Changed in gnome-shell (Ubuntu Cosmic):
status: Fix Released → Invalid
Changed in gnome-shell (Ubuntu Eoan):
status: Fix Released → Invalid
Daniel van Vugt (vanvugt) wrote :

Also, since the bug was only in 3.30.0 and older (fixed in 3.30.1), that makes it Invalid for cosmic and later. Because cosmic and later never had the bug and never needed a fix.

Pedro (pedro.liao) wrote :

My ubuntu 18.04 have already been updated to the latest state!
But it still crash when I swich workspace.
Is any package I need to install to solve this bug? Or other suggestion?

Daniel van Vugt (vanvugt) wrote :

No, the fix is not yet available.

Rafael Nicolay (rrnicolay) wrote :

Thanks, Daniel! I subscribed to the bug to be notified on release.
Waiting for it. Nice work, guys!

Horváth Csongor (csongi77) wrote :

After update (Ubuntu 14.04.2 LTS; 3.28.2, GNOME 3.28.2) it works flawless!

Raphaël Droz (raphael-droz) wrote :

I'm seeing the same message `st_widget_get_theme_node called on the widget [0x559c32c8cc50 StWidget] which is not in the stage.` even updating individual gnome-shell / *gjs packages to eoan (gnome-shell 3.32.1) although it does not seem to actually crash gnome-shell but rather "reload" it (It notifies me that application is "ready"). It happens almost everytime I switch among windows, even with all extensions disabled.

Dave Chiluk (chiluk) wrote :

Enabling this plugin is the easiest way to work around this issue in bionic.
https://extensions.gnome.org/extension/1328/disable-workspace-switch-animation/

That being said what is the status of a real fix?

Daniel van Vugt (vanvugt) wrote :

The fix has "landed" in git, meaning it will be in the next 18.04 update of gnome-shell. But I don't know when that will be.

Changed in gnome-shell (Ubuntu Bionic):
status: In Progress → Fix Committed
ekimai (home-ekimai) wrote :

I can confirm - this is fixed with the latest Gnome update.

Daniel van Vugt (vanvugt) wrote :

The fix is not yet available for testing. We are glad you no longer experience the crash, but that's probably just luck.

ekimai (home-ekimai) wrote :

In my experience, there's no such thing :)

But Gnome updated this morning, so I switched window managers and it doesn't crash anymore.

Daniel van Vugt (vanvugt) wrote :

That's great news.

For everyone else though, please note gnome-shell for Ubuntu 18.04 has not been updated since 6 May. We will let you know here when a fix is available for testing.

Hello Jean-Francois, or anyone else affected,

Accepted gnome-shell into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell/3.28.4-0ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-bionic

package : gnome-shell 3.28.4
verification-done-bionic

for people want to test this package follow these steps

-add "deb http://archive.ubuntu.com/ubuntu/ bionic-proposed main" into /etc/apt/source.list file (without quotations)

-run "sudo apt-get update"

-run "sudo apt install gnome-shell

-make sure that you installed the right version by "gnome-shell --version"

Pedro (pedro.liao) wrote :

Thank you, Ahmed Mamdouh.
After your suggestion, I update gnome-shell.
Finally, it won't be crash.
I was waitting for a long time, and can not use "workspace".
Now I can use multi workspaces again.

ekimai (home-ekimai) wrote :

It would appear that something has changed in the Android emulator, and it's less likely to be the cause of the crash.

I'd expected to simply run gnome with animations turned on, run the emulator, get a crash when switching desktops. While this now seems more stable, it does occasionally crash.

I can confirm that using the above update resolves the problem. I've been using it for a couple of days without any issues.

ekimai (home-ekimai) wrote :

Thanks for your efforts :)

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.28.4-0ubuntu18.04.1

---------------
gnome-shell (3.28.4-0ubuntu18.04.1) bionic; urgency=medium

  * New upstream stable release
    - Fix ellipsization in dialog subtitles/bodies (LP: #1809788)
    - dnd: Only handle touch events in wayland (LP: #1817020)
    - windowManager: listen actively to windows being destroyed during WS switch
      (LP: #1812527)
    - Fix unresponsive-app dialog blocking input in other windows (LP: #1740869)
    - Fix regression on missing spread animation (LP: #1827284)
  * d/p/js-fix-invalid-access-errors.patch,
    d/p/js-ui-Choose-some-actors-to-cache-on-the-GPU.patch:
    - Refreshed
  * d/p/switchMonitor-switch-to-next-config-upon-initial-keypress.patch
    - Ensure switch display mode is cyclic (LP: #1772811)
  * debian/control:
    - Depends on mutter 3.28.4-0ubuntu18.04.1
  * d/p/st-widget-Add-missing-g_return_val_if_fail.patch:
    - st-widget: Protect from NULL obj in get_theme_node (LP: #1796606)

 -- Marco Trevisan (Treviño) <email address hidden> Fri, 10 May 2019 11:43:10 +0100

Changed in gnome-shell (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-shell has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.