Full screen key chorded zoom (Alt+Super+=) fails in 18.04.1/18.10

Bug #1799073 reported by Christopher Patti on 2018-10-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Undecided
Unassigned

Bug Description

Hi all. I noticed this problem when I upgraded from 18.04 to 18.04.1 (Worked perfectly in stock 18.04) and then I was testing the 18.10 beta and hoped it would be fixed there but it's not.

To reproduce: login to the regular Ubuntu desktop, hit Super+Alt+= (You can validate that your keyboard shortcut is set to the default in Settings->Keyboard.)

I also tried changing the keyboard mapping for this action in case there was a conflict, and no matter what I set it to I couldn't zoom from the keyboard.

As a partially blind user, this is a show stopper for me - I require screen zoom to be able to use Ubuntu at all for any serious work.

Thanks for everything you do!
-Chris
(Happy to try any work-arounds or testing people can think up to help fix this problem)
---
ProblemType: Bug
ApportVersion: 2.20.10-0ubuntu13
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
DisplayManager: gdm3
DistroRelease: Ubuntu 18.10
GsettingsChanges:
 b'org.gnome.shell' b'command-history' redacted by apport
 b'org.gnome.desktop.interface' b'gtk-im-module' b"'gtk-im-context-simple'"
 b'org.gnome.desktop.interface' b'text-scaling-factor' b'1.25'
InstallationDate: Installed on 2018-10-07 (14 days ago)
InstallationMedia: Ubuntu 18.10 "Cosmic Cuttlefish" - Beta amd64 (20180927)
Package: gnome-shell 3.30.1-2ubuntu1
PackageArchitecture: amd64
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Tags: cosmic
Uname: Linux 4.19.0-041900rc8-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

As a workaround, please try:

1. Settings > Universal Access > Always Show Universal Access Menu = ON

2. Now in the accessibility menu in the top panel set Zoom = ON

tags: added: cosmic
Daniel van Vugt (vanvugt) wrote :

Please also run this command to send us more information about the system:

  apport-collect 1799073

Changed in gnome-shell (Ubuntu):
status: Confirmed → Incomplete
status: Incomplete → Confirmed
Daniel van Vugt (vanvugt) wrote :

After applying the workaround in comment #2, the zoom keys seem to start working.

apport information

tags: added: apport-collected
description: updated

apport information

Christopher Patti (feoh) wrote :

That work-around works perfectly, thank you *SO* much!

FWIW I ran the apport command after applying the work-around you suggested. Let me know if there's anything else I can do to help on this one.

Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers