gnome-shell crashed with SIGSEGV in st_widget_get_theme_node() from <JavaScript>BoxPointer::_reposition()

Bug #1796606 reported by errors.ubuntu.com bug bridge on 2018-10-08
80
This bug affects 7 people
Affects Status Importance Assigned to Milestone
GNOME Shell
New
Unknown
gnome-shell (Ubuntu)
Medium
Marco Trevisan (Treviño)
Bionic
Medium
Marco Trevisan (Treviño)
Disco
Medium
Marco Trevisan (Treviño)

Bug Description

https://gitlab.gnome.org/GNOME/gnome-shell/issues/1018
https://gitlab.gnome.org/GNOME/gnome-shell/issues/804

---

[ Impact ]

 - GNOME Shell crashes in st_widget_get_theme_node

[ Test Case ]

 - No clear test case for this, monitoring errors.ubuntu.com is the only feasible solution

[ Regression Potential ]

Shell actors might have wrong theming.
The crash will be converted in error trackable through journalctl

---

The Ubuntu Error Tracker has been receiving reports about a problem regarding gnome-shell. This problem was most recently seen with package version 3.30.0-3ubuntu1, the problem page at https://errors.ubuntu.com/problem/b693e6165eedd2cd0390c2e800ccb28aaca4cd0d contains more details, including versions of packages affected, stacktrace or traceback, and individual crash reports.
If you do not have access to the Ubuntu Error Tracker and are a software developer, you can request it at http://forms.canonical.com/reports/.

Related branches

summary: - /usr/bin/gnome-
- shell:11:st_widget_get_theme_node:ffi_call_unix64:ffi_call:gjs_invoke_c_function:function_call
+ gnome-shell crashed with SIGSEGV in st_widget_get_theme_node →
+ ffi_call_unix64 → ffi_call → gjs_invoke_c_function → function_call

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed

Anyone affected, please share your

journalctl /usr/bin/gnome-shell -b

Managed to reproduce the crash by launching gnome-tweaks.
Here is the log from just before the crash to after logging back in.

Download full text (3.2 KiB)

Great, thanks for this.
Can you reproduce this repeatedly? If so, you've also a /var/crash file for this?

at least now we know where it crashes :)

spal. 22 17:57:57 grr gnome-shell[20099]: Object Shell.GenericContainer (0x563876a896d0), has been already deallocated — impossible to get any property from it. This might be caused by the object having been destroyed from C code using something such as destroy(), dispose(), or remove() vfuncs.
spal. 22 17:57:57 grr gnome-shell[20099]: Object Shell.GenericContainer (0x563876a896d0), has been already deallocated — impossible to access it. This might be caused by the object having been destroyed from C code using something such as destroy(), dispose(), or remove() vfuncs.
spal. 22 17:57:57 grr org.gnome.Shell.desktop[20099]: == Stack trace for context 0x5638745012a0 ==
spal. 22 17:57:57 grr org.gnome.Shell.desktop[20099]: #0 56387a1040b0 i resource:///org/gnome/shell/ui/boxpointer.js:234 (7fc34a71a940 @ 574)
spal. 22 17:57:57 grr org.gnome.Shell.desktop[20099]: #1 7fff5ce00020 b resource:///org/gnome/gjs/modules/_legacy.js:82 (7fc34aab0b80 @ 71)
spal. 22 17:57:57 grr org.gnome.Shell.desktop[20099]: #2 7fff5ce00100 b self-hosted:981 (7fc34aaf01f0 @ 474)
spal. 22 17:57:57 grr org.gnome.Shell.desktop[20099]: #3 7fff5ce01b80 b resource:///org/gnome/shell/ui/layout.js:211 (7fc34a701790 @ 62)
spal. 22 17:57:57 grr org.gnome.Shell.desktop[20099]: == Stack trace for context 0x5638745012a0 ==
spal. 22 17:57:57 grr org.gnome.Shell.desktop[20099]: #0 56387a104170 i resource:///org/gnome/shell/ui/boxpointer.js:448 (7fc34a71ab80 @ 179)
spal. 22 17:57:57 grr org.gnome.Shell.desktop[20099]: #1 7fff5cdff090 b resource:///org/gnome/gjs/modules/_legacy.js:82 (7fc34aab0b80 @ 71)
spal. 22 17:57:57 grr org.gnome.Shell.desktop[20099]: #2 56387a1040b0 i resource:///org/gnome/shell/ui/boxpointer.js:235 (7fc34a71a940 @ 597)
spal. 22 17:57:57 grr org.gnome.Shell.desktop[20099]: #3 7fff5ce00020 b resource:///org/gnome/gjs/modules/_legacy.js:82 (7fc34aab0b80 @ 71)
spal. 22 17:57:57 grr org.gnome.Shell.desktop[20099]: #4 7fff5ce00100 b self-hosted:981 (7fc34aaf01f0 @ 474)
spal. 22 17:57:57 grr org.gnome.Shell.desktop[20099]: #5 7fff5ce01b80 b resource:///org/gnome/shell/ui/layout.js:211 (7fc34a701790 @ 62)
spal. 22 17:57:57 grr org.gnome.Shell.desktop[20099]: GNOME Shell crashed with signal 11
spal. 22 17:57:57 grr org.gnome.Shell.desktop[20099]: == Stack trace for context 0x5638745012a0 ==
spal. 22 17:57:57 grr org.gnome.Shell.desktop[20099]: #0 56387a104170 i resource:///org/gnome/shell/ui/boxpointer.js:448 (7fc34a71ab80 @ 179)
spal. 22 17:57:57 grr org.gnome.Shell.desktop[20099]: #1 7fff5cdff090 b resource:///org/gnome/gjs/modules/_legacy.js:82 (7fc34aab0b80 @ 71)
spal. 22 17:57:57 grr org.gnome.Shell.desktop[20099]: #2 56387a1040b0 i resource:///org/gnome/shell/ui/boxpointer.js:235 (7fc34a71a940 @ 597)
spal. 22 17:57:57 grr org.gnome.Shell.desktop[20099]: #3 7fff5ce00020 b resource:///org/gnome/gjs/modules/_legacy.js:82 (7fc34aab0b80 @ 71)
spal. 22 17:57:57 grr org.gnome.Shell.desktop[20099]: #4 7fff5ce00100 b self-hosted:981 (7fc34aaf01f0 @ 474)
spal. 22 17:5...

Read more...

I cannot reproduce it repeatedly. Currently gnome-tweaks opens without crashing gnome-shell.

Russell Neches (ubuntu-vort) wrote :

When I first started getting these crashes, they were triggered by attaching an external monitor, but that problem seems to have been fixed. Now, I am getting crashes when I put my laptop to sleep and then wake it up. It also destroys screen and tmux sessions somehow, so these crashes have about the same effect on the user as a kernel panic. Yet another way that systemd is broken, I guess?

There was a [similar bug](https://bbs.archlinux.org/viewtopic.php?id=224570) reported on Arch Linux, where the redshift extension was blamed as the culprit (though no explanation was given about his this was determined or what the mechanism might be.

I'm going to try disabling Night Mode.

Chris Rogers (settonull) wrote :

This (gnome-shell seg fault) happens to me every few times I close and reopen my laptop (though not every time). I've uploaded them almost every time, no idea how to link it to this (or any other) bug report.

https://errors.ubuntu.com/user/4594f62062058db851ff674f534862397e01aff99cc3bd84bf1015db3caa0b25927c8496a9181576609876d3f4807d122cf432748f94e6525c39ace3fb3b4352

Chris,

Do you have a journalctl error when this is happening?

tags: added: fixed-3.32.1 fixed-upstream
tags: added: rls-dd-incoming
Daniel van Vugt (vanvugt) wrote :

Are you sure it's "fixed-upstream"? Both the upstream bugs in comment #10 are still open.

Daniel, while the fix¹ didn't landed yet it will land on 3.32.1².

[1] TBH this isn't really a fix for the problem itself but at least in ubuntu where we
    compile without `G_DISABLE_CHECKS` will mute the crash, making things for us at least
    good enough to close this.
[2] https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/438

Will Cooke (willcooke) on 2019-03-12
Changed in gnome-shell (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
tags: removed: rls-dd-incoming
Changed in gnome-shell (Ubuntu Bionic):
status: New → Triaged
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)

This has been fixed for disco in gnome-shell 3.32.0-1ubuntu1

Changed in gnome-shell (Ubuntu Disco):
status: Confirmed → Fix Released
Changed in gnome-shell (Ubuntu Bionic):
status: Triaged → In Progress
Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
Changed in gnome-shell (Ubuntu Bionic):
importance: Undecided → Medium
Changed in gnome-shell (Ubuntu Disco):
importance: Undecided → Medium
description: updated
Changed in gnome-shell:
status: Unknown → New
tags: added: disco
summary: - gnome-shell crashed with SIGSEGV in st_widget_get_theme_node →
- ffi_call_unix64 → ffi_call → gjs_invoke_c_function → function_call
+ gnome-shell crashed with SIGSEGV in st_widget_get_theme_node() from
+ BoxPointer::_reposition()
summary: gnome-shell crashed with SIGSEGV in st_widget_get_theme_node() from
- BoxPointer::_reposition()
+ <JavaScript>BoxPointer::_reposition()
description: updated

Hello errors.ubuntu.com, or anyone else affected,

Accepted gnome-shell into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell/3.28.4-0ubuntu18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-shell (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic

No errors.ubuntu.com report for 3.28.4 and 3.32.0 (where the same patch is applied), plus this fix is part of the upstream release, and so marking as verified as per the GNOME SRU release exception.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.28.4-0ubuntu18.04.1

---------------
gnome-shell (3.28.4-0ubuntu18.04.1) bionic; urgency=medium

  * New upstream stable release
    - Fix ellipsization in dialog subtitles/bodies (LP: #1809788)
    - dnd: Only handle touch events in wayland (LP: #1817020)
    - windowManager: listen actively to windows being destroyed during WS switch
      (LP: #1812527)
    - Fix unresponsive-app dialog blocking input in other windows (LP: #1740869)
    - Fix regression on missing spread animation (LP: #1827284)
  * d/p/js-fix-invalid-access-errors.patch,
    d/p/js-ui-Choose-some-actors-to-cache-on-the-GPU.patch:
    - Refreshed
  * d/p/switchMonitor-switch-to-next-config-upon-initial-keypress.patch
    - Ensure switch display mode is cyclic (LP: #1772811)
  * debian/control:
    - Depends on mutter 3.28.4-0ubuntu18.04.1
  * d/p/st-widget-Add-missing-g_return_val_if_fail.patch:
    - st-widget: Protect from NULL obj in get_theme_node (LP: #1796606)

 -- Marco Trevisan (Treviño) <email address hidden> Fri, 10 May 2019 11:43:10 +0100

Changed in gnome-shell (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-shell has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.