Natural scrolling is only applied to the vertical axis

Bug #1785600 reported by Vincent on 2018-08-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Undecided
Unassigned

Bug Description

(Apologies if this is the wrong place to report this - I tried to find the right place but the Ask Ubuntu people were not that helpful unfortunately. [1])

I've turned on Natural Scrolling for my touchpad. This works fine vertically: when I move my fingers up, the content scrolls down, and vice versa. However, when I move my fingers right, the content also moves right. I would expect it to move left with Natural Scrolling turned on.

[1] https://askubuntu.com/questions/1062559/where-do-i-report-a-bug-about-touchpad-behaviour?noredirect=1

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: gnome-shell 3.28.2-0ubuntu0.18.04.1
ProcVersionSignature: Ubuntu 4.15.0-29.31-generic 4.15.18
Uname: Linux 4.15.0-29-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
CurrentDesktop: communitheme:ubuntu:GNOME
Date: Mon Aug 6 12:46:25 2018
DisplayManager: gdm3
InstallationDate: Installed on 2017-07-13 (388 days ago)
InstallationMedia: Ubuntu-GNOME 16.04.2 LTS "Xenial Xerus" - Release amd64 (20170215)
SourcePackage: gnome-shell
UpgradeStatus: Upgraded to bionic on 2018-07-28 (8 days ago)

Vincent (vinnl) wrote :
Daniel van Vugt (vanvugt) wrote :

I've just tested this in 18.10 (Firefox) and natural scrolling is correctly applied to both vertical and horizontal movement.

Also, I think your statements are confused:

 * "when I move my fingers up, the content scrolls down". Yes, we call that scrolling "down" (the viewport) so the content is moving "up" which is the same direction as your fingers.

 * "when I move my fingers right, the content also moves right. I would expect it to move left with Natural Scrolling turned on." Yes, correct behaviour with natural scrolling when moving your fingers right is for the content to move right (and the scrollbar/viewport moves left).

"Natural scrolling" means the page is virtually stuck to your fingers, so the scroll direction will always be the opposite direction to your finger movement.

So it seems like everything is working. Is there a particular app you find isn't working?

Changed in gnome-shell (Ubuntu):
status: New → Incomplete
Vincent (vinnl) wrote :

@vanvugt Aaargh OK, on the one hand I knew that, on the other hand apparently my intuition is completely messed up. I don't know why that is, anyway, it seems to indeed work as intended. Sorry for bothering you.

Changed in gnome-shell (Ubuntu):
status: Incomplete → Invalid
Daniel van Vugt (vanvugt) wrote :

No problem. I actually assumed it was still broken at first, since it used to be. But it was a pleasant surprise to find fully working.

Vincent (vinnl) wrote :

@vanvugt Hmm OK, now I'm starting to doubt myself again. It might still be messed up, but when I move my fingers right, that means that content to the left of the view should move to the right, correct? And the scrollbar should move to the left? Because that's not happening, I think.

I've attached a short screencast, which shows gedit with content wider than the viewport. I move my fingers to the right on the touchpad, with natural scrolling turned on. Nevertheless, content that's currently to the right of the viewport scrolls into view, i.e. to the left.

Sorry if I'm getting it wrong again, I'm really confused right now :S

Changed in gnome-shell (Ubuntu):
status: Invalid → New
Daniel van Vugt (vanvugt) wrote :

Please also try some other apps (like Firefox), and list all those affected by the problem.

So far we only have 'gedit'.

Changed in gnome-shell (Ubuntu):
status: New → Incomplete
Vincent (vinnl) wrote :

I couldn't think of too many applications in which I could trigger horizontal scrolling, but at least I've tried some different toolkits:

- Gimp
- Inkscape
- Firefox
- VSCode
- LibreOffice Writer

Changed in gnome-shell (Ubuntu):
status: Incomplete → New
Vincent (vinnl) wrote :
Vincent (vinnl) wrote :
Vincent (vinnl) wrote :
Vincent (vinnl) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Rasmus Malver (rasmusmalver) wrote :

It can be fixed following the instructions in this answer:
https://askubuntu.com/questions/1029128/inverted-horizontal-scrolling-ubuntu-18-04#answer-1031657

I've had the problem before. It seems like a weird why-bother-choice by the community / Canonical.

summary: - Natural scrolling is only applied in one direction (vertical)
+ Natural scrolling is only applied to the vertical axis
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers