Keeping Alt+Space pressed shows the window menu and then minimizes the window

Bug #1784671 reported by Andrea Azzarone on 2018-07-31
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Low
Andrea Azzarone
Bionic
Undecided
Marco Trevisan (Treviño)

Bug Description

[ Description ]

Pressing Alt+Space and keeping it pressed causes a window to be minimized

[ Test case ]

1. Press Alt+Space and keep it pressed
2. The menu should stay open without any action being performed automatically

[ Regression potential ]

Key-actions happening with popups open when keybindings use modifiers might be broken afterwards. No case that I know.

---

To reproduce:

Open a couple of windows
Press Alt+Space and keep it pressed

Expected results:

The window menu opens and nothing else happens

Current behavior:

The window menu opens
The window is minimized
The window menu of the following window is open
The window is minized

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Changed in gnome-shell (Ubuntu):
importance: Undecided → Low
tags: added: cosmic
tags: added: bionic
Iain Lane (laney) wrote :

Thanks!

Marco or Andrea: Please could you make this bug SRU compliant since it's included in ubuntu/bionic?

Changed in gnome-shell (Ubuntu Bionic):
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
description: updated
description: updated

Hello Andrea, or anyone else affected,

Accepted gnome-shell into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell/3.28.3-0ubuntu0.18.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-shell (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Daniel van Vugt (vanvugt) wrote :

Did a fix for cosmic land yet? It's unclear...

Indeed, that was fixed in gnome-shell 3.29.4 while in cosmic we've 3.29.90

Changed in gnome-shell (Ubuntu):
status: Confirmed → Fix Released
assignee: nobody → Andrea Azzarone (azzar1)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers