Upgrade to 3.28.3 and SRU it

Bug #1782614 reported by Marco Trevisan (Treviño) on 2018-07-19
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Medium
Marco Trevisan (Treviño)
Bionic
Undecided
Marco Trevisan (Treviño)

Bug Description

[ Description ]

The third stable release in the 3.28 series.

[ QA ]

Run Ubuntu session, expect the shell to work normally with various setups

https://wiki.ubuntu.com/StableReleaseUpdates/GNOME

[ Regresison potential ]

Many patches we were including already have been fixed, VPN fixes so network related featurs should be checked more

Iain Lane (laney) on 2018-07-24
Changed in gnome-shell (Ubuntu):
status: In Progress → Fix Committed
Changed in gnome-shell (Ubuntu Bionic):
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)

Fixed in:

gnome-shell (3.28.3-0ubuntu1) cosmic; urgency=medium

  * debian/patches/30-remoteMenu-Prevent-the-shell-from-becoming-unrespons.patch,
    debian/patches/magnifier.js-Fix-zoom-juddering.patch,
    debian/patches/st-label-Unset-clutter-text-instance-on-disposal.patch,
    debian/patches/st-texture-cache-Don-t-add-NULL-textures-to-cache.patch,
    debian/patches/st-texture-cache-Save-cairo-surfaces-to-a-different-map.patch,
    debian/patches/ui-Theme-lookup-should-respect-XDG_DATA_DIRS.patch:
    - Drop patches applied on the 3.28 branch
  * debian/patches/js-fix-invalid-access-errors.patch:
    - Refreshed to reflect upstream changes

Changed in gnome-shell (Ubuntu):
status: Fix Committed → Fix Released
Robie Basak (racb) wrote :

For Bionic:

Shouldn't this be 3.28.3-0ubuntu0.18.04.1 directly, rather than 3.28.3-0ubuntu0.18.04.1 then 3.28.3-0ubuntu0.18.04.2?

Missing Launchpad-Bugs-Fixed field in changes file. Did you use Ubuntu or set vendor to Ubuntu if on Debian? Please re-upload with that.

Bugs like bug 1783363 appear to be missing SRU paperwork. Please fix (or tell me why not necessary) before re-uploading.

Doesn't debian/patches/workspace-fix-repositioned-windows-in-activities.patch need a bug and SRU paperwork? AIUI, GNOME packages in Ubuntu have an exception for upstream microreleases (as QA'd by upstream) and not for cherry-picks.

Robie,

Yes, I'd go directly with 3.28.3-0ubuntu0.18.04.2, actually we've also a .3 ready, so probably we could go with that too.

Bug #1783363 never hit bionic, the fix was just applied to cosmic, so no need to SRU it.

debian/patches/workspace-fix-repositioned-windows-in-activities.patch was already present in ubuntu, we just refreshed it with some minor changes as per upstream review. But nothing changed in behavior.

Iain Lane (laney) wrote :

I had tagged .1 - in error since it wasn't accepted - when uploading it, so it was easier on our side to upload a new revision with -v.

I guess you would prefer us to remove references to bugs that aren't directly being SRUed. In this case it was a change between .1 and .2 so I left it in. The bug is not nominated, which I intended to be an indication of its status. I've done that before with other SRUs without any problems, but if it is an issue then I will remove it when re-uploading.

Sorry about the LP-Bugs-Fixed. I uploaded from a Debian packaging directory on Ubuntu and I'd set DEB_VENDOR=Debian.

I'll take a look at the 3.28.3 proposal and probably upload that.

Iain Lane (laney) wrote :

Uploaded again, thanks Marco and Robie. This time I removed the confusing bug reference and compressed the changelog entries into one. The version is ...18.04.2 even though this is the first release of this upstream release to bionic, because of the aforementioned tagging error.

Hello Marco, or anyone else affected,

Accepted gnome-shell into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-shell/3.28.3-0ubuntu0.18.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-shell (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic

Fixed in gnome-shell 3.28.3-0ubuntu0.18.04.2

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic

The verification of the Stable Release Update for gnome-shell has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.28.3-0ubuntu0.18.04.2

---------------
gnome-shell (3.28.3-0ubuntu0.18.04.2) bionic; urgency=medium

  * New upstream release (LP: #1718931, LP: #1782614)
  * debian/patches/30-remoteMenu-Prevent-the-shell-from-becoming-unrespons.patch,
    debian/patches/magnifier.js-Fix-zoom-juddering.patch,
    debian/patches/st-label-Unset-clutter-text-instance-on-disposal.patch,
    debian/patches/st-texture-cache-Don-t-add-NULL-textures-to-cache.patch,
    debian/patches/st-texture-cache-Save-cairo-surfaces-to-a-different-map.patch,
    debian/patches/ui-Theme-lookup-should-respect-XDG_DATA_DIRS.patch:
    - Drop patches applied on the 3.28 branch
  * debian/patches/js-fix-invalid-access-errors.patch:
    - Refreshed to reflect upstream changes
  * d/p/popupMenu-Don-t-handle-key-presses-directly-if-there-are-.patch
    - Don't handle key presses directly if there are modifiers (LP: #1784671)
  * debian/patches/workspace-fix-repositioned-windows-in-activities.patch:
    - Cherry-pick from upstream 3.28 branch

 -- Marco Trevisan (Treviño) <email address hidden> Fri, 03 Aug 2018 07:18:24 +0100

Changed in gnome-shell (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers